Release SuperZaxxon Final released!

Discussion in 'Software Releases' started by EvilDragon, Jun 28, 2012.

  1. Spectralist

    Spectralist Still Fresh

    Joined:
    Nov 14, 2007
    Messages:
    68
    Newest fix didn't do anything for me as far as I can tell. I decided to do some more thorough tests to see if I could find any useful data.


    For clarity the nub problem I'm having is the left nub simply doesnt work, no response in the input tester no mouse movement, etc. Right nub works fine though. But rebooting into 2.6 fixes the left and the fix remains after booting back into 3.2. In 2.6 both nubs always seem to work.


    I've reflashed straight to the release of SuperZaxxon Final and went through all the patches posted with 8 different tests. To see if there's any illuminating differences. The only difference I found is that in uImage_sz_nub_test and the two after it suspend doesnt kill my nub while it does on the original SuperZaxxon Final release.


    For completions sake here's a summary of all the tests I ran:



    Code:
    Boot into 3.2 from power off when 3.2 was previously run without fixing nub by restarting with 2.6:
    
    	All 4 Tests - Left nub no response
    
    Boot into 3.2 from power off when 2.6 was previously run:
    
    	All 4 Tests- Left nub works
    
    Boot into 3.2 from power off when 3.2 was previously run after fixing nub by restarting with 2.6:
    
    	All 4 Tests - Left nub no response
    
    
    Restart into 3.2 without powering off when 3.2 was previously run without fixing nub:
    
    	All 4 Tests - Left nub no response
    
    Restart into 3.2 without powering off when 2.6 was previously run:
    
    	All 4 Tests- Left nub works
    
    Restart into 3.2 without powering off when 3.2 was previously run after fixing nub by restarting with 2.6:
    
    	All 4 Tests- Left nub works
    
    
    Enter/exit suspend mode in 3.2 after fixing nub by restarting with 2.6:
    
    	SuperZaxxon Final - Left nub no response
    
    	uImage_sz_nub_test - Left nub works
    
    	uImage_sz_nub_test2 - Left nub works
    
    	uImage_sz_nub_test3 - Left nub works
    
    Enter/exit suspend in 3.2 with out fixing nub by restarting with 2.6:
    
    	All 4 Tests - Left nub no response

    Hopefully that's in some way helpful. I mostly did it because I noticed in uImage_sz_nub_test3 that powering off completely from 2.6 then powering on fixed the nub until the next power off but I'd never tried that before and wondered if it happened in one of the patches or was there from the start, apparently it was like that from the start. Seems really weird.
     
  2. notaz

    notaz Certified Guru

    Joined:
    Aug 23, 2005
    Messages:
    4,913
    Location:
    Lithuania
    That's some messed up stuff, how is it doing if you take out battery for 10minutes, reinsert and boot straight to 3.2 nub_test3?
     
  3. porg

    porg Active Member

    Joined:
    Feb 26, 2010
    Messages:
    772
    Location:
    Vienna, Austria
    My problems regarding charging were improved after the battery removal/pause/reinsertion procedure.


    Can only recommend this to everyone!


    Not much effort (only date/time needs to be set again), but a potentially large effect.
     
    Last edited by a moderator: Jul 20, 2012
  4. notaz

    notaz Certified Guru

    Joined:
    Aug 23, 2005
    Messages:
    4,913
    Location:
    Lithuania
  5. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
    Test4 is working fine.


    I didn't have the little desktop bug when AC connected.
     
  6. st0kes

    st0kes Still Fresh

    Joined:
    Sep 30, 2008
    Messages:
    10
    Hi, has someone just updated the installer without updating the checksum? Some of the files in the zip are dated 09:36 yesterday, and when I try and flash I'm getting an incorrect checksum "Update Failed" message.


    I have tried several SD cards previously known to work, and I have downloaded the update 3 times from 2 links, flashed 3 times and got the same message.


    Checksums mismatch is:


    2180aa90d82992ff52339fe9d9711205


    vs


    fb136149154683fa0a5e6cd78d77e881


    Thanks for any advice.
     
  7. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
    Indeed, seems the rootfs image was updated.

    Might be the Notaz kernel update ?
     
  8. notaz

    notaz Certified Guru

    Joined:
    Aug 23, 2005
    Messages:
    4,913
    Location:
    Lithuania
    Hmh ED asked yesterday if I've finished dealing with nub issue, I did not answer in time that I'm not (we're still testing here). It seems he rushed the update before his holidays, so this download will be broken for a week now :(
     
  9. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
    I can push the final-final on my server.
     
  10. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
  11. fusion_power

    fusion_power Advanced Member

    Joined:
    Dec 11, 2006
    Messages:
    7,048
    Location:
    germany
    Uh oh, emergency, I guess I have killed minimenu. I just wanted to test some of the included skins, now it just doesn't work annymore. I guess it showed me an old skin that was not installed anymore on the Pandora. Actualy impossible after complete reflash. Where please is the config located so I can set the skin back to default?


    And why does it show non existing or faulty skins in the options that lead to a permanent reload loop of Minimenu? I hope this is not a serious bug. SOme warnings would be nice if a skin doesn't work correctly or the good old 15 seconds dialouge that auto resets skin when not confirm.


    I don't want to reflash so I hope I can fix MiniMenu per config, I just have not found the right one yet.
     
  12. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
    Maybe /etc/pandora/conf/mmenu.conf ?


    There's also /etc/pandora/mmenu


    Take also a look at .* in your home folder.
     
  13. fusion_power

    fusion_power Advanced Member

    Joined:
    Dec 11, 2006
    Messages:
    7,048
    Location:
    germany
    Thx, found it and solved it. BUT MMenu again makes trouble, SERIOUS trouble. Hiding apps also can lead into infinite loop forever, not sure when, maybe when app is part of 1 PND or you hide the app that was selected last. I don't want to test anymore since my system becomes broken even more and more through al the resets. :(


    Please help again, my XFCE menu bar now looks messed up, not sure what happens but icons are back to default, thunar launcher is empty, clock is gone....


    You better never mess around with MiniMenu settings, seems it can break your entire OS, dangerous.


    How can I get back the standard XFCE menu bar? Seriously, Linux scares me sometimes pretty hard.
     
  14. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
    ^^ Relax.


    If you want to reset all Xfce parameters, boot into CLI mode, log in then then remove the .config/xfce4 folder:



    Code:
    
    rm -rf .config/xfce4
    
    
    Then



    Code:
    sudo reboot
     
  15. Tom`

    Tom` Very Active Member

    Joined:
    Apr 22, 2008
    Messages:
    1,168
  16. NoeleyC

    NoeleyC Well-Known Member

    Joined:
    Oct 23, 2008
    Messages:
    1,348
    Seems to work great for me too!


    (null)
     
  17. porg

    porg Active Member

    Joined:
    Feb 26, 2010
    Messages:
    772
    Location:
    Vienna, Austria
    Another MiniMenu bug also re-appeared in SuperZaxxon Final:


    If you remove a SD card, MiniMenu scans forever (in an infinite loop), thus gets unresponsive.


    As soon as you re-enter the SD-card MiniMenu recovers.


    Removing and reinserting works fine in XFCE, no such troubles.


    So I guess the bug is rooted not within libpnd but MiniMenu.
     
  18. fusion_power

    fusion_power Advanced Member

    Joined:
    Dec 11, 2006
    Messages:
    7,048
    Location:
    germany
    I never relax when things go wrong, I'm an emotional man... :D


    And it was 4 'o clock in the morning, I just wanted a qucik test and everything went wrong. I never should touch the Pandora before going to bed. ^^


    "CLI" Mode? No clue. I just tried to recover all the elements per hand and set everything so far I could. Took 20 minutes which is ways to long. It would be better to find ways to lock the xfce settings and prevent them to change of their own mood. Seems quite instable, these XFCE elements. I'm not even sure why this happend since I just have trouble with MiniMenu. I can't remember I moved the mouse cursor to early during booting up XFCE, maybe this is enough to drive the Desktop crazy.


    However, the MiniMenu issue stays. To be more precise, I was going to hide some of the many Games from the Gnomegames Compilation, worked so far but "Quadrapuzzle" caused the instant MiniMenu suicide. It had it's own cathegory, maybe this causes trouble when hiding such programms and they are also marked as "last used app". I edited the config file and could reactivate MiniMenu but the issue remains. I guess this can be reproduced.


    ...I really didn't want to find bugs, I did not even searched for. I'm always that "lucky". :D
     
  19. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,194
    CLI is Command Line.


    Hold R while powering on the OP.
     
  20. fusion_power

    fusion_power Advanced Member

    Joined:
    Dec 11, 2006
    Messages:
    7,048
    Location:
    germany
    Ah, thanks. I've should have known this since I already booted this way. ^^


    Deleting the file with sudo from within the XFCE or MiniMenu doesn't work I guess then?


    However, I think I'm close to the original menu bar. I dropped orage and just used the clock, tooltip mouseover doesn#t seem to work for displaying date, even if it's activated but besides this, Menu bar works fine. :)


    Now I carefully look what else are the issues with Minimenu. There seems a good bunch of this.
     

Share This Page

Loading...