Slackware for Pandora 14.0

When we can get it for Pandora I'll aslo test it.

Have one of your first slackware versions already tested and run out of thime then to update.

14 is definitly on my to do list.
Downloading it right now from the wiki. I'll load it tomorrow & see how it goes. I'll report back! Thanks for this.
Last edited by a moderator:
I installed Slackware 14.0 this morning. Have only had a little time to mess around with it, but I have to say that I'm very impressed. I'm a linux novice since I've only used Angstrom & Ubuntu (and know almost no command line). I immediately felt comfortable with this OS. The integration with the PNDs is amazing. With the info on the wiki, I was able to build my own install packages using slackbuilds in no time (well, it does take the Pandora quite a long time to build the packages).

I'm going to be spending quite a bit of time with this. I'll report back in a day or two.

Thanks again for this.

i bet you written it often but can you shortly explain again how to install your Slackware on SD,i want to try it to ;)

Or a Link with a Howto ^_^
Last edited by a moderator:
Hi sorry for doubleposting :rolleyes:

I have Slackware on my Pandora and many works fine,good work.

The Nubs arent work correctly under this System here by me (Slackware14 RC1)

Have you it based on the Kernel from Zaxxon 1.5 Final from Mainsite?

With this Version was Problems that some Pandoras didnt get enough Power for the Nubs sometimes.

Here is a new Version who is the Voltage Management corrected:


I think that can be the Problem then under this Firmware works my Nubs correct ander under Zaxxon 1.5 Final have they

the same Error like your actual Release Candidat.

and i have Errors mounting my Fat32 usb Sticks with Qemu Images,it says:

Adding read ACL for uid 0 to /run/media/root failed

Operation not supported

Have you no fat32 support?

Impressive work,wow. I like Slackware and i want to try Qemu oder newer Qemu Versions in the Future on your System ;)

Maybe i make some Videos for Youtube with your System ^_^
Last edited by a moderator:
Yup, it's the 1.51's kernel. Nubs works fine here. I suppose you tried to reset ?

About mounting:
The community-driven package manager is now sync'd with the 14.0 release.

I'm now going for a one week compilation marathon :^).
I've been really enjoying Slackware! It's amazing having a full OS on my Pandora. Multitasking has been great and Firefox seems to be much more stable & responsive than in Angstrom on the Pandora.

I do have two questions:

1. I can't get my SD card in the second slot (the one on the left) to open. I followed the wiki where it said to take it out and then put it back in again, but when I do this and try and open the card in the file manager, I get this error: "Failed to mount "name of SD card". Adding read ACL for uid 1000 to 'run/media/me failed: Operation not supported." I tried this with both a FAT32 & EXT 2 formatted SD card.

I saw on the first page that you can change custom kernel or manually mount the SD card. Can you give me newbie instructions on how to manually mount it?

2. How do I run PNDs in Slackware? I've just been running them directly from a folder with the "Run PND Application." Is there an easier way?

Once again, thank you!
Last edited by a moderator:
See this post for automounting.

Pnds worked fine in 13.37, and now there's something wrong i didn't figured out for now.

Once you rebooted on the new kernel, mount the sd cards, then:


killall pndnotifyd

pndnotifyd -d 3

That did the trick! Thank you for the quick response. You really have taken the Pandora to the next level with this.
Thx ^^.

But there's still some bugs to clear for the 14.0 to be perfect.

I can't debug for now, as my only OP is compiling a big bunch of programs.

By the way i flagged all those compilations with Pandora-optimized settings.
Hi Linux-SWAT,

finally I took the time to read the main SL4P Wikipedia article. Great work, really! I'll give SL4P another try, this time following your instructions. :p Maybe this will avoid some problems I had before.

You might want to change two lines in that article for better understanding (I hope I understood them correctly ;-)

In some builds, i ship KDE. 256M users, avoid selecting it as full desktop.


In some builds, i ship KDE. users of 256MB-Pandoras, avoid selecting it as full desktop.

Due to 3.2 kernel and dynamically linked libraries, all .pnd are not compatible.


Due to 3.2 kernel and dynamically linked libraries, not all .pnd are compatible.

Now I'll read all those advanced-usage articles.

Many thanks for all that work. I guess, Slackware will be my OS choice in future, and I hope I'll be able to help with bugfixing and development, at least a bit.

By the way: Is anyone free to edit / add info in this Wiki article and those advanced-usage articles?

Is this the correct current rootfs image?

The link to "-current" in your article leads to a diretory with only subdirectories, not with an actual image. That confused me a bit. Following the subdirectories, I got to the image referenced above...

I edited the wiki. Thx for suggestions.

I removed the -current branch, as it's now released as 14.0, release candidate until i clear out the remaining bugs.

Get it here:


The remaining -current rootfs is a PXE server prototype. You can boot a x86 computer over the network with it.
Last edited by a moderator:

Question remains: Is anyone welcome to edit your SL4P articles, or are you the only maintainer?

I mean, if I use SL4P on a daily basis, I may discover things I'd like to document. If these are new topics, I will create new pages for it and may add links to your main page. But if if it's part of a topic you documented already, I may simply add the info to your page.

As you wish. Any help is welcome.

Yes i'm the sole maintainer.

I used "I" in the wiki because i put a lot of work in SL4P, and i felt natural and serious to do like this.