Release Xash3D - Half Life

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,467
Age
47
Location
France, near Lyon
Using the hacked SDL2 that support Nub as Joystick, here is a version where the Left nub is usable to move.

You may need to activate Joystick support, by editing your valve/config.cfg and change joystick "0" to "1"

Build 06
-----------


  • Added support for Nub as Joystick
  • Left nub to move now (you may need to enable joystick in valva/config.cfg)
 
Last edited by a moderator:

___

Advanced Member
Joined
Jan 31, 2006
Messages
3,373
plausible and more than likely. i will investigate.
I have the same issue and it always happens when my wifi reconnects. I overcame the issue by doing alt-tab and switching back into the game. I'd rather know how to make the game true fullscreen.
 

ZXDunny

Deep avatar
Joined
Oct 12, 2010
Messages
2,552
Using the recommended (CC) driver, I'm getting lots of diagonal corruption on the textures. Is this normal? I don't see any difference when I use any of the other drivers.

Also framerate (CC clocked at 900MHz) seems to be around 3 to 10 FPS.

D.
 

Farox

Certified Guru
Joined
Jan 8, 2009
Messages
2,065
Age
51
Location
Italy
Website
rbnet.it
Also framerate (CC clocked at 900MHz) seems to be around 3 to 10 FPS.
Not for me...

I have tried with recommended and default (CC) drivers and fps is min 13-15 @800Mhz, the only problem i have that after some die and reload, the game exit to desktop (usually after 3 times i reload a save) i also tried with a swapfile (256MB) but the behaviour is the same.

I have to test with latest build (06) but i think is the same, also the same is for the old versions (but the latter revisions of the engine work better IMHO)
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,467
Age
47
Location
France, near Lyon
Using the recommended (CC) driver, I'm getting lots of diagonal corruption on the textures. Is this normal? I don't see any difference when I use any of the other drivers.


Also framerate (CC clocked at 900MHz) seems to be around 3 to 10 FPS.


D.
Go to the options to enable fps. On a CC clocked @800Mhz, I'm getting much more than that (more than 10fps anyway), it's odd (using 4.00 driver).

The diagonal corruption, I think it's "normal", it's some limitation on the SGX driver.

Also framerate (CC clocked at 900MHz) seems to be around 3 to 10 FPS.
Not for me...

I have tried with recommended and default (CC) drivers and fps is min 13-15 @800Mhz, the only problem i have that after some die and reload, the game exit to desktop (usually after 3 times i reload a save) i also tried with a swapfile (256MB) but the behaviour is the same.

I have to test with latest build (06) but i think is the same, also the same is for the old versions (but the latter revisions of the engine work better IMHO)
I'm trying to fix that quick-reload issue. I have made a beta of Halflife uplink, if it's ok, I'll update this pnd too.
 
Last edited by a moderator:

ZXDunny

Deep avatar
Joined
Oct 12, 2010
Messages
2,552
Yeah, I'm on the v3 SGX driver you recommended - and I see exactly as on PandoraLive - mismatched u/v for textures that are close to you, notably on the train. Framerate is quite poor though, ranging from 2 or 3 fps in large areas to up to 50fps in closed-in areas, according to the game's fpx counter.

D.
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,467
Age
47
Location
France, near Lyon
The mismatched u/v texture, I cannot fix that (for now), and all driver display the same corruption.

But, 2-3 fps? I don't have that (on my CC). There is something strange with your Pandora. Are you sure the CPU speed is correct?
 

Eversmile

Still Fresh
Joined
Aug 23, 2008
Messages
98
Age
29
Location
Essex, England
Website
Visit site
I'm trying to play Poke646, a singleplayer mod. I can't get any weapons working, am I doing something wrong? They just don't appear in game. Also, small request, can walk be made into a toggle too? Like crouch.
 
Last edited by a moderator:

elwing

Rabbit Addict
Joined
Feb 23, 2009
Messages
3,118
Hi Eversmile.

some mod will work just great, but all mods that use custom game dll will not work with this PND as It can't, for obvious reasons use the native x86 game dll. this package come with a re-implementation of half-life game dll.

the game will load the maps, but any custom trigger, weapon or change in the game code will not work.
 

gadgetoid

Moderator
Staff member
Joined
Jan 6, 2009
Messages
2,022
Age
35
Location
Sheffield, UK
Website
pinout.xyz
This is incredible! Started playing vanilla Half Life- another classic on my todo list, although I'll probably not play it through again- it's not the same without Sven Coop :D


Does anyone else have trouble climbing ladders with the analog stick?


Half Life was my entire world for way longer than it should have been- Sven Coop, Natural Selection, Opera, that vampire one, Day of Defeat and, of course, Counter Strike- and probably more besides. It was a significant college addiction that led to some err... Attendance issues :D


NS2, for anyone who hasn't tried it, is an incredible stand-alone successor to what was definitely the best HL mod.


Sent from my iPhone using Tapatalk
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,467
Age
47
Location
France, near Lyon
New build on the repo, with updated sources (based on build 3030). Looks more stable (on the died / reload issue).

Also include latest glshim, that seems more stable too.

Build 07
-----------


  • New build, with updated sources
 

LardLad

Still Fresh
Joined
Oct 18, 2012
Messages
97
The new build crashes every time I try to load a custom game.  Doesn't seem to matter which mod I attempt to load.  Of course I am running an old version of Super Zaxxon - 1.55 - so maybe my results are atypical.  My Pandora is a 1 GHz model.  Didn't have this issue with the previous build.
 
Last edited by a moderator:

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,467
Age
47
Location
France, near Lyon
The new build crashes every time I try to load a custom game.  Doesn't seem to matter which mod I attempt to load.  Of course I am running an old version of Super Zaxxon - 1.55 - so maybe my results are atypical.  My Pandora is a 1 GHz model.  Didn't have this issue with the previous build.
Strange, it should not behave much differently than previous build.

Does it work with default game?

Can you put a copy of the pndrun_xash3d.out logfile here?
 

LardLad

Still Fresh
Joined
Oct 18, 2012
Messages
97
The default Half Life seems to work fine, the issue is limited to custom games - any mod, doesn't seem to matter which one I try, causes the engine to crash.  I'll find the .out file and upload it.

I know I should upgrade the OS, but everything was working so well I was reluctant to introduce any change.  I'll take a look at the threads on the most recent update to the OS.
 

NoeleyC

Well-Known Member
Joined
Oct 23, 2008
Messages
1,348
I just tried the most recent update of this on my 1.72 firmware model with the Half Life dreamcast mod and that seems to work fine for me! I don't have any other mods installed at present...
 
Top