Release F-1 Spirit remake

Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,229
Age
37
Location
Innsmouth, MA
@ ptitSeb: I'd say FPS varies roughly from ~15 to ~25 on my Rebirth Pandora with OC @ 850 MHz.
 
Last edited by a moderator:

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
11,977
Location
Somewhere off the coast of the EU
So, I've been playing a fair bit of this recently. I think I've spotted a bug though.


It seems to have trouble with saving stuff. It's managed to save my 9 point finish in the first race, but I can't reload custom cars, and I can't seem to find a valid filename to save replays.


Since I'm using custom cars quite a lot now to give me a chance on the replay stage, setting up a game is quite slow as I need to configure my car every time.


Anyone else experienced this problem?


Edit: Rally stage, not replay stage!
 
Last edited by a moderator:

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,275
Under Slack:

/f1spirit: error while loading shared libraries: libssl.so.0.9.8:

It uses ssl ???

also /usr/lib/libmikmod.so.2, Slack is .3 :p :p :p

Isn't it possible for f1 to search for .so et voilà ?

Anyway, the pnd works.
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,530
Age
47
Location
France, near Lyon
Yes f1-spirit use ssl to upload hiscore (even if it doesn't really works).

About mikmod, I don't remember precisely how the .so loading is done here.

But it works despite those errors? Is there something I cando to improve things?
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,275
I can add some ln -s during the Slack construction, like i do for other .pnd.

But it would be cool (not only for Slack, but also for other distros, and probably P2 OS) if you load .so instead of .so.2 etc. Dunno if it's possible. Anyway all notaz pnd are working.

I also fixed a link for Not Tetris, but there's a segfault after that :/.
 

Monkfish

Active Member
Joined
May 8, 2012
Messages
724
Age
35
Location
England
cool game but i got a wierd crash yesterday, i'll upload the PND_out here later if i get the chance

EDIT: i cant give you the pnd.out file as i reflashed my unit since then, if i have the same error again then i'll post the out file
 
Last edited by a moderator:

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,530
Age
47
Location
France, near Lyon
New build on the repo.

I make the EGL context compatible with latest SGX Video drivers, and while at it, I also used the "powervr.ini" trick to use flip instead of blit, making the game proabably a little bit faster and with less (none) tearing. And because the game is designed to run à 50fps, I switch the LCD to 50Hz at start :)

Build 03

----------

  • Compatible with latest SGX Video Drivers
  • Use Flip instead of Blit (more speed and less tearing)
  • Switch LCD to 50Hz at start (and restore original frequency at exit)

Enjoy that new build!
 
Last edited by a moderator:

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,530
Age
47
Location
France, near Lyon
Quick fix, I broken vorbis lib when doing some experiments.

Build 04

----------

  • Fixed sound that was broken with build 03
 
Last edited by a moderator:

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,530
Age
47
Location
France, near Lyon
New build on the repo. I recompiled everything and used Tremor for ogg. I didn't notice any significant speedup (ok, maybe, but that must be just placebo effect). Don't forget to use Alt-F to show FPS if you want some numbers on screen.

Build 05

----------

  • Fresh build
  • Using Tremor (integer) for ogg sound
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,530
Age
47
Location
France, near Lyon
New build on the repo.

I tried some optimisation on the GLES side (no, not texture atlas, but still more batching). It should have improve a bit speed (and I hope I didn't broke anything in the process).

Build 06

----------

  • Fresh build, using GCC 5.0 and lto
  • Tried some more GLES optimisations (should be faster, at least on Gigahertz)
 

ekianjo

Hardcore Member
Joined
May 7, 2012
Messages
8,261
Location
神戸市、日本 (Japan)
New build on the repo.

I tried some optimisation on the GLES side (no, not texture atlas, but still more batching). It should have improve a bit speed (and I hope I didn't broke anything in the process).

Build 06

----------

  • Fresh build, using GCC 5.0 and lto
  • Tried some more GLES optimisations (should be faster, at least on Gigahertz)
Oh cool :)

Did you do any benchmark ?
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,530
Age
47
Location
France, near Lyon
Oh cool :)


Did you do any benchmark ?
Not really, but I used integrated fps display (Alt-F) and played the Rally track. It feel smooth on my gigahertz (more than 30fps), and I also tried on a CC, and the fps was ok (between 20 and 30 fps).
 
Top