Sim Card not registering


Mar 16, 2003
Hi, looking for a bit of advice on getting my Pyra connected to a mobile network. I'm pretty sure I've got the SIM inserted properly (which was a challenge in itself as the socket doesn't seem to like any standard size!) but Modem Manager just sits saying that the card needs to be registered with the network. If I go into info it shows that it is reading the IMEI properly but is my searching for a network without success. I've tried outside and that makes no difference. I've tested the same SIM in my phone and it connects fine any suggestions? Many thanks. Dave.
I'll take the battery out when I get a chance and take some photos but I 3d printed a SIM Nano to Standard converter and used that. The problem I had is that the standard SIM seems to get in the way of the locking clips so I had to trim a bit off either side. I tried inserting an old standard SIM I had knocking about and that also stopped the locks from sliding in properly so it isn't an issue with the 3d print.

(edit) typos
Welcome to the club.
Its actually working alright, the problem is that the modem has the transmitting power of an anti theft tag.
Go out, find a cell tower, try it in front of it. With some luck you get enough reception to be able to do stuff like sending an sms.
That's still the weirdest thing so far.
It works in hns basement where other devices have almost no reception anymore. The antenna circuit is measured by someone who does this as main job... so we have no clue why it seems to work for some and not for others.
hns used his own Letux OS for doing all the tests, so I can only imagine something is different there.