SD Card Problem


Niall

Still Fresh
Joined
May 19, 2011
Messages
2
Hi, I'm having a bit of a problem with some of my SD Cards. I bought 3 "7dayshop" brand SD Cards and here's where it gets interesting, one of them works fine and I have no problems with it. When I try to use the other 2 cards, they simply aren't detected at all. dmesg gives the following:


mmc1: unrecognised EXT_CSD structure version 3


mmc1: error -22 whilst initialising MMC card


Now the best I can tell with a bit of googling is this error is caused by an outdated driver or kernel, although I could be wrong.


If it helps, on my Fedora 14 install I can use the cards using a card reader fine. If I use the same card reader on the Pandora the cards still aren't detected.


Is there any sort of quick fix? Will an opkg update help at all?
 
H

hakmanplayer

Guest
Maybe the other 2 cards are corrupted??


With all due respect, i have never herd of that brand of SD card before.


I only use Sandisk either class 2,4 or 6.


I know some people in these forums have talked about certain SD cards being corrupt.
 

Mr_Loon

Can't Remember
Joined
Aug 30, 2010
Messages
2,330
Hi Niall, welcome to the boards.


Do you have a link to the cards you bought? I bought a 32GB class 10 from 7 day shop and it worked fine with Pandora FWIW.


The only thing I can suggest is trying to format the non working cards with the Panasonic SD card formatter.


Sounds like you've found a really knotty problem to me, here's hoping one of the forum gurus will have some idea what might be at the bottom of these issues.
 
Last edited by a moderator:
H

hakmanplayer

Guest
Hi Niall, welcome to the boards.


Do you have a link to the cards you bought? I bought a 32GB class 10 from 7 day shop and it worked fine with Pandora FWIW.


The only thing I can suggest is trying to format the non working cards with the Panasonic SD card formatter.


Sounds like you've found a really knotty problem to me, here's hoping one of the forum gurus will have some idea what might be at the bottom of these issues.


Sorry Niall i am no guru.
 
Last edited:

Niall

Still Fresh
Joined
May 19, 2011
Messages
2
Maybe the other 2 cards are corrupted??


With all due respect, i have never herd of that brand of SD card before.

Not corrupt, at least as far as I can tell anyway. :blink:


Cheap brand I know, but they offer the advertised speeds and as far as price goes, they were a steal.

Do you have a link to the cards you bought? I bought a 32GB class 10 from 7 day shop and it worked fine with Pandora FWIW.

Those were the exact cards I bought! Except I bought from their ebay page. I actually bought 3 of them and 1 of them does work, the other 2 are the problematic cards.

The only thing I can suggest is trying to format the non working cards with the Panasonic SD card formatter.

Was the first thing I tried! :p I even formatted one of the cards in EXT2 just to be safe. Same error though.

Can these cards be detected on other devices or a PC?

Yep. Other devices can use the problematic cards fine.


I'll dig out some other SD cards tomorrow to see if I can narrow down the problem.


EDIT: After reading the forum, I came across another thread about SD cards and came across this post:

Please use H2testw to test the card. It may determine whether it is faulty or a fake.

I will test all 3 cards tomorrow.


EDIT: Cards are legit but I found the exact problem, the kernel on my pandora(2.6.27.46) doesn't support the CSD structure 3 cards, or something along those lines. :lol: All I need to do is update the kernel and the problem should be fixed. :)
 
Last edited by a moderator:
Top