Release OpenLara

Discussion in 'Software Releases' started by ptitSeb, Sep 30, 2018.

  1. notaz

    notaz Certified Guru

    Joined:
    Aug 23, 2005
    Messages:
    4,911
    Location:
    Lithuania
    I much prefer the ES1 version for it's smoothness. Might be good to have an easier switch, but I'm ok with editing .es file too.

    There is sometimes a crash in MeshBuilder::renderModel() when returning to main menu from the game, or when completing a level. gdb doesn't give an usable backtrace. Easiest way to reproduce is to complete Lara's home level (crashed 2/3 tries, ES1 mode, just run to the very end, jump into the pool and get out of it and the level should end).

    There is also an issue of bats not falling to the ground after dying (might be OpenLara bug).

    Seems to be ok in the ES1 version.
     
  2. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,195
    Location:
    Innsmouth, MA
    @notaz : you are right about the ES1 version. It's faster and the water effect doesn't glitch. But as @ptitSeb said, the lights are not quite correct...

    I thought my Rebirth unit would default to ES1, but actually it uses ES2.

    Cheers, Magic Sam
     
  3. second exodous

    second exodous Advanced Member

    Joined:
    Sep 27, 2005
    Messages:
    2,966
    Location:
    Utah, USA
    I kinda remember this just being a bug in Tomb Raider, I remember I had problems with the camera when going through underwater tunnels. Is this a completely new engine for Tomb Raider or does it use more than just the graphics?
     
  4. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,317
    Location:
    France, near Lyon
    I'll debug the crash tomorrow (I'll hold the version with configurable trigger until the bug is fixed I think).

    The water "fog" bug with ES2, I noticed already, but it's not happening all the time. I'll check an option about a workaround already in the code for something like that (I think)...

    For the Bats not falling down, yeah, I noticed that, and I assumed it was it's an OpenLara bug, but I'm not sure. I'll try to have a look, but I'm not sure.

    About ES1 / ES2 selection, maybe I'll do a message box question at start, with the default value beeing the same as previous launch (so you can just press enter if you don't want any change).
     
  5. Palmiga

    Palmiga Member

    Joined:
    Oct 18, 2010
    Messages:
    93
    Tomb Raider 1 from the directors cut wont work. Tomb Raider 3 works on my 1Ghz pandora, but Lara couldnt slide down the big slide at the beginning. She hangs after a few meters.
     
  6. xnopasaranx

    xnopasaranx Superbad!

    Joined:
    Jan 31, 2006
    Messages:
    3,315
    @ptitSeb the bats do not fall down in the webGL version either, so I'd assume it is a bug in openlara and not with your port.
     
  7. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,317
    Location:
    France, near Lyon
    New version on the repo.

    I added shoulder buttons, they should be configurable now.
    Also, I fixed a bug in gl4es, with the deletion of Framebuffer. I think that was the issue with the end of level, but I'm not sure. To be safe, I have left all debug info in the binaries this time.
    Also, I added some zenity dialog to choose between GLES 1 and 2. Previous choice is remembered so just press "enter" to go with previous choice.

    Build 05
    -----------

    • Pandora shoulder buttons can be configured
    • Added non-intrusive dialog to choose GLES 1 or 2
    • Fixed a bug in gl4es with Framebuffer deletion
     
    PokeParadox, rSl, xnopasaranx and 2 others like this.
  8. PokeParadox

    PokeParadox Founder of Pirate Games - Penjin Coder Staff Member

    Joined:
    Dec 8, 2005
    Messages:
    6,511
    Location:
    UK
    Thanks for this! I finally got some time to try this out and it's quite nice. ES feels better overall although I did notice some minor glitches. ES2 felt more like the original software rendering, i.e. a little sluggish around 20-30fps.

    Is there, or could there be an easy way to switch between data files? I basically copied all TR1-3 files but can only launch TR1?
     
  9. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,317
    Location:
    France, near Lyon
    Mmm, I don't know, I have only tried using TR1 data files... I'll do some experiment with TR2 and TR3, but my guess is that it take the 1st one it find for now.
     
  10. Palmiga

    Palmiga Member

    Joined:
    Oct 18, 2010
    Messages:
    93
    The only game that works here is TR3, but I stuck at the first slide.
    TR2 shows only the first 2 videos, the game wont start.
    Still no luck with my TR1-Version.:'(
     
  11. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,317
    Location:
    France, near Lyon
    I updated the PND on the repo, with a newer build of the GLES2 version. Unfortunatly, for now, the GLES1 version is not working correctly with the new sources, so I've left it untouched in the PND. The GLES2 is working nicely, and appart from the slow start (still present), the version was smooth on my Gigahertz models (and bats now fall to the ground when killed).

    Build 06
    -----------

    • Updated GLES2 version
    • Updated libs
     
    rSl and Linux-SWAT like this.
  12. doragasu

    doragasu Member

    Joined:
    Jun 2, 2008
    Messages:
    321
    Great, I always missed this game since the first day I got my hands on the Pandora.

    Unfortunately GLES1 version does not work on my first batch pandora. I have added the PSX TR1 files (had to rename every file uppercase). When using GLES1 version, it loads the menu screen, but starting the game or Lara's home causes the game to crash. When the game crashes, it cannot be started again (does not even reach the main menu) until I reboot the console. Strange enough, the GLES2 version works, but the menu screen is completely black, and when entering a level the poor framerate makes the game uncomfortable to play.

    Here is the pndrun output:
    Code:
    =======================================================================================
    PND             : /media/IORI_PANDORA/pandora/menu/openlara.pnd
    PND_FSTYPE      : Squashfs
    APPDATADIR      : /media/IORI_PANDORA/pandora/appdata/openlara
    APPDD_FSTYPE    : ext3
    PND_CPUSPEED    : <unset>
    EXENAME         : runscript.sh
    ARGUMENTS       : <unset>
    =======================================================================================
    [ START ]--- Mount the PND ----------
    Mounting : mount -t squashfs -o ro "/dev/loop0" "/mnt/utmp/openlara"
    Mounting the Union FS : mount -t aufs -o exec,dirs="/media/IORI_PANDORA/pandora/appdata/openlara=rw+nolwh":"/mnt/pnd/openlara=rr" none "/mnt/utmp/openlara"
    [SUCCESS]--- Mount the PND ----------
    [ START ]--- Starting the application ( runscript.sh  ) ----------
    --------------------------------------------------------------
    Setting PATH to /mnt/utmp/openlara:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
    --------------------------------------------------------------
    Setting LD_LIBRARY_PATH to /mnt/utmp/openlara/lib:/lib:/usr/lib
    System check
    ============
    Freememory is 124
    Cpu Speed is 800
    Sys Speed is 332
    PND Build is 06
    Pandora model is 2
    LIBGL_FB=1
    LIBGL_ES=1
    LIBGL: Initialising gl4es
    LIBGL: v1.1.1 built on Dec  5 2018 00:38:51
    LIBGL: framebuffer output enabled
    LIBGL: Using GLES 1.1 backend
    LIBGL: loaded: libGLES_CM.so
    LIBGL: loaded: libEGL.so
    LIBGL: Using GLES 1.1 backend
    LIBGL: Extension GL_OES_framebuffer_object detected and used
    LIBGL: Extension GL_OES_point_sprite detected and used
    LIBGL: Extension GL_OES_point_size_array detected
    LIBGL: Extension GL_OES_texture_cube_map detected and used
    LIBGL: Extension GL_OES_blend_subtract detected and used
    LIBGL: Extension GL_OES_blend_func_separate detected and used
    LIBGL: Extension GL_OES_blend_equation_separate detected and used
    LIBGL: Extension GL_OES_texture_mirrored_repeat detected and used
    LIBGL: Extension GL_OES_mapbuffer detected
    LIBGL: Extension GL_OES_depth24 detected and used
    LIBGL: Extension GL_OES_rgb8_rgba8 detected and used
    LIBGL: Extension GL_EXT_multi_draw_arrays detected
    LIBGL: Extension GL_EXT_texture_format_BGRA8888 detected and used
    LIBGL: Extension GL_OES_draw_texture detected and used
    LIBGL: Max texture size: 2048
    LIBGL: Texture Units: 4(4), Max lights: 8, Max planes: 6
    LIBGL: Hardware vendor is Imagination Technologies
    LIBGL: Targeting OpenGL 1.5
    LIBGL: Enable FastMath for cortex-a8
    LIBGL: Expose GL_ARB_texture_non_power_of_two extension
    LIBGL: Don't handle Texture Matrice internaly
    LIBGL: glXMakeCurrent FBO workaround enabled
    LIBGL: FBO workaround for using binded texture enabled
    LIBGL: Current folder is:/mnt/utmp/openlara
    init gamepads:
    sound enabled, dsp opened for write
    set Frequency to 44100, return 0 (rate=44100)
    set dsp to stereo (2 => 0)
    set dsp to 16bits signed audio (16/16 => 0)
    set dsp fragment size to 9x10 (512 => 0)
    OpenLara (Oct  8 2018)
    Vendor   : ptitSeb
    Renderer : GL4ES wrapper
    Version  : 1.5 gl4es wrapper 1.1.1
    cache    : /mnt/utmp/openlara/home/.OpenLara/
    supports :
      variyngs count : 0
      binary shaders : false
      vertex arrays  : false
      depth texture  : false
      shadow sampler : false
      discard frame  : false
      NPOT textures  : true
      RG   textures  : false
      border color   : true
      anisotropic    : 0
      float textures : float = false, half = false
    
    LIBGL: Enable LIBGL_VSYNC=1 if you want to use vsync.
    shader: cache warm-up...
    shader: cache is ready
    meshes: 13
    MegaMesh (i:1584 v:1126 a:3, size:39200)
    error loading file "level/1/AMERTIT.PNG"
    error loading file "audio/1/track_02.ogg"
    *** glibc detected *** ./OpenLaraFFP: free(): invalid pointer: 0x41eec008 ***
    ./runscript.sh: line 123:  2147 Aborted                 ./OpenLaraFFP
    [ FAILED]--- Starting the application ( runscript.sh  ) ----------
    [ START ]--- Restoring the frame buffer status ----------
    [SUCCESS]--- Restoring the frame buffer status ----------
    [ START ]--- Restoring nub mode ----------
    [SUCCESS]--- Restoring nub mode ----------
    [ START ]--- uMount the PND ----------
    [ START ]--- Waiting the Union to be available ----------
    [SUCCESS]--- Waiting the Union to be available ----------
    rmdir: failed to remove `/mnt/utmp/openlara': Device or resource busy
    [ START ]--- Waiting the PND mount dir to be free ----------
    [SUCCESS]--- Waiting the PND mount dir to be free ----------
    cleanup done
    [SUCCESS]--- uMount the PND ----------
    =======================================================================================
    Return code is : 4
    
     

Share This Page

Loading...