Open2X Bug Report: Fat Corruption :(


Jul 10, 2008
well i'm reporting just to make sure senorcuak acknowledge this, in case this is something important.

well i'm using my f200 B with a transend SDHC 8GB Class 6, with open2x DR7. with the original kernel (the not SD-stuff patched one)

I was doing something, exited to the menu (all fine till know), opened termula (terminal emulator), showed a friend siggen, exited, and there found out that all in the "nativos" folder had been wiped out. (termula is in "sistema" folder)
the only thing left in nativos was the nanobounce folder but in the old dos style name, NANOBO~1, and one more but don't remember which one it was...

hope this be useefull to you, of maybe you fixed something related to this in the newer kernel, but just in case you didn't see this :p

PS: "nativos" and "sistema" are inside "games" which is in the sd card's root
PPS: This is the first time that the my SD card gets corrupted while powered.
Thanks for the info.. The only SD card my GP2Xes have a problem with is my 8GB Class 6 Transcend card. Every other card works fine but that one card fails to be recognized occaisionally and I have also had a corruption problem with it once.

I recommend not using that card. I don't think it is an Open2X-specific problem because I compiled a version of the Open2X kernel that used the original GPH-specific SD code and it still has problems recognizing the card more often than not. I suspect that the card is just fundamentally incompatible with GP2Xs.

I saw you posted in my updated SDHC kernel thread so you already have tried the new kernel I am referring to.
nah, i still haven't flashed the newer kernel. As everything worked fine i hadn't had the need for it.
I'll flash the newer one one of this days, just to see if i can notice any diferent behavior.

PS: sadlly i'm a bit short of money so i'll have to stick with the transend one till i can buy some other brand :( so i'm going to be "testing" it some more x.x