Help With Squidgesnes / Mame Please


ketchupgun

Member
Joined
Jun 20, 2006
Messages
155
Age
44
Location
Toronto, CANADA
Website
www.theimponderables.com
ok...explain this to me.
I had squidgesnes 0.34 on my Gp2x

had roms on SD in /roms/snes (along with megadrive, sms, etc etc)

worked fine....then I accidentally formatted the NAND.

So now I am reloading everything I had. DrMD woirks great.

Squidesnes...upon launching hangs a black screen?! why?

and when I launch MAME, it can't find roms...which are on SD in /roms/mamegp2x


HELP!
thx so much!
 

Aimless_E

Member
Joined
Oct 10, 2005
Messages
461
you put your programs on the NAND? huh... :)

Well anyway , I think your suffering from a pathing issue. Check to make sure the emulators know where your putting your roms. Once you formated the Nand (Only Vecktar and the GPL texts are there by default) you got rid of the config files. I bet it has something to do with that.

Squidesnes as far as I know doesn't use SDL and the SDL-libs aren't installed on a formattable section of the NAND anyway.

If you still think you might need them you can find them near to where you found mame and squidesnes. Look in needed files or libraries cant remember which one :)
 

ketchupgun

Member
Joined
Jun 20, 2006
Messages
155
Age
44
Location
Toronto, CANADA
Website
www.theimponderables.com
you put your programs on the NAND? huh... :)

Well anyway , I think your suffering from a pathing issue. Check to make sure the emulators know where your putting your roms. Once you formated the Nand (Only Vecktar and the GPL texts are there by default) you got rid of the config files. I bet it has something to do with that.

Squidesnes as far as I know doesn't use SDL and the SDL-libs aren't installed on a formattable section of the NAND anyway.

If you still think you might need them you can find them near to where you found mame and squidesnes. Look in needed files or libraries cant remember which one :)


So pathing, how do you peeps set up your NAND & SD/ cards?
(you leave the NAND free?)

on the SD:
/movies
/photos

/games/squidgesnes
/games/drmd...

/roms/snes
/roms/megadrive
/roms/mame


(is it necc. to keep the emulators's folder in the SD root?)

how do you specify where the emulator should look for the roms...i figured that was dictated by the emaulator's readme.txt

anyways...DrMD works fine presently; Mame launches but can't find roms; Squidgesnes just hangs blank. So what's the deal? what should be on my NAND? Where do I find config files? If there a way to restore the NAND to factory default?



thx guys!
 
Last edited by a moderator:

ketchupgun

Member
Joined
Jun 20, 2006
Messages
155
Age
44
Location
Toronto, CANADA
Website
www.theimponderables.com
FIXED!

Unzipped Squidgesnes .34 to SD's root folder and it works now..works great .. except for Clay Fighter .. oh well.

is it common then to unzipped emulators to the root of the SD, as opposed to organzing your SD into
1.Games
2.Photos
3. Music

etc etc

(btw, I know nothing about hec editors and source codes and such, s editing this stuff is out of the question .. though, if you're a deeloper and in need of some artwork, PM me...I'm a photographer and graphic designer..we can discuss!)
 

gaterooze

Coltrane Sundia
Joined
Aug 7, 2004
Messages
2,723
Website
Visit site
Unzipped Squidgesnes .34 to SD's root folder and it works now..works great

Hm, strange that. It shouldn't really matter where the emu is unzipped to on the SD.

Try this: put Squidgesnes (try 0.37a first, it's fast!) in /games/squidgesnes/ (or wherever) and tick the setting "Use absolute rom dir."

re: NAND, probably best not to add anything to it (it has limited writes, although that's in the hundreds of thousands). I never use mine. Sorry for mentioning SLD libs, apparently they are stored in a read-only portion of the NAND and you shouldn't need to worry about that.
 
Last edited by a moderator:
Top