Handy (Atari Lynx Emualtor) For Wiz .. Very Alpha


Internal Development
Mar 11, 2003
This one is for DaveC.

Well, maybe not so much for poor Dave, since I did add scaling in so he might be PO'd, but its a start ;)

This is a very alpha port of stock Handy for SDL, using GPH's SDL (ie: several layers of slowdowns in there), but it performs alright. I should move it to run right on the harsware which would make it perform much better and fix sound, but I've not had much time and thought a quick port woudl be better than no-port, right? That said, it works, but don't expect much. If you like it, I can fix it up ;) Sound is choppy, no ROM picker, but you can see if it works ;)

Grab it here for now:

I included a brief INSTALL.txt or somesuch, copied here:

This is your alpha-hack; it works alright, but no frills yet :)

1) There is no UI yet; a Lynx ROM must be specified upon on the command line,
for which I'm supplying handy.gpe for -- edit that to specify a ROM.

2) Invoke handy.gpe from the Wiz -> Launcher menu item

3) You will need to obtain Lynx Boot ROM and name it "lynxboot.img" -- any
other filename and you're out of luck.

4) libiconv is included; keep it in the same directory or it will not run.

5) By default, handy.gpe runs the ROM file "foo.lnx", so you can just
drop in a replacement ROM-file, named that.

Handy was ported by Tuskenraider2k and was one of the best emu's on the GP2X, it was more or less near perfect I think. It should therefore run at full speed on the Wiz. Btw where is he these days?
Oh btw, most regular commandline opts for sdl handy apply

what are your fav games? Although I was an Atari salesman for the lynx1 back in the day (and my beloved Atari ST), I never cared much for the lynx titles we carried.. Beyond surfing :) I was so disappointed by "Gauntlet 3"


I post way too much from my phone. *cramp*

Well I just tried this. The scaling isn't *that bad* as you at least just did an even integer double to 320 x 200 that is good. You need it to be doubled or the image would be microscopic. I don't care for the scanline filter (handhelds dont show scanlines like a CRT :) ) but maybe that could have an option to be be turned off in the future.

Yes the sound is stuttery (with buzzing) and it is way too LOUD! the volume control understandably doesn't work as it is early. Please, if you are going to make the volume fixed for now could you put it at least half of what it is now? This will blow the speakers and suck battery dry in 5 minutes the way it is. I had to shut it off right away due to it being so loud.

I hope you will update this in the future. It is a great start. If the obvious things were fixed this would be great.

That other source I gave you may be of some use I hope. That emu ran fullspeed with perfect sound at 250 MHz. Too bad that one was messy and couldn't be directly ported as it would have run perfect on the Wiz.

Some of the better games were:

Blue lightning, Slime world, Xenophobe, Power Factor, block out, chip's challenge, Crystal mines II, Gates of Zendocon, Lemmings, Super missile command, Electrocop, and many arcade conversions like Rampage that still don't work on MAME on the Wiz.

Thanks for the port :)
Not sure if it was messy per se, just the directories and such were a mess and 'fat'; ie: it'd been through several folks hands and ported to various machines, and all there, so it'd take a bit of effort just to sort through; but Handy is 'Handy', hasn't changed much in all the years since Keith let it out of the bag. But with time being tight right now, I just went for the easier egg to fry :) Still, I coudl proabbly speed it up quite a bit pretty easily which nmight solve sound, or maybe I need to ditch GPH SDL and go to the metal .. all just takes time. But I wanted to get you something when I got a free moment..

So first thing to do is halve the volume, then add volume +/- control, and a UI for picking ROMs, and then should be 'useful', if not great.

Electrocop stunk; we had that, and Blue Lightning (I think that was the title) and a few others at the store .. naturally I bought myself a Lynx and some games (some good like Joust, Ms Pacman, Chips etc), but a lot of lazy ports up front turned me off :) I really really liked Callifornia Games or whatever that was though, at the time.

There should be a commandline option to disable audio ..

-throttle / -nothrottle
-fsaa -nofsaa
-frameskip X

There were some other good original games too but it is all subjective. I think Skweek was a decent puzzle game that used the sprite scaling hardware pretty well, Crystal mines was a good action/puzzle game too. You would just have to go through a few ROMs and see what you like.

The Lynx was the first ever home console to do hardware scaling for sprites so it was impressive in it's day.

I think if the emu was optimised the sound issues would be helped. When an emu struggles the sound seems to get choppy. To me the lack of a ROM selector is minor and is probably last on the desired features list to me. I think one of those frontends like Capex or Selector (used with GnGeo or FBA) could be used for that. If I had a preference the speed/sound (of course the hardest to do :) ) would be the most important. Maybe some routines from the GP2X handy would help there? I know that one was fast.

Have you tried the new USB networking that they got working? It may save you some time developing, which is always a good thing, especially if you don't have allot of it :)

Thanks again for the porting.
Is there any news of an update for this emulator?

Also I noticed that Rorque has managed to get a frontend working for it by using the Selector program from NewsWeez. (Here: http://lostsite.altervista.org/wiz/?p=1052#comments. )
Please will you let me know what needs to be edited to get this to work?

Cheers, Neil
Neil L said:
Is there any news of an update for this emulator?

Also I noticed that Rorque has managed to get a frontend working for it by using the Selector program from NewsWeez. (Here: http://lostsite.altervista.org/wiz/?p=1052#comments. )
Please will you let me know what needs to be edited to get this to work?

Cheers, Neil

Yes, i do, in fact, i design my own front for selector, but unfortunelly, it doesn`t work now.I dont know why.
Last edited by a moderator:
Neil L said:
Thanks for the quick reply. :)

If you do get it running, please will you let me know how.

Cheers, Neil

i send you PM and link to it.It`s simple, you must have archive with handy and selector, put selector files to handy directory, and edit selector.cfg.You must remember to fill both filetypes, without it selector will crash.
Last edited by a moderator:
I know this is probably a bit off topic, but do you know that the c64 site "games that weren't" managed to dig out and fix up a complete c64 conversion of "Gauntlet 3" - you might want to grab it and try it if you were a gauntlet fan.

Thank you, always good to see a new emulator, I never had a lynx, once this gets a bit more polished I'll try it out. Obviously I'm a big fan of retro computing but it's one of the few systems I dont have in my collection. I did have a GameGear, which had some pretty good games (though the TV tuner I bought second hand with a slightly duff aerial was my favourite cart for the GG. Once on holiday I soldered a mass of AA batteries together and used them to power a ZX speccy I picked up in a bootsale, with it pluged into the GG TV converter I managed to load Treasure Island Dizzy using my sony walkman! That was the most fun I ever had with the GameGear) - back to the subject in hand, how did the lynx compare with Segas GG?
FWIW, the source for my build is here:


Looks like I did a very quick drive-by port on this one, but it seems to have worked.

A couple people have noted they want to hack on this, so get it there :)

I'm having a little trouble compiling it for the Caanoo. All I changed was the paths to my toolchain in the makefile.

daniel@TG624:~/handywiz/handy_sdl-0.5-src$ make -f Makefile-0.95

*** Checking compilation environment... OK

*** Building Handy/SDL for Linux for GPH CAANOO...

*** Compiling src/handy-0.95/cart.cpp...
gcc: error trying to exec 'cc1plus': execvp: No such file or directory
make: *** [obj/cart.o] Error 1
Did you change just the paths, or the executables too? It looks like it's trying to compile C++ code with gcc instead of g++ (use arm-gph-linux-gnueabi-g++ instead of arm-gph-linux-gnueabi-gcc)
I actually can't get it to compile for the Wiz, even. I dunno how skeezix got around it, but for me it keeps looking for certain components of OpenGL that just don't exist on the Wiz.

I asked skeezix about his toolchain and libs, and he said he'd need to check his hard drive to see, but he hasn't gotten back to me on that yet.

EDIT: Nevermind, I got it compiling. I had to change a whole bunch of stuff in the Makefile, replace my SDL headers, and remove some lines of code from the source.

As of right now, I have no idea if the executable I compiled works, though - I have yet to test it.

EDIT 2: Nope, the one I compiled immediately exits to the Wiz menu. Hmm.
fishybawb said:
Did you change just the paths, or the executables too? It looks like it's trying to compile C++ code with gcc instead of g++ (use arm-gph-linux-gnueabi-g++ instead of arm-gph-linux-gnueabi-gcc)
Okay, I've specified the linker and C++ compiler. It seems to work so far, but it looks like it's looking in the wrong place for SDL...

*** Linking it all together...
/home/daniel/GPH_SDK/tools/gcc-4.2.4-glibc-2.7-eabi/bin/arm-gph-linux-gnueabi-ld: skipping incompatible /usr/lib/libSDL.so when searching for -lSDL
/home/daniel/GPH_SDK/tools/gcc-4.2.4-glibc-2.7-eabi/bin/arm-gph-linux-gnueabi-ld: skipping incompatible /usr/lib/libSDL.a when searching for -lSDL
/home/daniel/GPH_SDK/tools/gcc-4.2.4-glibc-2.7-eabi/bin/arm-gph-linux-gnueabi-ld: cannot find -liconv
make: *** [handy_wiz.gpe] Error 1
Last edited by a moderator:
Alright, I finally got it compiling and running with the official SDK, although I had to use OpenGL headers from my PC's Linux distribution before it would finish compiling.

Com64: You'll need to go back in the Makefile and specify the full path to the sdl-config script provided by GPH in all three locations where it's referenced.

EDIT: Alright, just to let you guys know, my initial attempt to add in volume controls failed. Pressing a volume key immediately mutes the sound.

I think I did manage to get a lower initial volume set up, but unfortunately, the sound still sounds broken up. I don't think I'm the guy to fix this.

I'm hoping someone with more experience and programming talent than I can eventually get this sorted, as I'm really missing Lynx on my Wiz. For the time being, I either have to suffer my original Lynx (which is hard to see and has bad battery life), or settle for playing Chip's Challenge on the GP32 port of Handy.