[gba] New Beta Of Gpsp2x! Very Fast & Better Sound!


gavie

Member
Joined
Sep 15, 2006
Messages
176
Location
The Netherlands
Website
Visit site
Is it just me, or is the front end of the emulator not responding very well..
The emulator in the menu is not always responding nicely when I press buttons like down or up to scroll trhough my roms, I haven't had these problems on other apps, so I guess it's just because this is the beta.. :p
Anyway, I really like this emulator.. Roms like Prehistorik man, Megaman, and some others I've tried are very playable :) Some games just lock up after playing a while.. but this is awesome!!
 

PostmanPat

Still Fresh
Joined
Dec 30, 2005
Messages
45
Just donated. I can't thank you enough, keep up the amazing work. Could someone do some videos of the new version?

thanks
 

Amon_Re

Member
Joined
Nov 22, 2006
Messages
428
zodttd posted on Mar 10 2007 at 10:38 AM said:
For those without PayPal, donating a giftcertificate would be definitely cool. I never tried that but sites like outpost.com, amazon.com, playasia.com and possibly others are all great choices. Always PM me if you would like to donate but aren't able to. I can always work something out. :)

I could send you Belgian beer or chocolate :p
If only i had visa... *oh well*
 
Last edited by a moderator:

MrHillBilly

Still Fresh
Joined
Aug 23, 2006
Messages
82
gavie posted on Mar 10 2007 at 02:27 PM said:
Is it just me, or is the front end of the emulator not responding very well..
The emulator in the menu is not always responding nicely when I press buttons like down or up to scroll trhough my roms, I haven't had these problems on other apps, so I guess it's just because this is the beta.. :p

I have the same prob. about the slow responce in the start up.

NICE JOB. Alien Hominid runs perfect :D , I did have one crash during play for some reason, but it went past the crash on another load. I might be overclocking my GP2X a little too hard.

Is it just me messing up something or do the save states not save after a reboot. They seem to work if you do not reboot.
 
Last edited by a moderator:

Emu&Co

Member
Joined
Feb 12, 2004
Messages
803
Age
34
Location
Germany / Bavaria
Website
dreimer.de.vu
Advance Wars 2|Round based Strategy: runs fine, 60 fps
Advance Wars|Round based Strategy: Stutery Sound, 40 fps
Banjo Kazooie: Grunties Revenge|Adventure: Emu locks up after Copyright notice
Banjo Pilot|Racing: Black Screen
Boktai 2|RPG: Stutery Sound, 28-30 fps
Bomberman Max2 Red|Bomberman (duh):slightly stutery sound (no fps counter)
Bomberman Max2 Blue|Bomberman (duh):slightly stuttery sound (no fps counter)
Boundish|Pong: runs good, slightly suttery sound, 30 fps
Bust a Move|Puzzle:runs great, 60 fps
Castlevania, circle of the moon|Platform:Slightly Stuttery, 40 fps
Castlevania, Harmony of Dissonance|Plattform:runs great, mostly 60 fps
Castlevania, Aria of sorrow|Platform: runs ok, 50-60 fps
Chu Chu Rocket|Puzzle: Runs great, 60 fps
Coloris|Puzzle:Runs good, 53 fps
Demikids dark version|RPG:slightly Stuttery, 45 fps
Demikids light version|RPG:slightly Stuttery, 45 fps
Denki Blocks|Puzzle: Runs Great, 60 fps
Dial Hex|Puzzle: Runs Great, 52 fps
Digidrive|Puzzle: Runs ok, 30 fps
Donkey Kong king of Swing|Platformer: Runs good, 55-60 fps
Dotstream|Racing(?): runs ok, 40 fps
Egg Mania|Puzzle:crashes (Bad jump c8e8c8cc (200ea78))
F-Zero GP Legend|Racing: Stuttery, 30-40 fps
Final Fantasy 1+2|RPG:Slightly Stuttery, 50-60fps
Final Fantasy Tactics Advance|Strategy: slightly suttery, 30-40 fps
Fire Emblem|Strategy: works good,mostly 60 fps
Golden Sun 2|RPG: Black Screen :(
Golden Sun|RPG: see above :(
Kingdom Hearts|Card/RPG: Freezes on the intro Video
Kirby and the Amazing mirror|Platform: stuttery, 35- 45 fps
Kurkuru Kururin|Puzzle: runs well, 50fps
Legacy of Goku 2|RPG: runs good, 60fps
Legacy of Goku|RPG: I seem to have an unpatched game (this game wont run on the HW found)
GameofLife/Yathzee/Payday|Multigame: runs good, 55-60fps
Lufia-ruins of lore|Adventure: Messed up menu text, otherwise fine, 60 fps
Lunar Legend|Adventure:slightly stuttery, 50fps
Mario&Luigi-Superstar Saga|Adventure: loops the emu after selecting the game
Mario Golf|Sport: Black Screen (Uses Golden Sun engine)
Mario Kart|Racing: Very Skippy, 30fps
Mario Party Advanced|Board:runs good, 60fps
Mario vs Donkey Kong|Platform:runs ok, 40-45fps
Metal Slug Advance|Schmup:runs ok, 45 fps
Metroid Fusin|Platform:playable but skippy
Metroid Zero Mission|Platform: playable but skippy
Onimusha Tactics|strategy: runs nice, 55-60fps
Orbital|puzzle: runs great, 60fps
Phantasy Star Collection|RPG: runs nice, 60fps, redundand, just an emulated version (talk about running an emulator in an emulator o_O)
Pinball of the Dead|Pinball:skippy, barely playable
Riviera-the Promised Land|RPG/Adventure: runs great, 55fps
Shining Force|RPG:runs good, 50fps
Shining Soul II|Adventure: runs fine, 8(eight)-40 fps
Shining Soul|Adventure:runs fine, 50-60fps
Soundvoyager|Puzzle:nice, 60fps
Sudoku Fever|Puzzle:lock up (bad jump ea000044 (30047d8))
Summon Night - Swordcraft Story|RPG: runs great, 60fps
Super Monkey Ball Jr.|Action:Very Skippy, Stuttery, 30fps
Sword of Mana|RPG:runs Great, 60fps
Tactics Ogre|Strategy:stuttery, 40fps
Tales of Phantasia|RPG: Stuttery, Slow during fights, otherwise quite fast
Wario Land 4|Platorm: ok, no fps counter
Wario Ware|Minigames:Unplayable due to graphical glitches
Zelda the minish cap|Adventure:Runs Great, 60fps
Zone of the Enders|Strategy: runs great, 50 fps

Tested with 200 MHz and Sound
 

yodaofborg

Assimilated you will be!
Joined
Nov 5, 2006
Messages
439
Age
43
Location
Manchester, UK
Website
Visit site
Emu@Co that would be nicer listed at http://checklist.berzerk.co.uk/ :)

Here's a crappy vid of me playing a tony hawks game http://www.youtube.com/watch?v=gB1ElyxL5EA I was playing the gp2x in one hand, and phone with the other, I honestly am a little better, heh, but it shows how well it runs at least.
 
Last edited by a moderator:

Rivroner

Very Active Member
Joined
Jun 4, 2006
Messages
1,106
GunPei2X posted on Mar 11 2007 at 04:19 AM said:
Emu&Co, that's super-impressive at only 200mhz.
I´m not sure that results are at 200mhz.I get the same but to 270.
Maybe OC is not runnig well in the emu or Emu&CO typed wrongly the number :D
 
Last edited by a moderator:

hilarycheng

Still Fresh
Joined
Feb 16, 2006
Messages
43
Zodttd,


I have played several my favorite game, Super Robot Series. I found that sometimes, the game will hang without any clue. here is my configuration.

Configuration : Scaled 3:2, No Filtering, Default FrameSkip, Audio On and Buffer at : 1024

Anyone has similar problem ?

Regards,

Hilary
 

Rivroner

Very Active Member
Joined
Jun 4, 2006
Messages
1,106
hilarycheng posted on Mar 11 2007 at 07:35 AM said:
Zodttd,


I have played several my favorite game, Super Robot Series. I found that sometimes, the game will hang without any clue. here is my configuration.

Configuration : Scaled 3:2, No Filtering, Default FrameSkip, Audio On and Buffer at : 1024

Anyone has similar problem ?

Regards,

Hilary
Yes, you can read it in the general thread.
Zodttd is fixing it and adding performance and he will release (private) it tomorrow or in a couple of hours i suppose.
 
Last edited by a moderator:

UMXPrime

Still Fresh
Joined
Sep 30, 2006
Messages
79
Well I have the hang problem in every game I tested.
Just to mention.
Keep the good work Zod !!!
 

MrHillBilly

Still Fresh
Joined
Aug 23, 2006
Messages
82
UMXPRime posted on Mar 11 2007 at 10:17 AM said:
Well I have the hang problem in every game I tested.
Just to mention.
Keep the good work Zod !!!

I was having that prob. and I chaned GBA BIOS and that seemed to fix it. It did not do it in the version B4 this one.


Hey anyone want to buy a GBA? No I still need it to make roms, but that is going to be about the only thing it gets used for now.




Karnaaj Rally is working with a few glitches in the game play running 40FPS, with the GP2X clocked to 260MHZ, but the audio is about 2 Sec. off. I have tried every version I could get ahold of and I ripped my own from my cart. and it still does it.

I just wanted to pass that on.

About 80% of what I have tried has worked GREAT at 230MHZ. I can not wait to see the next version.
 
Last edited by a moderator:
Top