Firmware 1.2.1 Released


craigix

Mega GP Mania
Joined
Feb 3, 2003
Messages
11,010
Location
England
Website
twitter.com
It's not gamepark, its dignsys the people who magiceyes made gamepark use. They are shit. And there is nothing gamepark can do as they have signed a contract with magiceyes.
 

chris_r

Member
Joined
Jun 16, 2004
Messages
745
With any luck there will be a loophole in the contract, so they could break the contract because of the their unlwaful non-gpl compliance :blink:
 

BBTroll

Member
Joined
Sep 30, 2005
Messages
160
GPH might have had better luck buying a license from M$ and using WinCE/PocketPC, than Linux with Dignsys.

Death to Dignsys. :angry:
 

Eso Rimmer

Member
Joined
Jul 30, 2005
Messages
209
Age
38
Location
Czech republic
Website
www.emulatory.net
There is a post on the English GPH website which says that firmware 1.2.1 does not support 2gb sd cards.

I don't understand why there are such a serious bugs in newer firmwares... They should improve it with every new release instead of crashing things which worked in previous release. :(
 
Last edited by a moderator:

Planet_M

Still Fresh
Joined
Nov 23, 2005
Messages
83
It's not gamepark, its dignsys the people who magiceyes made gamepark use. They are shit. And there is nothing gamepark can do as they have signed a contract with magiceyes.

This is the second thread where craigix has tried to shift the blame to dignsys/magiceyes instead of gamepark regarding the crappy firmware. Essentially we have bought a gamepark console, gamepark are responsible for supporting it - for the end user the issue is 100% with gamepark. If gamepark need to take the issue up with dignsys/magiceyes then that is their issue, not ours.

I am also puzzled as to why there is an issue here at all, surely if this is an open source console then ALL the code should be open source (although I can understand/accept a proprietary closed source source DRM module being required to run commercial content). Dev's should be able to fix these issues as they see fit and re-compile better working firmwares.

My grasp of gp2x dev'ing, open source and linux are all limited, but am I correct in the assumption that the requirement to have magiceyes/dignsys involved means that this supposedly 'open source' console is reliant on proprietary closed-source code for some basic tasks?

Why can't we see open source, non-gph/magiceyes/dignsys compiled firmwares, with fixed SD card support, video codec support, etc? Is it purely that they have not happened yet? or is it not possible given the current open source content provided?
 
Last edited by a moderator:

ptom98

Still Fresh
Joined
Jan 12, 2006
Messages
3
just installed 1.2.0 and then 1.2.1, interestingly all the updates seem to be there and working, cant test the sound issues people are chatting about as my batteries are so low at the mo, but one thing i have noticed is the inital loading screen still reads v 1.1.0 whilst in the Settings -> Info the version reads 1.2.1, anyone got any ideas?
 

GeminiDomino

Member
Joined
Dec 17, 2005
Messages
374
It's not gamepark, its dignsys the people who magiceyes made gamepark use. They are shit. And there is nothing gamepark can do as they have signed a contract with magiceyes.

Does Korean law allow contracts to force one to remain a party to illegal actions?

Interesting...
 
Last edited by a moderator:

reallynotnick

The smartest newb
Joined
Aug 20, 2005
Messages
871
Website
Visit site
just installed 1.2.0 and then 1.2.1, interestingly all the updates seem to be there and working, cant test the sound issues people are chatting about as my batteries are so low at the mo, but one thing i have noticed is the inital loading screen still reads v 1.1.0 whilst in the Settings -> Info the version reads 1.2.1, anyone got any ideas?

It is either one of the two (I forget which one)

1. You just applied the patch and did not get the 'firmware updating' screen at startup

2. You just got the 'firmware updating' screen at start up and have not applied the patch. All you have to do is apply the patch to fix this.
 
Last edited by a moderator:

Drag

Member
Joined
Jan 11, 2004
Messages
371
Age
33
Location
USA
Website
drag.wootest.net
I think it's 1.

Ok, I didn't upgrade to 1.2.0, so if I were to go straight from 1.1.0 to 1.2.1, would I need to apply 1.2.0's patches? It's been clarified to me that I don't need to upgrade to the 1.2.0 firmware and then 1.2.1 firmware, but I don't know about the patches.
 

Paradox

oh em gee
Joined
Nov 15, 2005
Messages
1,748
Age
34
Location
England
Website
Visit site
Why can't we see open source, non-gph/magiceyes/dignsys compiled firmwares, with fixed SD card support, video codec support, etc? Is it purely that they have not happened yet? or is it not possible given the current open source content provided?

i'd like to know this also, i would have thought devver's would have added things like more compatability in the movie and audio player, so they can play more formats etc, same in the picture viewer
 
Last edited by a moderator:

timbobsteve

Member
Joined
Oct 4, 2005
Messages
301
So I finally got the damn thing fixed and completely updated and patched, thanks "in part" (read: none at all) to you guys! Thanks for all your help, fellas!

Don't be rude. Just because you asked a question.. doesn't mean that anyone has to help you. Your problem had been asked many a time throughout these forums and there was always a sollution provided. Don't get snappy just because someone didn't wrap it up nicely and mail it into you PM-Box.
 
Last edited by a moderator:
Top