display link change of resolution


sepulep

Member
Joined
Nov 18, 2008
Messages
365
I noticed that changing the resolution with the displaylink driver fails.

for example, I turn on the display with the monitor attached it detects the 1024x768 resolution.
If i set the modelines etc in the xorg for 800x600 it will allow you to change through the xfce display setting,
but the picture produced is garbage (well not random garbage, it looks like lines are messed up) -
the video signal is produced ok though (reported by monitor).

On the other hand, if you start w/o monitor attached, the udlfb reports 800x600 as its default/ initial resolution
and then 800x600 will work, but 1024x768 fails (again signal is ok, but picture not)..it looks like the framebuffer
memory does not get reinitialized correctly after the initial allocation..

anyway..I don't know if anyone else ran into this...
 

Askarus

Hardcore Member
Joined
Sep 28, 2011
Messages
4,456
Location
Germany
I was using DisplayLink myself for some occasions.
There was that thing that I had to start the session with DL connected.
Then logout and login again and it will work with the monitor attached.

The whole thing was not "hotplug" or anything like that.
Might be that it is not possible on the Pandora to set a different resolution because of that.
To me it seems that the Pandora DisplayLink is functional but not the perfect implementation that fully supports any feature.
AFAIK it was @Linux-SWAT and @hmc who implemented it.
Maybe they know more. Both are no DisplayLink experts and we all were happy (well, they and me. I don't know anyone else who used that feature) that it worked.
 

sepulep

Member
Joined
Nov 18, 2008
Messages
365
it is pretty nice! surprisingly good for some games (e.g. openxcom), i was trying to eke out a bit more fps...its not a terribly important bug, but maybe i overlooked something obvious..
 
Top