C4A Manager now on repo.. beta, please test it :) (Create your C4A Profile without using c4a-mame no


Internal Development
Mar 11, 2003
I've just uploaded this to the repo:


Its a slimmed down version of the existing c4a-mame launcher - it handles C4A Profiles (and in the future, more stuff), but doesn't do any game launching or the like. Please give it a test :) This should help get C4A into more peoples hands, without having to suck down the rather enormous C4A Mame. (Some few people don't want an arcade emu; I know, weird, right? ;)

If this goes over successfully, we may include it in the firmware in some form or another.

That is nice, but why aren't you using the graphics I made specifically for this?
OK, don't actually need this if you already have C4A, right?

Or does this replace C4A.  You did say it doesn't launch games...and the Hub does not yet launch MAME direct...
This is just for profile management; say you want to try a c4a game but don't want to download MAME to do it; really, i should drop thr profile stuff out of c4a-mame and just have panmame talk c4a..

So try c4a manager out to let me know it works or not .. But you kumaki don't need it since you already have a profile..

Someone try it with network off, make sure it gives a sensible error..

If you want, I can send you my latest PanMAME sources and you can get maintainerrights if you want to combine the two.
You likely have more free time? In reality, the main diff is the launcher knows how to sync; the mame build just has limited dip and no savestates and such..

.. If we just trust people, and add my launcher to your pnd.. A second app in the pnd, running same mame .. We should be good! I could just drop it into your mame..

How about i just get your panmame, merge stuff in, give you the pnd to recompress, and you maintain it after.. No real changes to the c4a-de for awhile?

Thats ok. I don't have any freetime right now too though...
Is there any requirement that I'm not aware of? It doesn't seem to start on my Pandora. Thanks.
Shouldn't be..

Shows up in menu?

Can you see any errors in the /tmp/ pnd run log?

Tried with and without wifi?

I tried with and without wifi, same result.

Here is the log:

PND             : /media/P1/pandora/menu/compo4all-manager.pnd
APPDATADIR      : /media/P1/pandora/appdata/c4a-mame
APPDD_FSTYPE    : vfat
PND_CPUSPEED    : <unset>
EXENAME         : scripts/start.sh
ARGUMENTS       : <unset>
[ START ]--- Mount the PND ----------
Mounting : mount -o ro "/dev/loop0" "/mnt/utmp/c4a-mame"
Mounting the Union FS : mount -t aufs -o exec,noplink,dirs="/media/P1/pandora/appdata/c4a-mame=rw+nolwh":"/mnt/pnd/c4a-mame=rr" none "/mnt/utmp/c4a-mame"
[SUCCESS]--- Mount the PND ----------
[ START ]--- Starting the application ( scripts/start.sh  ) ----------
./scripts/start.sh: exec: line 46: /mnt/utmp/c4a-mame/bin/gtkdialog: not found
[ FAILED]--- Starting the application ( scripts/start.sh  ) ----------
[ START ]--- Restoring the frame buffer status ----------
[SUCCESS]--- Restoring the frame buffer status ----------
[ START ]--- uMount the PND ----------
[ START ]--- Waiting the Union to be available ----------
[SUCCESS]--- Waiting the Union to be available ----------
auplink:plink.c:223: AUFS_CTL_PLINK_MAINT: Inappropriate ioctl for device
rmdir: failed to remove `/mnt/utmp/c4a-mame': Device or resource busy
[ START ]--- Waiting the PND mount dir to be free ----------
[SUCCESS]--- Waiting the PND mount dir to be free ----------
cleanup done
[SUCCESS]--- uMount the PND ----------
Return code is : 2
It is but i might've copied in the wrong script when building it in a rush :) it runs for me, i pubbed it :)

Does it work for anyone? Given little feedback its hard to know ;)

I'll see about checking the script late tonight if i get a mo'


It lives in same appdata as c4a-mame mind, due to ancestry
I've updated it in the repo.. take a look.

New banner artwork (courtesy of mcobit!); same icon still.. I really like the joystick icon ;)

I've verified it does error nicely when network is unavailable; the problem with previous release was it'd get confused when you'd never used c4a-mame before.. should be fine now; it of course still works with existig c4a-mame.

It still uses c4a-mame appdata, due to history .. keeps things simple and unconfusing.

Assuming all is well, we can roll this into firmware..


I recently suffered data corruption on my SD card, had to format everything in order to start from a clean slate.

I just have downloaded C4A Manager again, but I don't remember the password I set for my C4A profile :(

What should I do ?

Thanks for your help,

Magic Sam
PM me your email address, one of these days soon I'll see if I can email attach you your c4a-prof file .. I really should rerlease the recovery tool; maybe this will inspire me :p