Broken/loose digitizer cable


jontheramer2

Member
Joined
Oct 13, 2012
Messages
44
After years of solid use, last night my Pandora started to act erratic to input. Touching the screen would make the arrow jump all over the place. I rebooted and had the same behavior. I calibrated the touchscreen and that makes the input not work at all when done. And sometimes, I cannot get out of the calibration tool because it's no longer registering inputs.

When I have a terminal open and I move the screen, I can see the xterm losing focus, so it thinks I touched the screen?

What can I do? It seems a hardware issue; can I fix it myself (I am handy with electronics but I guess I'm asking if I need a new flatcable or if it is easier than that)?

Also; how do I disable touch input? Everything works fine with the nubs but sometimes I get many ghost clicks which prevent me from doing work; I think if I disable touch, that will be solved.

A depressing day for my trusted Pandora :)
 

_jr_

Advanced Member
Joined
May 5, 2013
Messages
1,170
Sometimes the screen bezel pops out at some side and presses on the touch screen. In that case just reseating it should fix the problem.
 

jontheramer2

Member
Joined
Oct 13, 2012
Messages
44
Well; the bezel does not seem to be popped out and I resetted a 100 times (also because I cannot get out of the calibration tool if the input is not working; I tried pressing all buttons and I didn't have anything else that can do ssh at that moment).
[doublepost=1492421616,1492421120][/doublepost]It seems that when the digitizer does work, it only works in the middle of the screen and very erradic (like the mouse pointer I try to move at that time is 1+ cm removed from where I would expect it and it 'wobbles' aka it moves 5mm back and forth while moving it); when I 'have' the mouse pointer moving with the pen and I move it close to the edges of the screen, stuff will really mess up aka generating input clicks and movement randomly all over the screen. It takes a lot of randomly tapping and moving the arrow with the nubs to get it back to 'normal' after that.
 

jontheramer2

Member
Joined
Oct 13, 2012
Messages
44
And that happened all of a sudden? I will try that. Maybe you both are right... It just happened so suddenly while I was working on it and I definitely did not touch the lid, but maybe it slipped a nanometer.

Try loosening the Inner lid. I had the same a while ago. It happened because the inner lid was pushing against the digitizer on the sides of the screen.
[doublepost=1492589032,1492570781][/doublepost]After messing around with the screen casing the digitiser indeed started working again. So you were right! Thanks so much! Seems the thing is indestructible after all!
 
Top