XFCE tips - Desktop icon size/placement/taskbar


relliker

Member
Joined
Oct 16, 2009
Messages
290
Age
52
Location
EU
Tips:


1) Fit many more icons onto your desktop than the default allows you by going to:


Settings --> Desktop --> Desktop --> Icons (tab)


and change the icon size down to around 30. This way the icons are much smaller but still pleasantly readable.


2) Move icons around on the desktop to organise them thus:


a) Touch (or click) once on the icon you want to move to highlight it


B) press and keep pressed the left mouse button (or move right nub to the left)


c) Touch the screen where you want the icon to move to while still keeping the left mouse button pressed.


You should touch the screen where the icon text would be in the new position as the icon won't move otherwise.


3) When your desktop is chock-full with icons put new programs in the "menu" directory instead of the "desktop" or "apps"


directory so that they appear in the XFCE menu but do not put their icon on the desktop.


4) Use an auto-hide task bar so that it does not get in the way of programs running in full-screen mode, especially when they have


buttons to press at the bottom! Change this by by going to:


Settings --> Desktop --> Panel


and tick the Autohide box. I also set the task bar to full width and fixed position but you may have other preferences.


Result: (Hopefully) A much more organised and pleasant Pandora XFCE desktop experience!
 

pmprog

DNF (Did Not Finish)
Joined
Apr 25, 2011
Messages
4,150
4) Use an auto-hide task bar so that it does not get in the way of programs running in full-screen mode, especially when they have


buttons to press at the bottom!
Does this not break the Pandora button script? Granted, the work around for that is disabling the script and setting the menu up in the global hotkeys (that's what I do).


I also usually align my taskbar to the right hand wall. As more often than not, I need the vertical space over the horizontal.
 

relliker

Member
Joined
Oct 16, 2009
Messages
290
Age
52
Location
EU
4) Use an auto-hide task bar so that it does not get in the way of programs running in full-screen mode, especially when they have


buttons to press at the bottom!
Does this not break the Pandora button script? Granted, the work around for that is disabling the script and setting the menu up in the global hotkeys (that's what I do).


I also usually align my taskbar to the right hand wall. As more often than not, I need the vertical space over the horizontal.

No, the Pandora button script still works. EDIT: but you have to make the taskbar visible. Sorry, at first I thought you were referring to the task killer function of the Pandora button.
 
Last edited by a moderator:

fusion_power

Advanced Member
Joined
Dec 25, 2005
Messages
13,217
Location
germany
Website
Visit site
I'm still searching for a way to get more icons on the Desktop WITHOUT resizing them. So I want to reduce the Icon spacing on the desktop "Grid". I know this should be possible, but how? There is alot of space in between my Pandora Destkop Icons and I could easily get more rows and columns on screen, with unchanged Icon size. So where is the Icon spacing hidden so I can change it?
 

relliker

Member
Joined
Oct 16, 2009
Messages
290
Age
52
Location
EU
I have been through most of the xfce settings (the ones accessible from menus) and have never encountered settings to do with the grid spacing. Unless it can be done manually in some obscure config file from the command line I am almost sure that XFCE does not allow for grid space resizing. Seems resizing is possible for the panel, icons, fonts and window borders/wrapping etc. but not the icon grid itself.
 

iprice

Certified Guru
Joined
Jan 31, 2008
Messages
3,281
Age
51
Location
MK. UK. OK.
Website
Visit site
I'd like more icons on the screen too (with less space between). There seems to be a lrge space on the right of the screen with nothing on it too.


One question I have - Why do random icons appear when the SD card is removed and re-inserted (without adding/removing anything)? Is this a feature to remind you that there are other apps available? There doesn't appear to be any logical order to the way they are displayed either.
 

DaDaDaniel

Still Fresh
Joined
Jun 1, 2012
Messages
61
RTFM! Just kidding. ;) The xfdesktop readme states how the grid size can be reduced. I copied the readme from 4.6.1 to pastebin: http://pastebin.com/4dcbM3T3


You will have to edit the .gtkrc-2.0 in your home directory. It's already there, as some settings are customized by default. I added the following lines to the style "xfdesktop-icon-view" section:



Code:
XfdesktopIconView::cell-spacing = 5

XfdesktopIconView::cell-padding = 10

XfdesktopIconView::cell-text-width-proportion = 1.5

That makes one cramped desktop.



Also I modified the size of the steppers on scrollbars. The default scrollbar has a comfortable width, but the steppers are way to small. Add this line to the style "scroll section to make them bigger:



Code:
GtkScrollbar::stepper-size = 25


To activate any changes in .gtkrc-2.0 you will have to restart any program that uses them, or simply logout and login again. To test changes in the desktop sections it's easiest to simply killall xfdesktop from a terminal, it should automatically restart. If it does not, run xfdesktop by hand.
 

relliker

Member
Joined
Oct 16, 2009
Messages
290
Age
52
Location
EU
so the obscure-cli-config-file theory was unknowingly correct :D
 

fusion_power

Advanced Member
Joined
Dec 25, 2005
Messages
13,217
Location
germany
Website
Visit site
RTFM! Just kidding. ;) The xfdesktop readme states how the grid size can be reduced. I copied the readme from 4.6.1 to pastebin: http://pastebin.com/4dcbM3T3


You will have to edit the .gtkrc-2.0 in your home directory. It's already there, as some settings are customized by default. I added the following lines to the style "xfdesktop-icon-view" section:



Code:
XfdesktopIconView::cell-spacing = 5

XfdesktopIconView::cell-padding = 10

XfdesktopIconView::cell-text-width-proportion = 1.5

That makes one cramped desktop.



Also I modified the size of the steppers on scrollbars. The default scrollbar has a comfortable width, but the steppers are way to small. Add this line to the style "scroll section to make them bigger:



Code:
GtkScrollbar::stepper-size = 25


To activate any changes in .gtkrc-2.0 you will have to restart any program that uses them, or simply logout and login again. To test changes in the desktop sections it's easiest to simply killall xfdesktop from a terminal, it should automatically restart. If it does not, run xfdesktop by hand.
Thanks, this seems like what I've searched for. :) I'm sure I once played around with the .gtkrc-2.0 file but I never got any results. I guess I also never added new command lines so it may be the reason why it never worked. What are the default valus for the Icon Spacing on the Pandora XFCE Desktop by the way? I guess they are huge.
 

DaDaDaniel

Still Fresh
Joined
Jun 1, 2012
Messages
61
I don't know the defaults, but I don't think the spacing is set ridiculously high. The single most important setting to get more icons on the desktop is the cell-text-width-proportion value. If set to 2.5 a single 48px icon will use 120px + spacing.
 

fusion_power

Advanced Member
Joined
Dec 25, 2005
Messages
13,217
Location
germany
Website
Visit site
I've checked my home directoryy and I don't even have a .gtkrc-2.0 file there. I enabled hidden files in Thunar of course. So I just made the file and put the commands in but nothing happend (reboot of course), maybe I did the file wrong or I just put it on the wrong place. :unsure:
 

MarioPandio

Well-Known Member
Joined
Aug 28, 2010
Messages
1,378
Location
Half way up the stair
If you set desktop icon size down to 28, you can get an additional line of icons in and still have space for wbar at the bottom or right hand side.


You can move icons more easily by simply dragging the icon to a free spot and then hitting L shoulder button as you release the white square that represents the icon. You no longer need the right nub method and perhaps never did, as this also worked on HF4.
 

DaDaDaniel

Still Fresh
Joined
Jun 1, 2012
Messages
61
I've checked my home directoryy and I don't even have a .gtkrc-2.0 file there. I enabled hidden files in Thunar of course. So I just made the file and put the commands in but nothing happend (reboot of course), maybe I did the file wrong or I just put it on the wrong place. :unsure:
That's strange. It's certainly there in my home directory (latest beta5a, user created with setup wizard).


If it's not there you have to add the style section and widget_class rule as well.


It should look something like this for the desktop settings.



Code:
style "xfdesktop-icon-view" {

  XfdesktopIconView::cell-spacing = 5

  XfdesktopIconView::cell-padding = 10

  XfdesktopIconView::cell-text-width-proportion = 1.5

}

widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view"

I can't check my Pandora right now, or I would post my whole file.
 

fusion_power

Advanced Member
Joined
Dec 25, 2005
Messages
13,217
Location
germany
Website
Visit site
I'm still on Hotfix 6 so maybe this is the reason. I forgot the last line with widget_class "*XfdesktopIconView*" style "xfdesktop-icon-view" so of course this is likeley the problem why it was not working, I'll test it later, thanks so far. :)
 

pmprog

DNF (Did Not Finish)
Joined
Apr 25, 2011
Messages
4,150
I added the cell-spacing and cell-padding lines to my .gtkrc-2.0 file, and rebooted, but it didn't make any difference. Ideas?
 

DaDaDaniel

Still Fresh
Joined
Jun 1, 2012
Messages
61
Did you add XfdesktopIconView::cell-text-width-proportion = 1.5? That's the most visible one.
 
Last edited by a moderator:

pmprog

DNF (Did Not Finish)
Joined
Apr 25, 2011
Messages
4,150
Ah, great. Thank you... I didn't put that in, because I kind of assuming cell padding and spacing where the major contributors... Suppose I should have just tried adding it anyway :)
 
Top