WiFi mysteries resolved once and for all — Power saving is clearly the culprit!

Is there any way you could get a setup where your pandora and your router were the only transmitting wifi devices within range?
Is there any way you could get a setup where your pandora and your router were the only transmitting wifi devices within range?
Good idea.  Finally I have a reason to continue my "subspace dampening field" research.  I knew that all of these years watching Star Trek reruns would come in handy...
@F_Slim: I am far beyond that point (if interested: see this whole thread and the massive amount of my already performed tests and falsifications).

@Binky: Testing in an isolated WiFi environment, as mentioned earlier in this thread, is one of my last outstanding tests. Nevertheless, even if it would work then, it would not be satisfying, as the Pandora should be able to transmit in normal WiFi environments, as all other common WiFi devices do.

@Franko got that point, made his joke about that ;-)
Last edited by a moderator:
The strangest thing just happened to me: I got the Wifi-issue! Out of the blue basically. No page would load in Firefox unless powersaving was disabled. It worked fine an hour or so before!!

So I checked for other interfering Wifi-Hotspots using the same channel: nothing. BUT: something else on the same frequency. After I changed the channel everything is fine again.

I also noticed another network within the same 20MHz bandwidth which moved away after I changed to a closer channel.

So the problem was either caused by the interference on the same channel or by the other network in the bandwidth.

This is the first time this ever happened to me, just a few days ago I've been in a room with at least 20 other people using Wifi and had not problems at all.
I visited my parents last weekend with a pandora, and it turned out they have "incompatible" router with wifi power saving. PS is working fine here at home and disabling it doesn't give much positive effect, but there it went from 10-20KB/s with PS to ~350KB/s without (maxing out their Internet connection). However occasionally that router works fine with PS too, so as usual it's all inconsistent and confusing.

So when it went bad, I was able to do a bit driver-level debugging and found, with certain level or confidence, which firmware commands were causing problems. I've also found out that Linux wifi stack (mac80211) is trying to do dynamic power saving, i.e. it automatically turns off power saving when there is data to transfer and turns it back on when queues are empty for ~100ms. But what I found later is that this wifi chip is not very happy to change powersave modes too often, it takes it ~150+ ms to turn on PS and ~50ms to turn it off. Meanwhile, depending on load, stack may be switching states at 100ms internals, which means the chip is often interrupted in it's PS change sequence, which causes it misbehave. I did not have time for much coding at my parents' and had to go home (it's over 3h drive to them so I don't go there too often).

So I did some driver tweaks during this week, mainly to stop it switch PS states too often. I've also optimized scheduling a bit (moved transfers to dedicated thread to avoid context switching), optimized firmware command polling and register reads (see http://git.openpandora.org/cgi-bin/gitweb.cgi?p=pandora-kernel.git;a=shortlog for code changes). With this I seem to get a bit of performance improvement and more stable transfers here at home. I don't know if it fixes problems with my parents' router as I won't be able to test with it for some time.

The wifi tweaks are available along with slightly newer kernel through "System->upgrade pandora OS". Everyone's invited to test.
Last edited by a moderator:
Works fast without any command line tweaks. Thanks Notaz!

Forgot to say this won't help if your wifi is slow without power saving, which is the case with my CC pandora.

skeezix reported no improvements too, but I'm not sure on what kind of unit.
I've only tried my 1Ghz unit, I can try my Rebirth and CC units this weekend. My 1Ghz unit wasn't as good as my Rebirth where WiFi is concerned, but better than my CC unit.
Last edited by a moderator:
Amazing. My wifi was always horrible and that's made it obviously more stable.. how stable is unknown.
So, what if your wifi is sufficiently unreliable that you can't download the update? :(
So, what if your wifi is sufficiently unreliable that you can't download the update? :(
Plug in a USB Ethernet or Wifi adapter and download it.. or wait for the next full updater to come out so you can do an SD card update.
It does seem to be better with the update. Posting this will be the best test, since I am far away from the router here, and usually sending a post on the forum is impossible unless I turn off powersaving. (Works fine closer to the router).

So .. here we go! (click)

... nah ... Firefox failed as usual. Now trying Arora ... (click)

[EDIT:] ah, so that worked! So Wifi did improve! (Also judging from the responsiveness of other websites in Firefox)

On the other hand, sending this EDIT fails again also under Arora ... so maybe the forum isn't such a good test after all.

Anyway, thanks again Notaz. Overall I still think it got better when being far away from the router.
Last edited by a moderator:
Last edited by a moderator:
wow, just... WOW !!  :eek:  I had a vnc session open and went out to the balcony, every time I did this I always had to reconnect it to the router at my return, but now the session was still open and working !!  ^_^
WOW indeed!

I got a 1GHz Pandora and after the wifi update I can do loads of stuff that wasn't possible before:

Via Wifi I

  • Successfully refreshed the PNDManager List
  • updated some 27 MB file using PNDManager
  • meanwhile I surfed the net with Firefox
  • connected my PC via WinSCP and uploaded 180MB PNDs (11 files) to the Pandora (with disconnects though)
The changes have a tremendous positive effect on WiFi performance! Thanks a lot!

The disconnects I got with WinSCP are due to the pandora not responding any longer. That changes and is not a problem anymore if I ping my router from the console ("ping"). Manybe the wifi config could be treaked any further to fix this?

Also, the Pandora does quite a few seconds (5-10) of "waiting for site" but all sites I tried eventually loaded completely (Firefox).

After Porgs extensive but fruitless attempts at hacking the wifi I almost lost hope in ever having a Pandora with normal wifi capability. Now all of a sudden the usefulness of the wifi changed from 30% to 90% for me! Hurray!
I made some tests and the problem I have with my PC (Pandora wifi looses connection if my PC is connected through wifi too) is unluckily still there :(