[SOLVED] PNDs won't execute


Still Fresh
Apr 10, 2012
Hi All

I'm not sure what I'm doing wrong here but I can't get certain PNDs to open/execute. So far I've installed Midori browser and have a bunch of emulators and rooms working fine but when I try to install/open Chromium, Firefox , or Fennec nothing happens.

I then tried installing the latest hotfix but had the same problem with that. I've searched the forums and googled multiple times but I can't find a solution.

- the SD card isn't write protected

- Thunar is in icon view not list view

- I've tried putting the PNDs in pandora/desktop, pandora/menu, and, pandora/apps with the same result.

Any assistance much appreciated.


I assume by open you mean running them from the menu, not double-clicking the PND's?

If you are trying to run the from the menu: Output from the PND-system and programs is directed to /tmp in pndrun_<appdata-name for PND>.out, these files might help with figuring out why it doesn't run.
Thunar? You're clicking the icons in the menu or desktop, not trying to execute the PNDs in Thunar, right? PNDs are not binaries and have no program associated with them by default.
I had a problem sounding similar to this a few weeks back everything worked for me except emulators, it turned out I had a corrupt memory card, after I tried everything you have already tried. I copied the contents of my memory card to my PC. Then formatted the memory card and copied everything back onto the SD card, and it all works fine now. Could be worth ago.
Thanks for your replies. Well, therein lies the problem - they're not showing in the menu or on the desktop regardless of which folder I put them in so I tried right click>execute from within Thunar (which worked for Midori) but it doesn't work for the mentioned apps.

phelsumania - Thanks for the suggestion I'll give that a go tomorrow.
If the above suggestions don't work I would download and reinstall the latest hotfix. I had a similar issue and that resolved it.
Last edited by a moderator:
Thanks everyone. I installed Beta 5a, reformatted the SD card, and redownloaded the apps and it's all working now.