How do I start PNDs from Thunar again?


Apr 26, 2010
After I flashed to the latest ROM 1.54 I lost the ability to open .PNDs by double-clicking them in Thunar.

Somehow in the past I got it to work (together with a cute Pandora Icon for PNDs instead of the default binary-icon) but I have *no* idea how I did it and I can't find the (very old) thread where someone told me, how to do it.

I thought, pnd_utils did it, but I tried that and it didn't do anything.

I think I remember, that I edited some file for the MIME types...

Because I try a lot of new PNDs and sort them in different Folders (and only keep the important one on the desktop) this has really become part of my workflow.

Can anybody help me? :)
Thanks for the link!

I did what it said, and now I have a "run" entry in the right-click context menu, but double-clicking still doesn't work.

Where are those file associations for the MIME types located? Maybe I need to enter it there too.
Heh, I found the old thread, from almost exactly 2 years ago:

WizardStan helped me fix it last time and the fix still works:

"As super user (sudo) edit the file "/usr/share/mime/globs" and add to the very bottom "application/pnd:*.pnd", and the file "/usr/share/mime/globs2" gets "50:/application/pnd:*.pnd"
Not sure why globs2 gets a "50:" but it's needed to make it work. Other numbers might also work, but since I have no idea what it's for I'm not going to mess with it.
Now *.pnd files are no longer identified as generic applications that it will try to run if you double click them. Now they are documents of type application/pnd, which you can associate a program to open them with."

So thanks again! :)
Last edited by a moderator: