Scummvm 1.0.0

Neil L said:
DurTahar said:
It seems that the mouse and/or sprite trail thing seems to be in a lot of games. I hope there will be a fix for that in future releases!

I think it's to do with the scaling on the games. I think the game screen has been scaled down to fit the Wiz screen, but the cursors haven't been scaled properly.
Because I've noticed on The 7th Guest the triangular cursor (on the menu screens) needs to be over the top rather than pointing at the required option (when not using the touchscreen) and sometimes it appears half size. (Is this the size it should be?)
Hopefully this will be fixed soon.
Cheers, Neil

I've googled pictures of the 7th Guest running on the PC and the cursor on the Wiz is twice the size what it should be, this is probably causing the sprite trail and having to click with the centre of the cursor. Is there anyway to stop the sound breaking up on the cut scenes?

I've completed more puzzles since my last post with no major problems. :)

Cheers, Neil
Last edited by a moderator:
I'm not sure about stopping the sound from breaking up, but there's probably some way. Before SCUMMVM supported The 7th Guest I spent years trying to get it to play properly in XP and it never ever played sound in any sort of good way so I guess that's why I'm not bothered at all by the sound popping just a little :)
I have put scummvm on the sd, copied the game files in a folder and added the games to the scummvm's list.

only the games don't launch. what am I missing? does it need timidity or do I have to tweak something?

didn't find an answer in the readmes.

the games I have tried to use are Fate of Atlantis, Maniac Mansion, Day of the Tentacle and Sam and Max, the same files work in the linux scummvm.

edit: ok, I just deleted scummvm and then did it all over again and it worked. sorry for the panic post, no problems for now.
Is anyone having issues with saves? I've been playing Flight of the Amazon Queen, and have had issues saving. Sometimes it will make a new entry, and then freeze. Sometimes I am able to save over an existing entry without issue but sometimes not?

When it freezes, I need to reset the Wiz. And when this is done, SCUMMVM will no longer launch... it just goes black and then comes back to the Wiz menu.
yesterday it wouldn't let me save the game in fate of atlantis. no freezes, just failed at saving. after resetting the wiz the problem disappeared. I think it was having problems writing on the sdhc card, don't know why.
rex303 - I have started playing Fate of Atlantis as well. I've been able to save okay sometimes, but have had to turn off AutoSave. Occasionally when I save... it freezes up -so of course AutoSave will generally be a bad idea.

Anything I can change/re-configure to eliminate this problem???
I don't really know, I have left everything at default since at first scummvm stopped working with any game and I had to delete it. after that I have been touching less settings as possible, I usually just tweak the subtitle speed which is too slow in some games.

I also left autosave on, the fail at saving only happened once, I got as far as the balloon ride but haven't been playing much scummvm lately, so I haven't played through the whole game yet.
Well, being that the Wiz SCUMMVM version was ported from the original GP2X version, here is the ScummVM compatibility list on the GP2X:

Most games have "Save Issues" ...

Kind of sucks since all adventure games generally require many hours of playing. A lot of time wasted if you can't save :(
that's why I leave autosave on, if there are any problems saving you will know after 5 minutes (if the autosave works it works "silently", but if there are problems an error message pops up), and if there are no save problems but any kind of crash/freeze you still have an autosave to go back to.

clearly I still save manually as well, I just find the autosave a good feature.