Love Cramfs But...


Still Fresh
Jun 27, 2003
Dallas, TX (United States)
Visit site
I know there is a topic about the strange pauses that the GP2x has from time to time in emulators and programs but as I can tell there has been no solution to the problem yet.

I recently updated my Firmware to the wonderfully fast cramfs version of 1.4 and I love the boot up speed! Unfortunately I am now suffering from the strange 1/2 second to 1 second pause problem that I have read about. I had absolutely no pauses when I was using 1.1.0 with the Patch for 1.1.0. Clean bootscripts, read-only NAND, enable ext2 formated cards.

I hate to go back to 1.1 so I guess I'll just have to live with the pauses but I was wondering if anyone else noticed this when switching from 1.1 to 1.4?

I've had this problem, too, but I'm pretty sure I've noticed it on every firmware version I've tried, cramfs or no. Most recently I've noticed it when playing mame2x. Sometimes the game (any game) just hangs for a half second or so. I've always assumed it was something bizarro going on with linux in the background, such as synching the SD card.
I experience the same slow downs in gnuboy. I am not sure though if I have had the problem before upgrading to 1.4 cramfs... the slow downs are not as long as a second or even 1/2 though...
either .. sync just needs to be happening more frequently (if there is too much to synch, it stalls; thus early-sync's would prevent this) or .. there is a big bug in the SD driver.

guess which one you'll find in #gp2xdev.log? ;)
I have the same problem, though the pauses are usually closer to 2 seconds. However, it hasn't really proven to be an immense bother, so.... :)
It's my fault, related to the way I'm handling the USB-Serial connection. The next round of releases will have much nicer USB handling.

If you want to build a custom image, remove the ttygs0 line from /etc/inittab . But since I have no other way of connecting to my gp2x, this is staying in until I find a stable network driver.

Edit: the 2 second pauses every 5 minutes that is. These are the only ones I've been experiencing.
Its your SD card. Ive got a 150x one and have no slowdowns. Ive tried a 66x one and get occational slowdowns.
I am getting these pauses too in drmdx every so often during a game, it's not a major problem but it would be nice to get rid of. I am just glad I know what's causing it now as I was scared my gp2x was damaged or something.
PSyMastR posted on Mar 16 2006 at 08:23 PM said:
Its your SD card. Ive got a 150x one and have no slowdowns. Ive tried a 66x one and get occational slowdowns.
I doubt it. I never had slowdowns (like these) before I upgraded my firmware. Same card always.
Last edited by a moderator: