HF6 RC 8192CU Wifi Dongle Not Working

Yes, it's one of them Netgearz. :( Right now 'official' Pandora driver does not support it like notaz explained, so you need the driver from the file archive. There are some details right in this thread.

Why it would break your touchscreen and why it doesn't break it for me, bismuthdrummer or mcbearface - I don't know.

P.S. thirty quid? Are they crazy?

Cheers anyway

PS you think that's expensive or cheap?

Nope, no touchscreen problems for me here.

DrCJBoduma, thanks for being persistent with this. If you can be very specific about where precisely the problem occurs, that should shed light on what the problem is. It can't be that mysterious.

So, two questions:

On which step does the touchscreen stop working?

a. Replacing the 8192cu.ko file

b. sudo depmod 8192cu.ko (command line)

c. sudo modprobe 8192cu.ko (command line)
Thanks for the response bismuthdrummer

strange thing is it, in my two attempts, the problems occurred at two different times.

The 1st time it went through the whole processes a.b.c. and worked perfectly. It was only on the next restart that I lost touch screen and connection (either wifi stick or native)

The 2nd time I believe I got to the modprobe bit © and then it froze up and I think I had to reset my panda. upon restart it was the same as the 1st time (no wifi or touchscreen)

On which step does the touchscreen start working?

a. Restoring the original 8192cu.ko file

b. sudo depmod 8192cu.ko (command line)

c. sudo modprobe 8192cu.ko (command line)

d. Never, it does not start working again

d unfortunately

have tried a.b.c. but nothing, only reflashing with hf6 did the trick

The thought process here is that, if you can test the touchscreen at each step in the process, you'll find the step that causes it to break. If you can reverse it, then we know exactly what the high-level cause is, and given those facts somebody like notaz can go down into the black hole of the backend and take a guess at what the problem might be. I have a hard time believing that Hoodoo's driver is causing this, since we should all theoretically have identical hardware and software. But I am hardly an expert here.

EDIT: The "sudo depmod" might be superfluous in the second question -- I am just trying to be rigorous.

The only things I haven't mentioned (but I assume are not key, which probably means they are) :-D

  • I unzipped/packaged the hoodoo driver first
  • I did this on a windows pc
  • I copied and renamed etc the drivers from command line (with mv commands) and not the sudo thunar method.

I am feeling foolish and so might give it one more go, what do you think?

The method of copying the file and the OS on which the archive manager runs do not matter here. Linux is not some voodoo magick (although it can look like that), users just are not meant to poke the kernel or move modules around by hand unless they feel especially curious. But you have a good excuse here. :)

As for all that terminal stuff, it helps to reduce ambiguity (both with diagnostics and fixing stuff) and is just easier to type, consider 'how to change IP address' in Win XP and in Debian. First instruction would most likely involve pictures and "click this and that icon" while the latter would be like 'ifconfig interface new address'. It's geek's Latin. :)

Seems to be hardware quirk of your Pandora or this exact dongle, would be interesting to see if any other dongle causes this, or any other USB device while we're at it.

Last edited by a moderator:
Hi there I've noticed a difference in the advice on where to put the hoodoo driver

Chosen sugested here


Hoodoo suggests here

/lib/modules/ (think is one to many kernels though)

Could this be the issue as I think I used the first one



PS Hoodoo I didn't think the unpacking etc would cause it, but thought I would include it just in case there was some windows or terminal weirdness (permissions etc)

PS Bismuthdrummer - nice username, any reason?
Last edited by a moderator:
No, it shouldn't matter too. In the worst case the module just wouldn't work and that's it.

I still suspect that it's probably a hardware issue, but I'm not qualified to say it's for sure.

notaz also tinks it might be hardware related, but might be not.

One more thing we could take a look at is if touchscreen module is loaded when the touchscreen does not work. It's

lsmod | grep 7864

which lists all loaded modules and then looks for 7864 there. That brings up something like

ads7864 8960 0

hwmon 2516 1 ads7846

If it doesn't, then it might still be software related, but if it does, that might be hardware (or might not be).

Again, would be nice to see how any other Realtek dongle would work.
Hi Hoodoo,

I typed 'lsmod | grep 7864' and nothing happened

I doubt it'll help but it just typing lsmod brings up



Thanks (yet) again

I have to agree, this is seeming more and more like a hardware issue (but no one knows for sure yet!). Some people do have slightly different hardware in at least the fact that some Pandoras may run without battery on charger alone, but some Pandoras cannot. Whether or not that has any bearing here... well, you know the answer.

I think it's supposed to be:

lsmod | grep 7846

... instead of 7864. That gives me the same output as suggested by Hoodoo.

P.S. My username comes from a band I once drummed for, bet you can guess one of the words in the name. Where does DrCJBoduma originate? I am too lazy to try Google, for the record. :p
Last edited by a moderator:
OK, tried the lsmod | grep 7846

Nothing happened

Bismuth? (I teach chemistry so was curious) :)

DrCJBoduma - has no real significance, just liked it :-D
Originality is king. Bismuth is the heaviest stable element, or so I am told.

If you get no output, that seems anomalous, but that's beyond my knowledge, needless to say. Hopefully a Linux guru can lend a hand here. :)

Tried modprobe ads7846

output was "FATAL: module ads7846 not found

Good? Bad? Indifferent? :-D


PS Bismuthdrummer (was going to shorten your name to the chemical symbol for bismuth and then drummer but, upon seeing it written quickly changed my mind) :-D any other links to chemistry ?
Last edited by a moderator:
Hmm, probably it's good, because it seems to be software issue to me.

I normally don't do tech support, but I think we should have a realtime conversation, like on Saturday 23:00 UTC +4. Not sure if it would help though.

PM me.
Thanks very much for the help and offer. Sorry was away over xmas. I decided to do a reflash and with the new hf7 (alpha?beta?) and amazingly the wifi stick now works perfectly (straight away without any driver swopping or anything). Not sure why or how, but it's a result.

Any ideas what changed between hf6 and hf7a to make the difference (just curious)


PS Thanks again for the help
That's nice to hear, thanks notaz!

Congrats Doc, but I still wonder how did you manage to (repeatedly) remove the touchscreen driver. :)
Last edited by a moderator:
I've made a HF7a2 SD install and my Netgear WNA1000M dongle does not appear to work out of the box.

Hoodoo's 8192cu module is not working with this new firmware - "Invalid module format"

Any suggestion to get my WiFi dongle working on my new SD install?

Perhaps an updated kernel module that works - please?

PS: I have non-working touchscreen on my HF6 install, among other issues (programs not working, fuse module not loading) - These might be from upgrading from HF5. The Netgear dongle works very well on HF6 with Hoodoo's module.
ID 0846:9041 NetGear, Inc.

It almost works with the stock 8192cu module, the module is loaded when I insert the wifi stick and it detects wireless networks but can't connect, keeps asking for the password.

Update: Experimented more, got it connecting intermittently. It's working solidly in HF6, so I'm guessing clean installing HF7a2 again might help(?)

Update 2: I reinstalled HF7a2 SD and wifi is working well now, thanks Notaz!
Last edited by a moderator:
I was able to replicate the touchscreen issue DrCJBoduma had when installing the Hoodoo driver in HF6. I had installed the Shiki theme stuff prior to, but other than that it was on a fresh reflash.

I'm not really interested in troubleshooting this if HF7a2 is working, seems like a waste of valuable dev time. I'll just flash forward to HF7a2.
Last edited by a moderator:
One factor might be, that on my original HF7a2 SD install, I tried to connect using the wifi stick first before trying the built-in wireless and later noticed that the stick had been assigned wlan0 and the built-in was wlan1. When I reinstalled, I was careful to connect to my router with the built-in wireless once, before I plugged in my wifi stick.

It's even possible that I had the wifi stick in on first boot of my first install, which is an obvious no-no! - hopefully I wasn't that stupid, but can't remember.

Hope that helps someone.
Last edited by a moderator: