HF6 RC 8192CU Wifi Dongle Not Working


Still Fresh
Sep 8, 2011
Seattle WA
Well, as the title states I have a Netgear wifi dongle that uses the 8192cu chipset. I had it working in HF6 Alpha 4 with Hoodoo's fix, but have yet to get it to work with this release. I guess it supposed to be plug-in play, but it just doesn't show up in the wireless connections. Tried unpluging it, plugging it back it, turning on and off the built-in wifi, reinstalling HF6 RC with it plugged in and without, even tried the old depmod && modprobe. I would use the built-in wifi, but that won't find any networks and didn't work in any previous releases, so I gave up on that.

dmesg output

usb 1-2: USB disconnect, address 6

usb 1-2: new high speed USB device using ehci-omap and address 7

usb 1-2: configuration #1 chosen from 1 choice

usb 1-2: New USB device found, idVendor=0840, idProduct=9041

usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3

usb 1-2: Product: 802.11n WLAN Adapter

usb 1-2: Manufacturer: Realtek

usb 1-2: SerialNumber: 00e04c000001

Any help would be appreciated.

Last edited by a moderator:
I was just about to post. ^ What this fella said, running HF6 Final.

I managed to get it working ONCE, right after a reflash to HF6 RC. The red LED for wireless had not turned on, and I was getting 5Mb/s, compared to 100 kb/s when I switched on the regular wifi. I have two of the exact same stick (Netgear WNA1000M), both of which work flawlessly on my Windows boxes. Neither of them have worked since that single magical moment.

Hopefully someone can locate the holdup, I really can't imagine it to be much, but we all know these things get complicated.
I only can tell once again that using the driver I've compiled for hf 6 alpha would not help, bismuthdrummer tried it. :)

That's interesting, because the official driver from Pandora team works for new user Niko with Belkin Surf just fine.

Some daring people might get the source and recompile the driver against the newest kernel and see if it works. If it's of any use I might upload the driver source and the dirtily hacked makefile somewhere later today.

Hmm. I think I'd even just recompile the driver myself, but it would take some time, I need to checkout and build the latest kernel, and it's quite slow operation for me, so no earlier than tomorrow. But I'll not be able to test it and you'll have to do it on your own.
Last edited by a moderator:

It would be nice if someone told me which branch do I checkout from the kernel git repo and which patches do I apply to get the module binary compatible with the current firmware. Please note I already have the setup which works with hf6alpha4 so don't just throw links to the wiki at me. If the necessary toolchain is different from what DJWillis described I'd like to know that too. I could try and figure things out on my own in a week or so if I had a working Pandora around, but I don't.

I'm not sure if it's a good piece of advice, but if I needed the external wifi chip to work more than I needed all the rest of hotfix6 goodness I would just stick in the last kernel which worked with it come hell or high water. Chances are it would work, it worked when I've changed the OS from Angstrom to Debian and then to Gentoo, so it might still work with angstrom-angstrom transition. If you need the corresponding files I could upload these to my ftp tomorrow after midnight UTC+4 or you could download these from the official firmware server. Writing these to your NAND would be at your own risk, of course.
Last edited by a moderator:
Nothing has really changed, the same master/pandora-27-omap1 branch, same compiler.

Maybe mcbearface needs to unload the module currently being shipped with the firmware before trying to use Hoodoo's one.
I got it working again! :)

Hoodoo, I think your blob of that driver definitely works... I copied it into some subfolders somewhere like /kernel/drivers/net/wireless and /updates/drivers/net/wireless, and just for giggles I put in the adapter after a fresh boot. It prompted me for a wireless password and showed networks available. No red LED as with the internal wifi.

So please don't waste your time recompiling now, I think we just have a installation/configuration thing to figure out.
I'm trying what you just said bismuthdrummer. Now did you do anything other than copying 8192cu.ko into

/lib/modules/ && /lib/modules/ ?? Or should I be doing something else?
That's it, mcbearface, all I remember doing beyond that was "sudo depmod 8192cu" and "sudo modprobe 8192cu"... but I honestly can't say if this helped (I really need to learn more Linux!).
Oh wow. That's good, I've hit IRC yesterday, and aTm kept telling me 'it's in the wiki, it's the same kernel!', and I was like 'OMG WTF is going on with version numbering here?' Thanks for explanations notaz!

Glad to hear that had been resolved. Maybe they would take the driver to upstream then? Again, there is the source and the makefile, no need to run around with the blob, if it doesn't conflict with the other drivers why not?
Last edited by a moderator:
This post is where I found it: http://tuxme.net/?p=740

Here is the link to the source itself: http://tuxme.net/dat...L8192CU.tar.bz2

I didn't diff it against the one from Realtek's site, but I think it's just a source code w/o README and wpa-supplicant Realtek bundles its drivers with. I just tampered the makefile, the part about x86 platform, so that KSRC showed at the directory with compiled Pandora kernel and stuff like that. Don't have access to it right now but I don't think you need it. :)
Last edited by a moderator:
Looks more or less the same as Realtek's one (the one we ship), just different version, no idea why it wouldn't work.

bismuthdrummer: so you modprobed 8192cu.ko that comes with firmware and it didn't work, only works after replacing it with Hoodoo's one?
Last edited by a moderator:
For the record, one guy reported the driver which comes with hf6 works out of the box without any modprobing and command line voodoo with Belkin Surf Micro. Netgears don't work.

As for modprobing - aren't they loaded when necessary automagically? When I've been trying to fix mine, It definitely only took me to drop the file to /kernel/drivers and only run depmod (without parameters, just to query all of the modules), and I definitely didn't explicitly modprobe the module.
Last edited by a moderator:
As for modprobing - aren't they loaded when necessary automagically?
Yeah, but I thought maybe it did not work for some reason.

I diffed the drivers a bit more and they have slightly different supported device lists, something like 90% of the list matches, but there are some devices on list of driver's we used but not on yours, and some on yours but not on ours. Meh.
Last edited by a moderator:
Damn, now I'll have to make a pnd. Or maybe both can be included somehow? Or merged?
Last edited by a moderator:
bismuthdrummer: so you modprobed 8192cu.ko that comes with firmware and it didn't work, only works after replacing it with Hoodoo's one?
Yes, I tried several different times to reflash and get it working. Each time the driver registered in dmesg but ignored the device when I plugged it in. I didn't know any commands to force the adapter to use that driver, so I replaced it with the other one and it worked.
Damn, now I'll have to make a pnd. Or maybe both can be included somehow? Or merged?
I don't think these 2 can coexist, the module name matches and larger part of device list..

I've added a patch to add those devices to the Realtek driver, we'll see if that works after ED builds new hotfix.
Last edited by a moderator:
Just wanted to post a thanks to Notaz and Hoodoo from my Pandora using my newfound wifi. :) Been running fine now since the driver fix, hopefully updating the device id list for the 8192cu driver will add to the roster of pluggable adapters for the next hotfix. Plug-and-Play is hard to beat, especially on Linux.
I can confirm that I have the Netgear WNA1000M working on HF6 final, thanks to all your help - with the following steps:

1. Download HooDoo's kernel module here: http://dl.openhandhe...i?0,0,0,0,1,438

2. Rename existing 8192cu.ko of HF6 out of the way, then replace with the extracted file from step 1, here: /lib/modules/

3. Now in that directory: sudo depmod 8192cu.ko

4. From anywhere: sudo modprobe 8192cu

(I typed this by hand so please point out any typos!)

Wireless should come on as if toggled on, and connect to your default wireless network.

I haven't worked out how to add the module as auto load yet (I added it in /etc/modutils/ and ran update-modules and it's now in /etc/modules but not listed by lsmod - so I expect I've done it wrong, any advice appreciated!). So I'm currently starting it each boot with step 4 above.

By the way I bought it here: http://www.pixmania.....html?srcid=867

Well, I'm off to watch streaming movies whilst freezing my ass off in the garden - because I can ;)