Help Request - Breakout Board, Ext Hdd


Oct 1, 2005
Visit site
I've wracked my brain (and the forum and the wiki) over this one and getting nowhere.

I have a First Edition gp2x running firmware 2.0, and the breakout board from Craig.
I have, under gp2x advanced settings, usb host set to always on, with human interface and storage set to on.
I have power supplies for the gp2x and board.
I power up the board, red power light comes on.
The gp2x is connected via the supplied (with board) ext cable to board.
I power up my (fat32 formatted) usb hdd.
edit : forgot to say, usb hdd works fine on pc
I power up the gp2x and it seems to work ok, but no ext storage :(
I've tried under games videos and pictures - nothing listed.
I have very little knowledge of Linux, but was hoping it was just a case of plug in and go.
No matter what I connect to the boards usb ports, I do NOT get a green light on the board.
I have tried a mp3 player, the usb hdd, a game joypad, and a card reader.
The card reader power light comes on, so I'm getting power through the usb.

edit2: I've now tried two different usb hdd's, same result no green light on usb port on board, no ext storage under gp2x menus
edit3: crep spolling

Can anyone think of anything else I could try?
Thanks in advance.
garengarch posted on Sep 1 2006 at 04:05 PM said:
I have very little knowledge of Linux, but was hoping it was just a case of plug in and go.
I don't have a BOB so can't really help with that, but I do use a USB HDD connected directly to the EXT port on the GP2x. so I can tell you that it is just a case of plug in and go. There's nothing more to do other than turning on those options in the settings. Just make sure the GP2x is always the last device to get powered on.
Last edited by a moderator:
thanks sub

what worries me is that I'm not getting a green light on the board, no matter which of the 4 ports I use, and according to the board pdf, i should be.
I've had a similiar problem with home made BOB, connect everything up just the same way as you, but nothing under EXT storage.

Using a little script I can get the HDD to appear, not sure I should need to but it does work.

If you want the script I'll post that as well.
Make sure all the chips are on the BOB if there are any arrows pointing to empty spaces there might be a problem.
con3 is missing, i presume thats normal, and theres a black felt tip pen mark on the board, nothing that looks any different chip-wise to the photos on your site.

update: Craig, the board or the Ext cable must be bolloxed, i managed to get it set up for tv out and that doesn't work thru the boB, but works thru your previously supplied tv-out cable, so ext port seems ok on gp2x.
Get power on indicator on BoB, and power thru usb ports, and thats all I can test :(
Not sure if this will do you any good in light of the other posts but here it is anyway:
mount -t vfat /dev/sda1 /mnt/ext
cd /usr/gp2x

Very simply it takes the item in /dev/sda1 and mounts it as /mnt/ext/ then restarts the menu (wrote that myself I did, I'm a Linux newbie too!)

This does assume that the drive is appearing as sda1 (first partition of the sda which, I believe, is the first USB attached drive) and that it's formatted FAT (or FAT32).

I saved that script as "mountsad.gpu" (making sure it has Linux returns not Windows ones) then transferred it to the 2x.

Hope it's of some use to someone