Gmenu2X 0.11


bomberman

Member
Joined
Jan 2, 2008
Messages
416
Location
MO - USA
I have the following issues with the new version:

GP2X F200 4.0.0

Touchscreen - not working
sub sections - opaque first picture, then none displayed
rows/columns - option missing (on purpose?)
 

darionapole

Member
Joined
Jul 10, 2008
Messages
221
no idea, but you should upgrade to open2X, plus it comes with Gmenu2X.

when i was on FW4.1.1 i had the same issues
 

ryosaeba

Certified Guru
Joined
May 19, 2006
Messages
421
Age
37
Location
Como (Italy)
Website
mtorromeo.github.com
bman said:
I have the following issues with the new version:

GP2X F200 4.0.0

Touchscreen - not working
sub sections - opaque first picture, then none displayed
rows/columns - option missing (on purpose?)

I think the touchscreen problems may be related to the FW 4.0.0 (or later).
I never upgraded to that version because it caused more problems than it solved. On open2x it works fine.
I'll test the other issues tomorrow.
 
Last edited by a moderator:

Farox

Certified Guru
Joined
Jan 8, 2009
Messages
2,173
Age
53
Location
Italy
Website
rbnet.it
Have you tried to apply first the Notaz patch ?

I'm also on Open2x dr7 firm (and working fine :) ) but when i was using 4.1.1 this patch is always needed to use touch on F200.
 

bomberman

Member
Joined
Jan 2, 2008
Messages
416
Location
MO - USA
It's funny how everyone tosses out out O2X or 4.1.1 as I've been on 4.0.0 on the F200( B ) since it came out. I did update to O2X briefly and it broke more than I cared to fix. (Yes it is an impressive feat and I am not knocking the effort, that is a separate discussion.) I would be willing to go to 4.1.1 if I have to but all my touch screen programs (Animatch,Drench,ZDoom,Hexen,Exult,Albion,ScummVM,BoomShine,SpaceVarments,Poker,Sachunsung,Blocked,Blox,BennuGD etc.) are working just fine.

I've been running Gmenu2X 0.10test2 without problems for over two years so I'm not sure that the firmware may be the issue. I will defer to you on how you want to handle it as I fear GP2X development has lost favor to all its successors. :(

If you can restore the icon order and sub section graphics I would be grateful as the speed of this version is awesome.

Thanks for your work and support.
 

ryosaeba

Certified Guru
Joined
May 19, 2006
Messages
421
Age
37
Location
Como (Italy)
Website
mtorromeo.github.com
bman said:
It's funny how everyone tosses out out O2X or 4.1.1 as I've been on 4.0.0 on the F200( B ) since it came out. I did update to O2X briefly and it broke more than I cared to fix. (Yes it is an impressive feat and I am not knocking the effort, that is a separate discussion.) I would be willing to go to 4.1.1 if I have to but all my touch screen programs

Well my experience was perfect with open2x while FW4 added nothing except SDHC support (which was available as a patch before) and created new problems.
Returning back on topic, confirm that GMenu2X is running at least at 136Mhz.
If it was working for you with the previous version, it should also work now and it is working for me, but I had to point out that I'm not using the same firmware, I don't really know if that's the problem.
Maybe you can get confirmation by other users.
 
Last edited by a moderator:

bomberman

Member
Joined
Jan 2, 2008
Messages
416
Location
MO - USA
Changed default 136 to 166 a while back. Never lower.

Also noticed that screen contrast changed when using config section (SELECT) and moving cursor. Similar to what happens for sub section graphics.

The sub section graphics would be critical as I use it for emulator, java, and doom pwad selections. If that is not fixable I will have to got back to the previous version. Note: Just noticed that when I press any key but X/B/HOME once the sub section picture appears opaque and another press it is normal. When moving dpad pics disappear again.

Also noticed that fontSize=10 gets truncated on line 12. May be able to fix with a menu bar setting.
 
Top