encrypted SD card problem (truecrypt)


Still Fresh
Jul 18, 2016
im new here and this is my first post.

after some days playing around with my new device, i tryed to encrypt one of my SD cards (64gb) with truecrypt. everything worked except one thing:

i cant open any pnds and they dont appear on the desktop even thow i have pandora/desktop folder created (with the pnds in it).
i can get into the sd card threw /media/truecrypt but cant open the pnds. is there away to "fix" this?
same problem with containers.

i encrypted the sd card under windows 8.1
Execute the "mount" command in an Terminal. It should list all mounted filesystem's along with the Mount Options (in parentheses). It could be that /media/truecrypt is mounted with the "noexec" Option. If that is the case try "mount /media/truecrypt -o remount,<*>" else or If it still doesn't work, Paste the output of the "mount" Command here.

*all mount options listed by mount for /media/truecrypt Except for noexec, Comma seperated without spaces
thanks for the fast response

but it doesnt work. maybe i did something wrong

when i type in mount /media/truecrypt1 it says:
mount: /dev/loop1 already mounted or /media/truecrypt1 busy
mount: according to mtab, /dev/loop1 is already mounted on /media/truecrypt1

i had to put sudo in front of the mount /media/truecrypt1 is that normal?
is there a way to install truecrypt on the internal free space of the pandora?
treucrypt is now installed on my other sd card wich is not encrypted. i start truecrypt from there.
maybe thats the problem ?
Last edited:
So your truecrypt pnd is inside the encrypted volume? Yeah, that would definitely be tricky to unencrypt ;)

According to the description of the truecrypt PND I looked at on the repo, it should give you the option to install to internal storage, but I only glanced at it so I'll leave it up to you for now to figure out how to do it. That would probably be a good way to get truecrypt support out of the box, as it were.

Regarding mount, you need the '-o remount' option as in lukey's instructions above. If installing truecrypt to your internal storages /usr folder doesn't help, the output of just 'mount' on its own would probably be helpful in diagnosing any other issues though.
the truecrypt pnd is in the other sd card. one encrypted sd card and the other one not encrypted with truecrypt on it.

i dont think i had the option to install it on the internal storage. if i pull out my sd card (not the encrypted one) truecrypt disapears

in the discription it says:
(During first run, you can choose to install the "truecrypt" binary in /usr/bin, so that you can later use 'truecrypt' in your shell scripts for automated TrueCrypt volume mounting / unmounting.)
i did that during the installation.

i typed mount /media/truecrypt1 -o remount
nothing happend, not even an error or sth.
if i type -o remount, the terminal says uknown command

it looks like -o didnt excist
How do you mean, truecrypt disappears? Are you checking the files in /usr/bin? Files in there should ideally not be dependent on a PND being present, and I'd be surprised if they were. Or do you just mean the menu entry/desktop icon for it disappears - that's not really important if it's still in /usr/bin/. Provided it has the right key/password is should still be able to decrypt files in a truecrypt file system.

FWIW, most unix commands don't report anything when they work - they only print output if there's an error. '-o remount' is an option to mount, so typing it on its own is certainly an error. That behaviour looks perfectly normal to me. It'd probably be best if you could post the output you get when running 'mount' on it's own - then we can make a complete command for you to enter, if it turns out it is mounted incorrectly. I suspect it's mounted correctly, and truecrypt just need setting up properly, but we'll see.
you are right. only the icon disappears. it's still in /usr/bin. and i can open it.

when i type in "mount /media/truecrypt1" it say's:
"mount: /dev/loop0 already mounted or /media/truecrypt1 busy"
"mount: according to mtab, /dev/loop0 is already mounted on /media/truecrypt1"

when i type mount "/media/truecrypt1 -o remount" directly after it says nothing. but nothing happens aswell

off topic:
why can i open truecrypt threw /usr/bin/ (folder), but cant open pnds on my sd card threw the file system (folders)???? i have to open them threw the desktop or the "start" button (then settings etc.)
The '-o remount' option acts to unmount then mount the specified device again - it doing nothing is what you'd expect in most circumstances. It's useful because you can combine it with other options to change the way it's mounted, if there's a problem with the way it's mounted. But we don't know yet whether there is a problem or not as you haven't given us the output of plain 'mount' yet.

You'll have to forgive me - I've never used truecrypt so don't really understand what it does or how, but do you need to enter a password somewhere to decrypt stuff? Or is there some other way of identifying you as owner?

Also, I don't know how you open PNDs through start->Settings->etc., so I can't really help you there. If they're not in my menu for whatever reason I usually open them using pnd_run, which is a tool that ships with the Pandora. But if you can't open them through the file browser, I guess truecrypt might be hiding them still, so you won't even be able to run them with pnd_run.
damn! u guys meant only "mount". my bad... xD

it says:

rootfs on / type rootfs (rw)
ubi0:rootfs on / type ubifs (rw,relatime,bulk_read)
devtmpfs on /dev type devtmpfs (rw,relatime,size=222060k,nr_inodes=55515,mode=755)
proc on /proc type proc (rw,relatime)
tmpfs on /mnt/.splash type tmpfs (rw,relatime,size=40k)
sysfs on /sys type sysfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw,relatime)
tmpfs on /var/volatile type tmpfs (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,relatime,mode=777)
tmpfs on /media/ram type tmpfs (rw,relatime)
ubi1:boot on /boot type ubifs (rw,relatime)
/dev/mmcblk0p1 on /media/TIM_1 type vfat (rw,dirsync,noatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
gvfs-fuse-daemon on /home/tim11/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1001,group_id=1002)

back to off topic:
i meant, that if i download a pnd from pndmanger and i install it (on my second sc card, wich is not encrypted ) into the folder "desktop", i can only run the pnd from the desktop and not from the folder "desktop", eventhow its inside that folder.
when i install it into the folder "menu" the pnd can only be run threw "start" (bottom left pandora button, the cube thing ) and then the i can run the programm.
That's it! Okay, I don't spot a noexec option in that listing. I take it you only had the one SD card inserted when you ran that. If so, and that's the encyrpted card, then I think it's all fine, you don't need to remount it.

Back off topic: You mean you can't run a PND by double clicking it in the file browser? That's normal - a PND can contain more than one executable, so what should it do when you double click it? You put the file in /pandora/desktop and the system writes a few icons out to your desktop allowing you to double click it there, or you put it in /pandora/menu and those icons become menu items. That's how it's meant to work - you don't need to fire up Thunar and navigate to its folder to run things, just click them on the desktop or in your xfce menu.

What's the problem again? Your PNDs on the 'encrypted' card not showing up?
the full path is:

i can open text files thow...

the problem is, that i cant run pnds from the mounted volume.

edit: Desktop instead fo menu at the end of the first path...
Last edited:
Could you again run "mount" while you have access to the Truecrypt Partition. And Post the Output here.
rootfs on / type rootfs (rw)
ubi0:rootfs on / type ubifs (rw,relatime,bulk_read)
devtmpfs on /dev type devtmpfs (rw,relatime,size=222060k,nr_inodes=55515,mode=755)
proc on /proc type proc (rw,relatime)
tmpfs on /mnt/.splash type tmpfs (rw,relatime,size=40k)
sysfs on /sys type sysfs (rw,relatime)
none on /dev type tmpfs (rw,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw,relatime)
tmpfs on /var/volatile type tmpfs (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,relatime,mode=777)
tmpfs on /media/ram type tmpfs (rw,relatime)
ubi1:boot on /boot type ubifs (rw,relatime)
gvfs-fuse-daemon on /home/tim11/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1001,group_id=1002)
truecrypt on /var/volatile/tmp/.truecrypt_aux_mnt1 type fuse.truecrypt (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other)
/dev/loop0 on /media/truecrypt1 type fuseblk (rw,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)
You say you can open text files (on the truecrypted card?) - you should then be able to run pnds using the command pnd_run, for example:

cd /media/truecrypt1/pandora/menu
pnd_run spacerocks.pnd

Using pnd_run like that should run the first target in the pnd file, and as most pnds only actually include one target it'll usually work fine - and for those that include more, the first one should still do something visible.

If that works, your problem is the pnds don't get picked up and stuffed into your XFCE menu, or onto the desktop as appropriate. I'd guess the deamon that spots new cards being inserted and creates the appropriate .desktop files doesn't spot the truecrypt1 because of the peculiar way it's mounted.

Of course it's possible it won't work; pnds get read using a loopback mount, and I don't know for sure that you can mount a loopback mount from inside a loopback mount - I've never tried.

I should have asked already, but why did you encrypt your card with PNDs on it? PNDs aren't secret - you can redownload them all from the repo. Settings files that get created in appdata might be more secret, but mine aren't, for example. Is it just because you've other files in the card you don't want prying eyes to see?
pnd_run didnt work.
it says command not found.

even on my not encrypted card, where i can start pnds from the desktop, i cant start pnds from the console.
?????? i start thinking i dont use the console right..

in my encrypted card are for example pnds like BORG calendar. with appointments and other stuff. i want to hide them too

i hope its still fixable :/
Hmm, check your PATH: type 'echo $PATH' (note capitalisation) - the paths given back should include /usr/pandora/scripts

Secondly in that /usr/pandora/scripts there should be a script called pnd_run.

One of those two things (or both) can't be true if pnd_run gives you a command not found.

Before spending too much time on this, it's probably worth reflashing your unit to the latest OS. Maybe that will fix some other problems you're having at the same time.
pnd_run should be in /usr/bin.
The script in /usr/pandora/scripts is pnd_run.sh

Both need to be present for the pnd_run [PND filename] command to work.

Last edited:
pnd_run.pnd and pnd_run.sh are both where they belong.

does it anything have to do with this java pnd wich makes java applications work or the cummunity codec pack?

how do i reflash my pandora?

i now reencrypt (does this word exist ?^^) my ssd and i will foramt it to NTFS
See this thread for instructions: https://pyra-handheld.com/boards/threads/superzaxxon-v1-75.77636/ (or look for the latest release thread in that forum if you come across this post in the future).

If pnd_run didn't work, you wouldn't be able to load pnds from your unencrypted card - I suspect you just typed in the command wrongly. Codec pack certainly won't make a difference, and I strongly doubt Java would - but I don't have any experience of that PND.