Continuous restart of PANDORA - 1Ghz unit


Still Fresh
Sep 28, 2012
Hi everybody,

I’m a brand new member of this community and I kindly ask support for the following issue: last week I finally received my brand new Pandora 1Ghz (platinum), I put battery on device (without connecting to AC adapter) and immediately (without flicking power button) it get started (frankly speaking I don’t know if such behavior is normal…).

In any case, I finished set up and then I tried shut off device: Pandora shut down … and then immediately restarted by itself without flicking start button. It finished restarting, then I tried again shut down: no way at all, it immediately get started again. I tried several times, but result is exactly the same. Please note that all the restart of the unit have occurred without having connected unit to any electrical socket – i.e. AC adapter constantly disconnected.

From page I saw the following:

A common problem seems to be that if you switch off before unplugging, your Pandora will re-boot even though it is now left unplugged. This problem is compounded by the low battery shutdown script being called repeatedly (and actually preventing shutdown).

According to this, I’ve tried also flashing the unit: no way, problem still exists and unit can’t be stopped.

Basically, unit is working fine (I’ve tried also charging the battery with unit ON and it works, battery get charged when connected) but there is no way to shut down my device, cause always it get re-started by itself and this happen always with AC adapter disconnected.

Apart from re-start problem, I found also the following anomalies which I’d like to draw to your kind attention:

  1. If I put batter out of unit and I use AC adapter for start the device, It does not start (what I see is that connecting device Pandora logo appears for few second then screen turn black and system does not start even by flicking power button.
  2. If I put battery out of unit and connect to AC adapter keeping pressed Right shoulder button, in order to boot from SD card for example, magically it works and unit get fed through AC adapter. This works till I reach point 7 of reflashing procedure (see page then, after pressing ENTER button unit goes off and, just after that once again it restart immediately (again without flicking start button). So basically the re-starting of the unit (this time without pressing Right shoulder) leads me back to condition described at above point 1 : so unit does not start.

Resuming this complex picture I found:

  • my unit continuously restart if I try shut down (AC adapter disconnected);
  • start up procedure end successfully only when battery is inside unit – no way to start Pandora normally with AC adapter connected and battery out of unit;
  • Pandora can start with AC adapter and no battery only for going into boot menu (pressing R button before connecting AC adapter);
  • AC adapter seems working fine since it charges my battery when device is ON.

I saw this community is very active and members offer great support each other: I will be very grateful to everybody who’ll be able to help me in solving this issue.

Thanks in advance to everybody.
start up procedure end successfully only when battery is inside unit – no way to start Pandora normally with AC adapter connected and battery out of unit
The Pandora is not made to function without battery - by design. It wont work by plugging it in AC adapter without battery.
Hi Stewy, congratulations on writing a really concise & comprehensive help request. The one thing it was missing was exactly how you are shutting down the Pandora, i.e. via mini menu / XFCE desktop, which menu option you are choosing etc.

Sorry I can't be much help as the only thing I can suggest is that you check that the battery is making good contact inside the pandora. You can do this by putting a small piece of paper between the battery & battery door at the end where contact is made. Be careful when closing the battery case as the tabs are a little delicate.

You'll probably have to wait for someone with a little more knowledge than me to suggest something useful.
start up procedure end successfully only when battery is inside unit – no way to start Pandora normally with AC adapter connected and battery out of unit
The Pandora is not made to function without battery - by design. It wont work by plugging it in AC adapter without battery.

It is not designed for it but most units can work even without the battery, and mine is one of them.

Anyway this seems to me some sort of software problem... some people resolved issues like this booting the old kernel, but in your case maybe the flashing procedure might not have finished it's process if it stopped at that point...

If you can see the option to boot from the old kernel in the boot screen, try it.
Last edited by a moderator:
Automatic start after battery insertion is normal behavior. (in case the battery is loaded)

I used to have the same problem (constant restarts) with my first gen Pandora. I fixed that by ensuring stable position of the battery in its compartment. I simply put small piece of folded paper from one side of the battery. In my upgraded unit in platinum case I've noticed small foam stickers, propably inserted by ED or Askarus, which are providing the same service. Check if you have them. Usually those restarts are caused by loose battery contact.

P.S.: Welcome to the community!
Last edited by a moderator:
Thanks everybody for support and warm welcome in this great community!

I'd like to reply to all members giving me support up to now: battery is fixed in an very impressive way (is not flaky inside the battery pack seat). In fact in my case the re-start occurs exclusively at the end of each shut down, never happened when Pandora reach the end of the starting procedure (i.e. I can use normally Pandora for all its function, but - as I've said ad nauseam and for that I apologize - simply there is no way to shut down the device). Flashing of unit always ended correctly restoring the default config, but at said, this is not enough and my unit behavior has never changed.

I've tried both shut down from desktop and minimenu.

In any case, I've contacted ED (I purchased unit from dragonbox shop) and, after having analyzed problem, he confirmed that this is due most probably to a hardware malfunctioning (not software).

I've already sent back my unit to ED via UPS: he confirmed he's gonna substitute my unlucky Pandora (only three days used... sigh!) with a brand new one.

Hopefully end of next week I will get my brand new unit - can't wait for that!!!

I'll let you know how story end in next future!

Thanks to everybody for support, see you guys!
Hi guys,

I’ve just received back a brand new Pandora in substitution of my “non-shutting” unit and finally… IT TURNS DOWN! WOOOOOOP!

I never imagined I have ever could be so happy in front of a system that is able to shut down!

Seriously, I must point out that the whole event had a positive outcome since the first contacts with ED and all the staff: they have been very open to dialogue and replaced the console as promised in a very fast time.

So thanks to ED shop, now it’s time for me to enjoy what someone defined as “technological delirium” … better call it simply Pandora!
Also nice to hear that someone is satisfied with customer support :)