Can I disable the cache in midori?

Joined
Jan 8, 2010
Messages
498
I'm using the version 0.4.2a. And noticed that cache size grows like mad. Deleted the entir folder, and after a few minutes of use the folder have 16MB in size and more than 1000 items.


It does mean a huge drop in performance, I have make this test because when the folder reached 100MB, while browsing the status led didn't stop blinking and the time loading increased. Tested with two class 10 cards (transcend and sandisk)


It's not only the "browsing experience" what worries me but the harm that this behaviour may do to the SD card, it can't be healthy to read and write contantly on a folder with thousands of files, even list them all and sume the size takes a good amount of time.


Due to this experience I was wondering if cache can be disabled, I have tried limiting it's size to 10MB but the option is just ignored. My other idea was to simply redirect the cache folder to /dev/null but since it is fat32 formatted I can't do that.


I would like to disable it at least for some time to see the response and was woddering if there is any kind of advanced dialog like tje "about:config" in firefox from where to override that option.


PS


I have tested also in chromium with a similar output, after a few minutes of use the cache folder grew to over 10MB.


I'm beggining to think that cache on the pandora is useless. I think any browser would work better without it or even redircting it to the nand (with a limited size of 15-20MB), of course i'm just guessing.


I might try to format a spare SD in ext2/3 and then redirect cache folders to nand and /dev/null but I don't have time right now.


By the way it would be great to hear from people who have noticed similar issues.
 

slaeshjag

¯\_(ツ)_/¯
Joined
Apr 8, 2010
Messages
2,687
Location
~Stockholm, Sweden
I think I managed to disable the cache, this is how I did it:


First, in preferences; I set the maximum cache size to 0


Then, i cleared my private data (using the menu option)


After that, I can now browse around, and I have yet to se the "web" directory show up in the file manager, so I'm assuming it worked.
 
Joined
Jan 8, 2010
Messages
498
Correct, setting the option to 0 disbles cache.


But any other value is ignored.


I'm going to try to work without cache for some days and see if there's any problem.
 
Joined
Jan 8, 2010
Messages
498
The button on the top right corner of the window, then preferences, then network tab.


@fusion_power: indeed cache enhances loading speed, but our browsers (and his default options) come from PC, and as you can understand a modern computer and specially it's hard drive is able to manage an incredibly amount of files of any size. Pandora on the other hand has to rely on SD card which are a lot slower, no only on a sustained transfer but also managing large set of files. I don't think the best solution is disabling cache, what I want to find is what is the size that fits better for a SD card, and even that size may vary from one card to another.


And since I can't limit the size on midori it's certainly better to not have cache at all. Of course I can be wrong I have only a couple of cards to make tests and not much time, if you find the topic interesting you should make your own tests and discuss the results here.
 

slaeshjag

¯\_(ツ)_/¯
Joined
Apr 8, 2010
Messages
2,687
Location
~Stockholm, Sweden
The cache is not actually managed by midori, it is handled by libsoup. The buggy cache handling is probably caused by a outdated version of libsoup. I will upgrade libsoup to the newest version possible in the next release.
 
Joined
Jan 8, 2010
Messages
498
You are rigt onpon4 the option does appear only in 0.42a which is not uploaded to repo (it's considered a test version). If you want to try it, it's on the software news forum, the same thread about 0.42 relase.
 
Top