Caanoo Showing Up As "unknown Device" In Windows Xp


Still Fresh
Jan 31, 2011
I just bought my Caanoo last week and I've been beating my head against a wall trying to get it to connect to my PC. I'm running Windows XP Professional Service Pack 3 32-bit. When I connect the device using the cable provided, the Caanoo displays "USB Connected". After a few minutes, I hear the device connected sound from Windows but it never installs anything and nothing pops up in the notification area. The Caanoo is showing up as "Unknown Device" in Device Manager under USB Controllers. Double clicking this tells me that there are no drivers installed for the device. I cannot see the device in My Computer either. I do have an SD card in the Caanoo and its not locked or anything. I can access the card in the Caanoo using the explorer.

Am I missing something here? I've also downloaded the PC Manager from FunGP but it says that I don't have a device connected. I've asked their support about this but haven't received much help. Has anyone else experienced this problem? I've tried turning on all kinds of Windows Services and re-booting over and over. Nothing seems to work. Any help would be greatly appreciated. Thank you.
Thanks for the replies. I tried all of that and nothing worked.

When I tried uninstalling the "Unknown Device", it would just reinstall again. Finally, I uninstalled and then quickly unplugged it. That seemed to work but when I put it in another port and rebooted, it reinstalled the "Unknown Device" again.

I tried plugging it in and then turning it on. That didn't change things.

I was able to find a microsoft article that had some registry entries to delete if you're getting the "Unknown Device". I did that and now the PC is reading it as "Generic Volume" under "Storage Volumes". Still can't access it...PC Manager still doesn't recognize it. I'm about ready to give up and re-format my hard disk. I've tried turning services on, I've tried changing BIOS settings, I've done everything I can think of in Device Manager. This is really frustrating. I have no idea what to do now other than re-format.

go to hardware manager choose the unknow device go to properties and click on the update driver button choose manualy and then choose from list dialog unclick the only compatible hardware clickbox and choose generic usb data device click ok.
Okay, I noticed that I actually have both "Unknown Device" and "Generic Volume" under "Storage Volumes".

wizzx, I tried your method on both items, but every time unclick the "Compatible hardware" checkbox, nothing else shows besides the respective drivers. ie, I can only choose Unknown Device or Generic Volume. No option for Generic USB Data Device shows.

Another thing I've noticed ever since making the registry change: every time I boot up with the Caanoo plugged in and on, my computer hangs at the hardware loading screen. Right before you hear the normal 1 beep. It recognizes my disk drives and then just hangs. Well, when it was doing this, I turned the Caanoo off and then "beep" and it continued so I know the Caanoo is hanging up the computer loading devices and what not. Could this be an indication that the Caanoo is defective? I halfway think FunGP is hinting at that because they have asked me to try it on another computer but I don't have another computer besides at work and I don't want to bring it into work because we have policy against USB devices. Anyway, do I have any other options guys or should I try to get my money back? I could re-format but if it's the Caanoo that's the problem then I'd rather not.
I definitely recommend trying it on another computer somehow...

You have to know someone who has a computer.
Okay, I was able to try it on a computer running Windows 7 and it works fine. So, I guess it's my computer.
You could try downloading and running CCLeaner to clean up your registry. There's a slight chance that that could help. Otherwise, you're probably looking at manually fixing or removing registry entries like you did before.

Other things you can try would be to update your motherboard drivers. If a driver was downloaded from Windows Update it could have messed up your system in a way that prevents some USB devices from being detected properly. Likewise, do all of your Windows Updates, including service pack 3, though I'd skip any driver updates for things that are working fine.

If that doesn't work, you could try a repair installation of Windows. Basically, you put the CD in, reboot and when it detects a previous installation of Windows, tell it you want to repair that installation. It will keep most things intact so you won't lose settings and you won't have to reinstall all of your software, but it can fix problems related to messed up system files and registry entries.

And if THAT doesn't work, and you can't find any solutions online, you've either got a very strange hardware problem or you'll need to reinstall Windows completely.