Release Z-LOCK

Discussion in 'Software Releases' started by M-HT, Apr 25, 2016.

  1. M-HT

    M-HT Very Active Member

    Joined:
    Nov 30, 2007
    Messages:
    599
    Location:
    Bratislava
    Hi,

    I ported Z-LOCK to Pandora.
    Z-LOCK is a Japanese shooter with a twist: your shot power is directly proportional to the number of enemies locked on to you.

    Movement: DPAD / Left nub
    Shot: [A/Y]
    Adsorption: [X/B]
    Pause: [P]
    Quit: [ESC]

    Download:
    repo

    The source code is inside the PND and on GitHub.

    The Pandora port uses ptitSeb's fork of glshim.


    Changes:
    v0.2.0.3:
    * fix a crash on first run (when waiting to run demo)
    v0.2.0.2:
    * fix a bug which slowed the game down on each game over
     
    Last edited: May 3, 2016
    Tags:
    Magic Sam, _jr_ and Farox like this.
  2. atari_afternoon

    atari_afternoon Member

    Joined:
    Oct 11, 2012
    Messages:
    434
    Location:
    Germany
  3. Farox

    Farox Certified Guru

    Joined:
    Jan 8, 2009
    Messages:
    2,006
    Location:
    Italy
    Great work!
    A little bit difficult for my taste, i'll prefer Titanion, but anyway good that you ported another D programmed game to Pandora.
    Thanks
     
  4. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,147
    Location:
    Innsmouth, MA
    Hi all :)

    @M-HT : thanks for porting that great game to the Pandora ! Do you think you could hack C4A support in ?

    It needs some overclocking (~800 MHz) for smooth gameplay though.

    And I also had a crash once, I'll try to reproduce it.

    Cheers, Magic Sam
    --- Double Post Merged, Apr 30, 2016, Original Post Date: Apr 30, 2016 ---
    @M-HT : Bug report !

    I had the weird feeling that, the more I played that game, the slower it got...

    So I used @notaz ' Live system info to see how performance looked like on my Rebirth unit, OC @ 825 MHz, SGX driver 4.10:

    -1st play: ~20 FPS (from start to game over)
    -2nd play: ~15 FPS
    -3rd play: ~10 FPS
    -etc...

    There must be some leak somewhere, maybe the resources are not freed correctly upon restart...

    Could you please have a look at it ?

    Cheers, Magic Sam
     
  5. M-HT

    M-HT Very Active Member

    Joined:
    Nov 30, 2007
    Messages:
    599
    Location:
    Bratislava
    I fixed the bug, download the new version on the repo.

    I'm not sure about C4A support - there are multiple game modes, you can start at different levels (if you achieved them previously).
     
  6. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,147
    Location:
    Innsmouth, MA
    Hi all :)

    @M-HT : thanks for fixing that bug ! Out of curiosity, what was it about, and what did you do to fix it ?

    Cheers, Magic Sam
    --- Double Post Merged, May 1, 2016, Original Post Date: May 1, 2016 ---
    I also managed to reproduce the crash I had.

    On the very first start, with no prior appdata/z-lock directory existing, if you stay for too long at the title screen, the demo will fail to load and the game will segfault (on a Rebirth unit, latest SZ installed, SGX driver 4.10, OC @ 825 MHz):

    =======================================================================================
    PND : /media/Pandora/pandora/menu/z-lock.pnd
    PND_FSTYPE : Squashfs
    APPDATADIR : /media/Pandora/pandora/appdata/z-lock
    APPDD_FSTYPE : ext3
    PND_CPUSPEED : <unset>
    EXENAME : ./z-lock.sh
    ARGUMENTS : <unset>
    =======================================================================================
    [ START ]--- Mount the PND ----------
    Mounting : mount -t squashfs -o ro "/dev/loop0" "/mnt/utmp/z-lock"
    Mounting the Union FS : mount -t aufs -o exec,dirs="/media/Pandora/pandora/appdata/z-lock=rw+nolwh":"/mnt/pnd/z-lock=rr" none "/mnt/utmp/z-lock"
    [SUCCESS]--- Mount the PND ----------
    [ START ]--- Starting the application ( ./z-lock.sh ) ----------
    Segmentation fault
    [SUCCESS]--- Starting the application ( ./z-lock.sh ) ----------
    [ START ]--- Restoring the frame buffer status ----------
    [SUCCESS]--- Restoring the frame buffer status ----------
    [ START ]--- Restoring nub mode ----------
    [SUCCESS]--- Restoring nub mode ----------
    [ START ]--- uMount the PND ----------
    [ START ]--- Waiting the Union to be available ----------
    [SUCCESS]--- Waiting the Union to be available ----------
    rmdir: failed to remove `/mnt/utmp/z-lock': Device or resource busy
    [ START ]--- Waiting the PND mount dir to be free ----------
    [SUCCESS]--- Waiting the PND mount dir to be free ----------
    cleanup done
    [SUCCESS]--- uMount the PND ----------
    =======================================================================================
    Return code is : 1

    Cheers, Magic Sam
     
    Last edited: May 1, 2016
  7. Farox

    Farox Certified Guru

    Joined:
    Jan 8, 2009
    Messages:
    2,006
    Location:
    Italy
    Magic Sam likes this.
  8. M-HT

    M-HT Very Active Member

    Joined:
    Nov 30, 2007
    Messages:
    599
    Location:
    Bratislava
    @Magic Sam:
    The bug was caused by an object that should have been created only once at the start, but it was also created after game over (while keeping previous instances). Since the object was involved in drawing, that increased the mount of work with each created object.

    I can confirm the crash, and I'll take a look at the cause.

    @Farox:
    Good find.
     
  9. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,147
    Location:
    Innsmouth, MA
    Hi all :)

    High score (normal mode): dead in sector #6 with ~2M points.

    EDIT: 1 983 620 points to be exact.

    What about you guys ?

    Cheers, Magic Sam
     
    Farox likes this.
  10. M-HT

    M-HT Very Active Member

    Joined:
    Nov 30, 2007
    Messages:
    599
    Location:
    Bratislava
    I fixed the crash, download the new version on the repo.

    @Magic Sam:
    Today I reached my highest sector in normal mode - sector 4. So you are better than me.

    Have you tried other modes?
     
    levi likes this.
  11. FBnil

    FBnil Ready to Champion the Pyra to the World...

    Joined:
    Dec 14, 2012
    Messages:
    2,458
    Location:
    Yurp
    .. still sector 2 only... so many projectiles to evade...
     
  12. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,147
    Location:
    Innsmouth, MA
    Hi all !

    @M-HT : thanks for fixing that second bug :)

    I have only played in normal mode so far, but I'll try the other modes soon. I believe normal mode, starting from level one, would be a great candidate for C4A support ;)

    On a side note, do you guys understand what the absorption button and the counter in the lower right corner are for ?

    Cheers, Magic Sam
    --- Double Post Merged, May 5, 2016, Original Post Date: May 5, 2016 ---
    OK, I gave all the other modes a go. Score Attack Normal and Time Attack Normal could also use some C4A support :p

    N.B: the high score for these two modes don't show up on the title screen, is this a bug ?

    Cheers, Magic Sam
    --- Double Post Merged, May 5, 2016 ---
    I finally broke the 2M points barrier in normal mode: 2 293 820 points :D (dead in sector 7)

    Cheers, Magic Sam
     
  13. M-HT

    M-HT Very Active Member

    Joined:
    Nov 30, 2007
    Messages:
    599
    Location:
    Bratislava
    The adsorption (not absorption) works only in normal mode and boosts your attack power even when your not locked. It lasts a short while and then has to recharge before it can be used again.
     
  14. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,147
    Location:
    Innsmouth, MA
    Hi all !

    @M-HT : oops, sorry for the confusion, and thanks for your explanation :)

    New hi-score: 2 655 830 points, dead in sector 8 :D

    Cheers, Magic Sam
     
  15. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,221
    Location:
    France, near Lyon
    At last I have tried it.

    It's good (all those D shooter are amazing, the D language must have been created just to make shoot'em up!!!)

    Got only to level 4 for my 1st run, with only 540k... still a long way to go it seems...
     

Share This Page

Loading...