Trouble Flashing latest firmware


st0x

Still Fresh
Joined
Sep 12, 2007
Messages
7
I grabbed the firmware from http://www.openpandora.org/downloads/SuperZaxxonFinal.zip , Seems I keep running into checksum fail. I have tried 2 different media cards. after rebooting it wont load the previous zaxxon hotfix 6 install, could it be the card reader causing the md5 fail?


update log attached below,


----------------


[ 0.000000] Linux version 3.2.16-00257-g22711aa (notaz@pixelinis) (gcc version 4.3.3 (Sourcery G++ Lite 2009q1-203) ) #604 Sun Apr 29 20:37:25 EEST 2012


[ 0.000000] CPU: ARMv7 Processor [411fc082] revision 2 (ARMv7), cr=10c5387d


[ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT nonaliasing instruction cache


[ 0.000000] Machine: Pandora Handheld Console


[ 0.000000] Reserving 8388608 bytes SDRAM for VRAM


[ 0.000000] Memory policy: ECC disabled, Data cache writeback


[ 0.000000] On node 0 totalpages: 61952


[ 0.000000] free_area_init_node: node 0, pgdat c04ae9e0, node_mem_map c04d4000


[ 0.000000] Normal zone: 512 pages used for memmap


[ 0.000000] Normal zone: 0 pages reserved


[ 0.000000] Normal zone: 61440 pages, LIFO batch:15


[ 0.000000] OMAP3430/3530 ES2.1 (l2cache iva sgx neon isp )


[ 0.000000] Clocking rate (Crystal/Core/MPU): 26.0/332/500 MHz


[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768


[ 0.000000] pcpu-alloc: [0] 0


[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 61440


[ 0.000000] Kernel command line: console=tty1 ramdisk_size=8192 root=/dev/ram0 rw rootfstype=ext2 initrd=0x82321000,8M vram=6272K omapfb.vram=0:3000K


[ 0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)


[ 0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)


[ 0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)


[ 0.000000] Memory: 242MB = 242MB total


[ 0.000000] Memory: 232388k/232388k available, 29756k reserved, 0K highmem


[ 0.000000] Virtual kernel memory layout:


[ 0.000000] vector : 0xffff0000 - 0xffff1000 ( 4 kB)


[ 0.000000] fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)


[ 0.000000] vmalloc : 0xd0800000 - 0xf8000000 ( 632 MB)


[ 0.000000] lowmem : 0xc0000000 - 0xd0000000 ( 256 MB)


[ 0.000000] modules : 0xbf000000 - 0xc0000000 ( 16 MB)


[ 0.000000] .text : 0xc0008000 - 0xc0442c18 (4332 kB)


[ 0.000000] .init : 0xc0443000 - 0xc0473000 ( 192 kB)


[ 0.000000] .data : 0xc0474000 - 0xc04af080 ( 237 kB)


[ 0.000000] .bss : 0xc04af0a4 - 0xc04d3ea4 ( 148 kB)


[ 0.000000] SLUB: Genslabs=11, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1


[ 0.000000] NR_IRQS:410


[ 0.000000] IRQ: Found an INTC at 0xfa200000 (revision 4.0) with 96 interrupts


[ 0.000000] Total of 96 interrupts on 1 active controller


[ 0.000000] OMAP clockevent source: GPTIMER1 at 32768 Hz


[ 0.000000] sched_clock: 32 bits at 32kHz, resolution 30517ns, wraps every 131071999ms


[ 0.000000] Console: colour dummy device 80x30


[ 0.000000] console [tty1] enabled


[ 0.000701] Calibrating delay loop... 497.82 BogoMIPS (lpj=1941504)


[ 0.039123] pid_max: default: 32768 minimum: 301


[ 0.039489] Mount-cache hash table entries: 512


[ 0.040069] Initializing cgroup subsys devices


[ 0.040161] CPU: Testing write buffer coherency: ok


[ 0.040435] hw perfevents: enabled with ARMv7 Cortex-A8 PMU driver, 5 counters available


[ 0.041412] devtmpfs: initialized


[ 0.054870] print_constraints: dummy:


[ 0.055450] NET: Registered protocol family 16


[ 0.055938] GPMC revision 5.0


[ 0.060272] OMAP GPIO hardware version 2.5


[ 0.065155] omap_mux_init: Add partition: #1: core, flags: 0


[ 0.073852] Reprogramming SDRC clock to 332000000 Hz


[ 0.076965] hw-breakpoint: debug architecture 0x4 unsupported.


[ 0.086914] omap-mcbsp.2: alias fck already exists


[ 0.087402] omap-mcbsp.3: alias fck already exists


[ 0.089416] OMAP DMA hardware revision 4.0


[ 0.111877] bio: create slab <bio-0> at 0


[ 0.113555] print_constraints: vwlan: 1800 mV


[ 0.115783] SCSI subsystem initialized


[ 0.119232] usbcore: registered new interface driver usbfs


[ 0.119628] usbcore: registered new interface driver hub


[ 0.120025] usbcore: registered new device driver usb


[ 0.121948] omap_i2c omap_i2c.1: bus 1 rev1.3.12 at 2600 kHz


[ 0.126037] twl4030: PIH (irq 7) chaining IRQs 368..375


[ 0.126190] twl4030: power (irq 373) chaining IRQs 376..383


[ 0.126922] twl4030: gpio (irq 368) chaining IRQs 384..401


[ 0.127532] _omap_mux_init_gpio: Could not set gpio192


[ 0.128967] _omap_mux_init_gpio: Could not set gpio193


[ 0.132507] print_constraints: VUSB1V5: 1500 mV normal standby


[ 0.133453] print_constraints: VUSB1V8: 1800 mV normal standby


[ 0.134399] print_constraints: VUSB3V1: 3100 mV normal standby


[ 0.136444] twl4030_usb twl4030_usb: Initialized TWL4030 USB module


[ 0.138305] print_constraints: vdd_mpu_iva: 600 <--> 1450 mV normal


[ 0.139221] print_constraints: vdd_core: 600 <--> 1450 mV normal


[ 0.140197] print_constraints: VMMC1: 1850 <--> 3150 mV at 3150 mV normal standby


[ 0.141235] print_constraints: VDAC: 1800 mV normal standby


[ 0.142181] print_constraints: VAUX2: 1800 mV normal standby


[ 0.143157] print_constraints: VPLL2: 1800 mV normal standby


[ 0.144195] print_constraints: VMMC2: 1850 <--> 3150 mV at 2600 mV normal standby


[ 0.145172] print_constraints: VSIM: 2800 mV normal standby


[ 0.146148] print_constraints: VAUX1: 3000 mV normal standby


[ 0.147064] print_constraints: VAUX4: 2800 mV normal standby


[ 0.156372] omap_i2c omap_i2c.3: bus 3 rev1.3.12 at 100 kHz


[ 0.159851] Advanced Linux Sound Architecture Driver Version 1.0.24.


[ 0.161010] Switching to clocksource 32k_counter


[ 0.193328] musb-hdrc: version 6.0, ?dma?, otg (peripheral+host)


[ 0.198760] musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx, HB-ISO Tx, SoftConn)


[ 0.198791] musb-hdrc: MHDRC RTL version 1.400


[ 0.198822] musb-hdrc: setup fifo_mode 4


[ 0.198852] musb-hdrc: 28/31 max ep, 16384/16384 memory


[ 0.199554] musb-hdrc musb-hdrc: USB OTG mode controller at fa0ab000 using DMA, IRQ 92


[ 0.200592] NET: Registered protocol family 2


[ 0.200866] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)


[ 0.201293] TCP established hash table entries: 8192 (order: 4, 65536 bytes)


[ 0.201599] TCP bind hash table entries: 8192 (order: 3, 32768 bytes)


[ 0.201812] TCP: Hash tables configured (established 8192 bind 8192)


[ 0.201843] TCP reno registered


[ 0.201873] UDP hash table entries: 256 (order: 0, 4096 bytes)


[ 0.201934] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)


[ 0.202331] NET: Registered protocol family 1


[ 0.202667] Trying to unpack rootfs image as initramfs...


[ 0.204254] rootfs image is not initramfs (no cpio magic); looks like an initrd


[ 0.272094] Freeing initrd memory: 8192K


[ 0.272155] NetWinder Floating Point Emulator V0.97 (double precision)


[ 0.274475] omap_dsp_init: 600000 bytes @ 8f200000


[ 0.307250] VFS: Disk quotas dquot_6.5.2


[ 0.307861] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)


[ 0.311401] msgmni has been set to 469


[ 0.314147] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)


[ 0.314208] io scheduler noop registered


[ 0.314239] io scheduler deadline registered


[ 0.314300] io scheduler cfq registered (default)


[ 0.328308] OMAP DSS rev 2.0


[ 0.332916] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled


[ 0.335937] omap_uart.0: ttyO0 at MMIO 0x4806a000 (irq = 72) is a OMAP UART0


[ 0.336547] omap_uart.1: ttyO1 at MMIO 0x4806c000 (irq = 73) is a OMAP UART1


[ 0.337158] omap_uart.2: ttyO2 at MMIO 0x49020000 (irq = 74) is a OMAP UART2


[ 0.353973] brd: module loaded


[ 0.362670] loop: module loaded


[ 0.362792] OMAP overclocker loaded.


[ 0.365905] omap2-nand driver initializing


[ 0.366149] NAND device: Manufacturer ID: 0x2c, Chip ID: 0xbc (Micron NAND 512MiB 1,8V 16-bit)


[ 0.366790] Creating 5 MTD partitions on "omap2-nand.0":


[ 0.366851] 0x000000000000-0x000000080000 : "xloader"


[ 0.367828] 0x000000080000-0x000000260000 : "uboot"


[ 0.369049] 0x000000260000-0x000000280000 : "uboot-env"


[ 0.369903] 0x000000280000-0x000000c80000 : "boot"


[ 0.372802] 0x000000c80000-0x000020000000 : "rootfs"


[ 0.473999] usbcore: registered new interface driver libusual


[ 0.474914] mousedev: PS/2 mouse device common for all mice


[ 0.475677] input: keypad as /devices/platform/omap/omap_i2c.1/i2c-1/1-004a/twl4030_keypad/input/input0


[ 0.478607] input: power-button as /devices/platform/omap/omap_i2c.1/i2c-1/1-0049/twl4030_pwrbutton/input/input1


[ 0.480133] input: nub0 as /devices/platform/omap/omap_i2c.3/i2c-3/3-0066/input/input2


[ 0.481933] input: nub1 as /devices/platform/omap/omap_i2c.3/i2c-3/3-0067/input/input3


[ 0.485778] twl_rtc twl_rtc: rtc core: registered twl_rtc as rtc0


[ 0.486511] i2c /dev entries driver


[ 0.494873] OMAP Watchdog Timer Rev 0x31: initial timeout 60 sec


[ 0.495452] twl4030_wdt twl4030_wdt: Failed to register misc device


[ 0.495513] twl4030_wdt: probe of twl4030_wdt failed with error -16


[ 0.496215] voltdm_scale: No voltage scale API registered for vdd_mpu_iva


[ 0.496246] platform mpu.0: omap_target: unable to scale voltage up.


[ 0.496734] cpuidle: using governor ladder


[ 0.496765] cpuidle: using governor menu


[ 0.497497] omap_hsmmc omap_hsmmc.0: multiblock reads disabled due to 35xx erratum 2.1.1.128; MMC read performance may suffer


[ 0.724853] Registered led device: pandora::sd1


[ 0.725189] Registered led device: pandora::sd2


[ 0.725494] Registered led device: pandora::bluetooth


[ 0.725799] Registered led device: pandora::wifi


[ 0.727111] Registered led device: pandora::keypad_bl


[ 0.728271] Registered led device: pandora::power


[ 0.730957] Registered led device: pandora::charger


[ 0.732360] usbcore: registered new interface driver usbhid


[ 0.732391] usbhid: USB HID core driver


[ 0.735015] OMAP3 Pandora SoC init


[ 0.826141] asoc: twl4030-hifi <-> omap-mcbsp-dai.1 mapping ok


[ 0.827758] asoc: twl4030-hifi <-> omap-mcbsp-dai.3 mapping ok


[ 0.830902] ALSA device list:


[ 0.830932] #0: omap3pandora


[ 0.831146] TCP cubic registered


[ 0.831207] NET: Registered protocol family 17


[ 0.831268] NET: Registered protocol family 15


[ 0.831298] Registering the dns_resolver key type


[ 0.831390] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 1


[ 0.831451] ThumbEE CPU extension supported.


[ 0.831512] Registering SWP/SWPB emulation handler


[ 0.835327] PM: no software I/O chain control; some wakeups may be lost


[ 0.839447] clock: disabling unused clocks to save power


[ 0.871551] Console: switching to colour frame buffer device 100x30


[ 1.066833] input: gpio-keys as /devices/platform/gpio-keys/input/input4


[ 1.072875] twl_rtc twl_rtc: setting system clock to 2012-07-23 00:40:58 UTC (1343004058)


[ 1.077239] RAMDISK: gzip image found at block 0


[ 1.094024] mmc0: host does not support reading read-only switch. assuming write-enable.


[ 1.108032] mmc0: new high speed SD card at address b368


[ 1.113006] mmcblk0: mmc0:b368 NCard 1.86 GiB


[ 1.126647] mmcblk0: p1


[ 1.270904] mmc2: card claims to support voltages below the defined range. These will be ignored.


[ 1.279418] mmc2: new SDIO card at address 0001


[ 1.519012] VFS: Mounted root (ext2 filesystem) on device 1:0.


[ 1.523376] devtmpfs: mounted


[ 1.527954] Freeing init memory: 192K


[ 6.043090] UBI: attaching mtd3 to ubi0


[ 6.043121] UBI: physical eraseblock size: 131072 bytes (128 KiB)


[ 6.043151] UBI: logical eraseblock size: 129024 bytes


[ 6.043182] UBI: smallest flash I/O unit: 2048


[ 6.043212] UBI: sub-page size: 512


[ 6.043243] UBI: VID header offset: 512 (aligned 512)


[ 6.043273] UBI: data offset: 2048


[ 6.085083] UBI: max. sequence number: 2278


[ 6.107879] UBI: attached mtd3 to ubi0


[ 6.107940] UBI: MTD device name: "boot"


[ 6.107971] UBI: MTD device size: 10 MiB


[ 6.107971] UBI: number of good PEBs: 80


[ 6.108001] UBI: number of bad PEBs: 0


[ 6.108032] UBI: number of corrupted PEBs: 0


[ 6.108062] UBI: max. allowed volumes: 128


[ 6.108062] UBI: wear-leveling threshold: 4096


[ 6.108093] UBI: number of internal volumes: 1


[ 6.108123] UBI: number of user volumes: 1


[ 6.108154] UBI: available PEBs: 0


[ 6.108184] UBI: total number of reserved PEBs: 80


[ 6.108184] UBI: number of PEBs reserved for bad PEB handling: 2


[ 6.108215] UBI: max/mean erase counter: 45/27


[ 6.108245] UBI: image sequence number: 2012535452


[ 6.111724] UBI: background thread "ubi_bgt0d" started, PID 733


[ 6.205780] UBIFS: mounted UBI device 0, volume 0, name "boot"


[ 6.205841] UBIFS: file system size: 8386560 bytes (8190 KiB, 7 MiB, 65 LEBs)


[ 6.205871] UBIFS: journal size: 1032193 bytes (1008 KiB, 0 MiB, 6 LEBs)


[ 6.205902] UBIFS: media format: w4/r0 (latest is w4/r0)


[ 6.205932] UBIFS: default compressor: lzo


[ 6.205963] UBIFS: reserved for root: 396117 bytes (386 KiB)


[ 14.063995] UBIFS: un-mount UBI device 0, volume 0


[ 14.086456] UBI: mtd3 is detached from ubi0


----------


+ . /etc/updater_funcs.sh


+ LOG_TTY=3


+ LOG_DEVICE=/dev/tty3


+ status_uboot=missing


+ status_uboot_env=already empty


+ status_uimage=missing


+ status_rootfs=missing


+ mkdir /mnt/ubifs


+ [ ! -e /dev/mmcblk0p1 ]


+ mdevs=/dev/mmcblk0p1 /dev/mmcblk0p2


+ bootfiles=bootf.tgz bootfiles.tar.gz uimage.tar.gz


+ cd /tmp


+ basename /dev/mmcblk0p1


+ mpoint=/mnt/mmcblk0p1


+ keep_mpoint=no


+ mkdir /mnt/mmcblk0p1


+ mount /dev/mmcblk0p1 /mnt/mmcblk0p1


+ [ -x /mnt/mmcblk0p1/initialize.sh ]


+ [ -e /mnt/mmcblk0p1/bootf.tgz ]


+ tar xzvf /mnt/mmcblk0p1/bootf.tgz


autoboot.txt


bootmenu.txt


u-boot.bin


uImage


uImage-2.6.27.57-omap1


uImage-3


+ [ -e /mnt/mmcblk0p1/bootfiles.tar.gz ]


+ [ -e /mnt/mmcblk0p1/uimage.tar.gz ]


+ [ -x /mnt/mmcblk0p1/finalize.sh ]


+ [ -e /mnt/mmcblk0p1/rootfs.img -a -e /mnt/mmcblk0p1/rootfs.md5 -a -z ]


+ rootfs_file=/mnt/mmcblk0p1/rootfs.img


+ + cut -c 1-32


head -n 1 /mnt/mmcblk0p1/rootfs.md5


+ rootfs_md5=fb136149154683fa0a5e6cd78d77e881


+ rootfs_mpoint=/mnt/mmcblk0p1


+ keep_mpoint=yes


+ [ yes != yes ]


+ basename /dev/mmcblk0p2


+ mpoint=/mnt/mmcblk0p2


+ keep_mpoint=no


+ mkdir /mnt/mmcblk0p2


+ mount /dev/mmcblk0p2 /mnt/mmcblk0p2


mount: mounting /dev/mmcblk0p2 on /mnt/mmcblk0p2 failed: No such file or directory


+ continue


+ [ -e u-boot.bin ]


+ stat -c %s u-boot.bin


+ size=524288


+ nanddump --omitoob --omitbad -q -l 524288 -f u-boot.bin.flashed /dev/mtd1ro


+ cmp u-boot.bin u-boot.bin.flashed


+ log u-boot.bin already flashed, skipped.


+ echo u-boot.bin already flashed, skipped.


u-boot.bin already flashed, skipped.


+ echo u-boot.bin already flashed, skipped.


+ status_uboot=already there


+ nanddump --omitoob --omitbad -q -f mtd2dump /dev/mtd2ro


+ cmp mtd2dump /usr/local/erasednandblk


+ ubiattach /dev/ubi_ctrl -m 3


UBI device number 0, total 80 LEBs (10321920 bytes, 9.8 MiB), available 0 LEBs (0 bytes), LEB size 129024 bytes (126.0 KiB)


+ mount -t ubifs ubi0:boot /mnt/ubifs


+ handle_kernels


+ ls uImage uImage-2.6.27.57-omap1 uImage-3


+ kernels=uImage


uImage-2.6.27.57-omap1


uImage-3


+ [ -z uImage


uImage-2.6.27.57-omap1


uImage-3 ]


+ cmp uImage /mnt/ubifs/uImage


+ log uImage already flashed, skipped.


+ echo uImage already flashed, skipped.


uImage already flashed, skipped.


+ echo uImage already flashed, skipped.


+ status_uimage=already there


+ cmp uImage-2.6.27.57-omap1 /mnt/ubifs/uImage-2.6.27.57-omap1


+ log uImage-2.6.27.57-omap1 already flashed, skipped.


+ echo uImage-2.6.27.57-omap1 already flashed, skipped.


uImage-2.6.27.57-omap1 already flashed, skipped.


+ echo uImage-2.6.27.57-omap1 already flashed, skipped.


+ status_uimage=already there


+ cmp uImage-3 /mnt/ubifs/uImage-3


+ log uImage-3 already flashed, skipped.


+ echo uImage-3 already flashed, skipped.


uImage-3 already flashed, skipped.


+ echo uImage-3 already flashed, skipped.


+ status_uimage=already there


+ [ -e bootmenu.txt ]


+ cmp bootmenu.txt /mnt/ubifs/bootmenu.txt


+ [ -e autoboot.txt ]


+ cmp autoboot.txt /mnt/ubifs/autoboot.txt


+ umount /mnt/ubifs


+ ubidetach /dev/ubi_ctrl -d 0


+ [ -n /mnt/mmcblk0p1/rootfs.img ]


+ log Calculating checksum, this might take a few minutes..


+ echo Calculating checksum, this might take a few minutes..


Calculating checksum, this might take a few minutes..


+ echo Calculating checksum, this might take a few minutes..


+ + cut -c 1-32


md5sum /mnt/mmcblk0p1/rootfs.img


+ real_md5=2180aa90d82992ff52339fe9d9711205


+ [ 2180aa90d82992ff52339fe9d9711205 = fb136149154683fa0a5e6cd78d77e881 ]


+ log INCORRECT


+ echo INCORRECT


INCORRECT


+ echo INCORRECT


+ cleanup


+ cd /tmp


+ [ -n ]


+ [ -n /mnt/mmcblk0p1 ]


+ umount /mnt/mmcblk0p1


+ false
 

Wrath Of Khan

Soul soother...
Joined
Dec 29, 2009
Messages
5,219
Age
45
Location
Ireland
Format the card with the samsung sdcard software and then put the latest zaxxon final firmware on it and try to flash again id say.edit for the life of me i cannot find a link to the samsung sdcard tool.Grrr
 

st0x

Still Fresh
Joined
Sep 12, 2007
Messages
7
cheers, I've used SDFormatter v3.0.0.0 with the same result
 

st0x

Still Fresh
Joined
Sep 12, 2007
Messages
7
Cheers Strigoi I just saw the post reporting the md5 issue.
 

DaMummy

Soldier Paste
Joined
Nov 5, 2009
Messages
4,417
Age
36
Location
Ohio
Format the card with the samsung sdcard software and then put the latest zaxxon final firmware on it and try to flash again id say.edit for the life of me i cannot find a link to the samsung sdcard tool.Grrr
likely because its the Panasonic SD Formatter...
:}
 

st0x

Still Fresh
Joined
Sep 12, 2007
Messages
7
Dodgy MD5 on the linked firmware on the main site. Downloaded elsewhere with no issues.
 

Donna

Still Fresh
Joined
Apr 16, 2011
Messages
22
Location
Maryland, USA
Wish I had seen this post first. :(


Flashed, failed, touchscreen not working at all. Downloading from link above. I'll try and see what happens. I'm crossing my fingers.
 

Donna

Still Fresh
Joined
Apr 16, 2011
Messages
22
Location
Maryland, USA
Arrghh! Re-flash didn't work. Luckily I have a bootable SD card I made over the weekend. Works like a charm. I'll stick with that for now & try fiddling with the re-flash tomorrow.
 

Donna

Still Fresh
Joined
Apr 16, 2011
Messages
22
Location
Maryland, USA
Did you used the firmware from ED's link, or the previous backup one from my site ?


http://openpandora.f...enpandora/temp/
I used the one from your site (for the re-flash attempt). I'm also going to try a different SD card tomorrow. The one I was using for the flash was an older 2GB card. I have a newer one (maybe it was a compatibility issue). I'll post results tomorrow. Thanks!
 

Donna

Still Fresh
Joined
Apr 16, 2011
Messages
22
Location
Maryland, USA
Linux-SWAT - your words inspired me to give it another go tonight. I deleted the file I downloaded from your site. I downloaded it again. This time I put it on a much newer 16GB SanDisk extreme SD card (instead of the old 2GB card). I booted, flashed, and - ta da! It is working again. :D


I can now sleep peacefully. Thanks again!
 
Top