Stupid Questions About Psp Firmware.


pubjoe

Member
Joined
May 21, 2003
Messages
577
Age
40
Location
Eastbourne SE England
Website
Visit site
Hi, haven't been here for a while.

I recently ordered a Japanese (v1.0) PSP from ebay. (this one to be exact.) due to xboxmodchips selling out.

I have some questions about the firmware updates.

1: If I buy U.S. Copies of some original launch games (thinking about wipeout, lumines & Hot shots golf), Will they update the firmware to 1.5? Should I buy the Japanese versions to avoid this?

2: I think I read that the firmware only updates if the PSP is plugged into a power source and it will not update on batteries, is this true?

3: Does it give you an option to update or can it do it automatically?

4: Is it that much hassel to run homebrew stuff & emualtors these days with 1.5 & KXploit v1.50?

I'm sorry, no doubt this has been discussed all over the net a million times but I'm just a bit confused by reading different things from different sources. Things like "it's inevitable your PSP will update".

Thanks for reading and sorry I haven't been round here for a while since selling by GP, I miss you guys :( . (A pspX type website/forums would be cool wouldn't it?).
 

Mark

Boris Johnson: Cuddly Conservative
Joined
Dec 27, 2003
Messages
2,806
Location
Stoke-On-Trent UK
Website
www.gp-magazine.org.uk
1) Nope, these games are fine.

2) No idea, although it would make sense. I assume it would make you update before you could play it though, and only Coded Arms at the minute forces you to upgrade to 1.50.

3) It gives you the choice, but you can't play without updating.

4) Kxploit is no hassle at all. It just creates an extra folder with a % in front of it.
 

Squidge

Certified Guru
Joined
Nov 16, 2003
Messages
8,495
Location
UK
Website
Visit site
At the moment, games which require a higher firmware version than the one you are running display a message should as "The game could not be started. The system software needs to be updated." or equivalent - it's upto you if you actually update the system or not, but the game will not run until you do (utilities are available to bypass this check though).

As for 1.50 homebrew, it's no hassle at all, once the homebrew is installed on your memory stick, just browse to the stick and choose from the menu selection just as the 1.0 firmware.

In fact, I'd prefer the 1.50 firmware, as more games are compatible with it.
 

pubjoe

Member
Joined
May 21, 2003
Messages
577
Age
40
Location
Eastbourne SE England
Website
Visit site
Steve-O posted on Jul 3 2005 at 06:33 PM said:
did you read his feedback??

Sent a 1.5 not a 1.0
Hope you get the one you paid for :)
Hmmmm... No, that comment has only just appeared!

Though I notice that on that auction's title v1.0 is not mentioned, where as it is on the one I won.

Anyway, if 1.5 isn't too much hassel, I'd probably end up updating anyway, so I'll wait and see.

Cheers for the help.
 
Last edited by a moderator:

finty

what is this
Joined
Feb 17, 2004
Messages
4,985
Age
30
Location
Ireland
Website
Visit site
Damn them PSP's are cheap.

/me knows where this summers pay is going.

EDIT: BTW, Welcome back pubjoe!
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,473
Age
42
Location
Ingolstadt
shinneri posted on Jul 3 2005 at 07:19 PM said:
pubjoe posted on Jul 3 2005 at 12:45 PM said:
A pspX type website/forums would be cool wouldn't it?
It's being worked on. :D

I'm thinking this is it: http://pspxtreme.com/
Hehe, no it's not :p
But the domain name is similar. It should soon be up, it's already in the testing stages.

And, same as gp32x, the site has a file archive run by me (which is already up on www.psparchive.de)
 
Last edited:

bast525

Well-Known Member
Joined
Dec 4, 2004
Messages
1,653
At this moment it doesn't really matter if you get a 1.0 or 1.5.

You can run the homebrew on each equally, with only a very small amount of extra 'trouble' to get it running on the 1.5.

So if you get the wrong one don't even worry about it.
 

argon0

Member
Joined
Sep 24, 2003
Messages
310
None so far.

Coool EvilDragon.... Getting a bit fed up with pspcrazy.com....

You'll have to link in Clare's PSP compatibility list on: http://www.berzerk.co.uk/psp-tracker/index.php

Its a rewrite of her GP32 compatibility list, after I pointed people at her site for an example of a decent compatibility list....

Argon0
 

saintdragon

Member
Joined
Feb 11, 2005
Messages
967
Age
28
Location
LONDON
Website
Visit site
i know its probable been said soooo many times but im getting a psp tomorrow and my quistion is would the firmware be 1.5? it was bought from japan(my home country :D) a week ago so what firmaware is it going to be? i cant wait till 2morrow!!!
 

argon0

Member
Joined
Sep 24, 2003
Messages
310
finty posted on Jul 5 2005 at 12:15 AM said:
It is and the guy who runs it is an idiot.

I have to agree - I liked it to start with, but its been really getting on my nerves the last couple of weeks - and its not very stable either...

It seems that a lot of the boards talking about psp are getting into the illegal thing - psp-spot for one - although pspupdates (formerly psphacker) are now trying to distance themselves from that side of things - BUT I don't like their fora or the stupidly intrusive amount of adverts they have.

Much prefer it over here.... (even though I'm going to sell my GP32 in the near future...)
 
Last edited by a moderator:

Squidge

Certified Guru
Joined
Nov 16, 2003
Messages
8,495
Location
UK
Website
Visit site
saintdragon posted on Jul 5 2005 at 12:38 AM said:
i know its probable been said soooo many times but im getting a psp tomorrow and my quistion is would the firmware be 1.5? it was bought from japan(my home country :D) a week ago so what firmaware is it going to be? i cant wait till 2morrow!!!
It could be a 1.5, but it also could be a 1.51 or above since it's being bought from Japan, which is where they come from. You'd be best getting one from the USA, as your pretty much guaranteed to get a 1.5 from there.

Just wait until tomorrow and see!
 
Last edited by a moderator:

saintdragon

Member
Joined
Feb 11, 2005
Messages
967
Age
28
Location
LONDON
Website
Visit site
well it doesnt matter what firmware iv got now, its too late iv got my psp already with ridge and its boom bangin(really good)! lol! hope its a 1.5!
 
Top