Open Red Alert


Mar 22, 2006
Manchester, UK
Right, I've got the file compiled and I'm trying to run it on the gp2x, but it keeps asking for certain mix files that I don't have.

Could someone PM me a list of all the .mix files that red alert has in its folders (post patching possibly)?

Sorry about the nature of this, although red alert is now free, but I have mobile broadband and don't want to go over my download limit for the month.

Thanks for that.

hhmmm interesting, since I have different files.

and the game isn't running as it is complaining that it cannot find local.mix

I'll tell you the files I have when i get back on monday
lobski said:
quasist said:
lobski said:
How's the speed?
60 soldiers/minute for a tank :)

That's pretty full speed! Any videos? Links? Info?

Dude, I'm pretty sure Quasist just made that speed up...

Anyway, I'd really like to see this in action myself. I can't get wargus to work on my gp2x and a open red alert port would be cool.
Last edited by a moderator:
Last edited by a moderator:
Last edited by a moderator:
Apologies all, I fell asleep for god knows how many hours yesterday....


How's the speed?


I'm sure I said that I couldn't get it running without the relevant files, although if you are talking about the game through the usual way (ie pc) than I don't know. I just figured after two failed attempts previously, with opencnc and freeRA, that I was going to have another attempt at this new one.

It's based on the above ports and I've had no major problems compiling it.

There are a couple of bugs in the game that would cause it to crash but I decided to port it anyway because, well, it's either that or wait for psx4gp2x.

So the mix files I have are:


Here is the debug.log:


Trying to load "RedAlert"...
WARNING: Missing required file "local.mix"
.MIX archives loading ok
Please wait, OpenRedAlert 462 is starting
Initialising the graphics engine...ERROR: Unable to open conquer.eng

If anyone would donate the local.mix I would be greatful, but knowing my luck, it'll probably complain about not having some other file that I don't have!!
Apologies for being "away" but life reared it's ugly head!

Anyway, I decided to compile openRA for windows and found it worked perfectly, however, Linux Game Tome shows this game entry as being supported for x11 only and not console.

Is there a quick way to recompile for console support or would the source code need to be entirely rewritten?
Last edited by a moderator:
Openredalert has significant portability issues in the code - it works fine on X86, but ARM has different data alignment and so ORA fails.

I did a bit of work on it last year to get it running on my Zaurus, but I never got around to finishing it.

Openredalert has significant portability issues in the code - it works fine on X86, but ARM has different data alignment and so ORA fails

Data alignment is a bit over my head tbh. Most of the code looked ok and I couldn't figure out why it worked on windows and not on arm, until you posted.

So basically on ARM the main and redalert files are found and are loaded ok, but it cannot access the submix files in the main/redalert mix files.

I'm going to do the long winded approach and extract all the files within the mix files and see if the program will work.


...How would you run this as a console app?

Isn't most stuff ported to the gp2x playable in the linux console?


Besides, doesn't the GP2x have an XServer port somewhere?

Tried the x11 project. Couldn't get the original server to give me xeye's but the GPE image worked!
Last edited by a moderator:
Oh ok - I dunno... :blink:

Anyway, I've been extracting the files from the mix files and I've gotten it to display the main menu and run the music - the intro video won't start.

Since this is a very early POC (proof of concept) style release, please bear in mind that the mouse doesn't work and to exit the program, you'll have to power off your gp2x.

If you would like to help, then you'll need the XCC utilities from this page -, a text editor and patience! :p

Open the debug.log and see what it's missing, then open the Mixer from the XCC utilities and extract the files from the .mix files (right click then click extract - not forgetting to add the file extension). Re-load the program and repeat. :)

openRA (rar file)
Last edited by a moderator: