Networking Issue.


VRAndy

Very Active Member
Joined
Sep 23, 2008
Messages
1,127
Ok, thanks for help getting the log-in to work. I reflashed and it works fine.

...Except, I can't get the network to work properly. I can connect to the access point... but then I can't do anything.

So I bring up a command prompt, and try to ping my desktop.

And I get
"From 192.168.0.202 icmp_seq=50 Destination Host Unreachable".

This is weird, because my router only gives out ips from 100 to 199. So I do ifconfig, and the wlan0 interface is configured exactly how I expect it to be, but there's another interface called usb0 using the 202 ip address. Where did this usb0 interface come from? Is it screwing up my ability to use the wifi? Or is there some other problem, and usb0 is completely innocent?

thanks.
 

WizardStan

Mega GP Mania
Joined
May 24, 2008
Messages
16,733
VRAndy said:
there's another interface called usb0 using the 202 ip address.
Oh, now that's interesting. You can do network through USB by plugging it into the USB on your computer and doing some configuration (at least in theory, I had that briefly setup on my BeagleBoard as well). At least that's what it looks like to me.
I wonder if this is causing issue with other people. Someone else mentioned a .202 address, I think. Something like that. I didn't pay it any mind.
Try "ifconfig usb0 down" in an xterm, see if you can take that interface offline and try to ping out again. At the least try pinging your router.
If that doesn't work, also try "/sbin/route add default gw 192.168.0.1" (or whatever the IP for your router is) and try again.
 
Last edited by a moderator:

VRAndy

Very Active Member
Joined
Sep 23, 2008
Messages
1,127
WizardStan said:
" in an xterm, see if you can take that interface offline and try to ping out again. At the least try pinging your router.
Woo. ThAt fixes it. Posting from PAndora now!

Easy enough work around if it happens again on reboot.

Thank you very much!
 
Last edited by a moderator:

God Ginrai

Godmaster
Joined
Nov 27, 2005
Messages
5,454
Website
Visit site
VRAndy said:
WizardStan said:
" in an xterm, see if you can take that interface offline and try to ping out again. At the least try pinging your router.
Woo. ThAt fixes it. Posting from PAndora now!

Easy enough work around if it happens again on reboot.

Thank you very much!
Just posting this here because it has the 202 address in it: http://www.gp32x.de/board/index.php?/topic/53630-help-with-wifi/page__view__findpost__p__859566

Will now link to this topic in the other thread to let Pleng try this if he gets any trouble again.

-God Ginrai
 
Last edited by a moderator:

VRAndy

Very Active Member
Joined
Sep 23, 2008
Messages
1,127
Wait, Celebration too soon. I rebooted and, as expected, the problem came back, but this time I can't bring down usb0. It says "SIOCSIFFLAGS: Permission Denied"

Oh well, I'm going to bed. At the moment I'm just happy to know that my Pandora's Wifi hardware if functional.
 

God Ginrai

Godmaster
Joined
Nov 27, 2005
Messages
5,454
Website
Visit site
VRAndy said:
Wait, Celebration too soon. I rebooted and, as expected, the problem came back, but this time I can't bring down usb0. It says "SIOCSIFFLAGS: Permission Denied"

Oh well, I'm going to bed. At the moment I'm just happy to know that my Pandora's Wifi hardware if functional.
Well, you can try Pleng's incantation to see if that works. (The post I linked to)

-God Ginrai
 
Last edited by a moderator:

cosam

Active Member
Joined
Sep 1, 2008
Messages
703
Location
Netherlands
Website
www.cosam.org
WizardStan said:
Oh, now that's interesting. You can do network through USB by plugging it into the USB on your computer and doing some configuration (at least in theory, I had that briefly setup on my BeagleBoard as well). At least that's what it looks like to me.
I wonder if this is causing issue with other people. Someone else mentioned a .202 address, I think. Something like that. I didn't pay it any mind.
Try "ifconfig usb0 down" in an xterm, see if you can take that interface offline and try to ping out again. At the least try pinging your router.
If that doesn't work, also try "/sbin/route add default gw 192.168.0.1" (or whatever the IP for your router is) and try again.
I was also mystified by that .202 address. Turns out it's hard-coded into /etc/network/interfaces for usb0 and may be claiming the route for 192.168.0.0/24. It is however not declared as "auto" so I'm not sure how it's getting ifup'd. If you're not using USB networking, it's probably easiest to remove the entry completely.
 
Last edited by a moderator:

WizardStan

Mega GP Mania
Joined
May 24, 2008
Messages
16,733
VRAndy said:
Wait, Celebration too soon. I rebooted and, as expected, the problem came back, but this time I can't bring down usb0. It says "SIOCSIFFLAGS: Permission Denied"

Oh well, I'm going to bed. At the moment I'm just happy to know that my Pandora's Wifi hardware if functional.
Yeah, seems the wifi is working, that USB network connection is causing problems. First, if I've read everything correctly, it shouldn't be coming up automatically, and yet it is, and second, it shouldn't be the primary even if it is up. I wish I had my own Pandora so I could help troubleshoot better :(
 
Last edited by a moderator:

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,564
Age
43
Location
Ingolstadt
VRAndy said:
Wait, Celebration too soon. I rebooted and, as expected, the problem came back, but this time I can't bring down usb0. It says "SIOCSIFFLAGS: Permission Denied"
You need to be root to do that. So either type sudo ifconfig usb0 down or become root before that.

Weird though that this happens - USB Net is enabled on every Pandora and we've never encountered that... hmmm..
 
Last edited:

multiplex

Member
Joined
Aug 20, 2008
Messages
189
EvilDragon said:
VRAndy said:
Wait, Celebration too soon. I rebooted and, as expected, the problem came back, but this time I can't bring down usb0. It says "SIOCSIFFLAGS: Permission Denied"
You need to be root to do that. So either type sudo ifconfig usb0 down or become root before that.

Weird though that this happens - USB Net is enabled on every Pandora and we've never encountered that... hmmm..
Could it depend on what IP the router gives out? Seems to be router specific, at least.
 
Last edited by a moderator:

VRAndy

Very Active Member
Joined
Sep 23, 2008
Messages
1,127
EvilDragon said:
VRAndy said:
Wait, Celebration too soon. I rebooted and, as expected, the problem came back, but this time I can't bring down usb0. It says "SIOCSIFFLAGS: Permission Denied"
You need to be root to do that. So either type sudo ifconfig usb0 down or become root before that.

Weird though that this happens - USB Net is enabled on every Pandora and we've never encountered that... hmmm..
After further experimentation it seems to be somewhat random, I can't figure out what the pattern is. Occasionally it boots up and works fine, but most of the time that USB0 interface is up and messing with me. For what it's worth I've never plugged anything into any of the USB ports on the device.

When I get home I'll try commenting it out of the interfaces file.
 
Last edited by a moderator:

singler

Member
Joined
Mar 6, 2010
Messages
75
some for some people it works because 192.168.0.0/24 not everywhere is local subnet, if their wifi is configured for ex. 192.168.1.0/24 then 192.168.0.0/24 configuration will not interfere. if their wifi is on 192.168.0.0/24 and wifi interface is also up, it might be that Pandora sends some packets to wifi and some to usb
 

rohezal

Advanced Member
Joined
Oct 18, 2009
Messages
1,678
SiNGLerLT said:
some for some people it works because 192.168.0.0/24 not everywhere is local subnet, if their wifi is configured for ex. 192.168.1.0/24 then 192.168.0.0/24 configuration will not interfere. if their wifi is on 192.168.0.0/24 and wifi interface is also up, it might be that Pandora sends some packets to wifi and some to usb
Sometimes sudo is not enough (controll for usb bus, had some problems with my freerunner). Try the following:

sudo su //to become super user
ifconfig usb0 down //or what you want to do with it
 
Last edited by a moderator:
Top