Beta Midori 0.3.3

Jey123456 said:
./midori.bin: error while loading shared libraries: cannot open shared object file: No such file or directory

is the line that interest us here. whats your missing is that library. there is a fix on the openpandora board.

ok, that seems to have worked out... and it IS very fast... faster than lightweight2 on my PND... BUT... it still doesn't support Gmail... so it will be a general browser, but I will continue to work with lightweight2 for gmail support... the old html look/functionality of Gmail is very inefficient for me and my purposes... now, if someone were to port Thunderbird, I wouldn't even bother with a browser for mail... :p but that might be a tall order...
Last edited by a moderator:
This new version seems a bit crashier than the previous "fixed" version...

Here's a .out file from a recent crash:

PND_ARGS        : -p /media/mmcblk0p1/pandora/menu//midori-0.3.3-1.pnd -e ./run -b midori-0.3.3
PND             : /media/mmcblk0p1/pandora/menu//midori-0.3.3-1.pnd
PND_FSTYPE      : Squashfs
APPDATADIR      : /media/mmcblk0p1/pandora/appdata/midori-0.3.3
APPDD_FSTYPE    : vfat
PND_CPUSPEED    : <unset>
EXENAME         : ./run
ARGUMENTS       : <unset>
[10h01m35   START ]=== Mount the PND ==================================================
[10h01m35    INFO ]   Mounting : mount -t squashfs "/dev/loop1" "/mnt/pnd/midori-0.3.3"
[10h01m35    INFO ]   Mounting the Union FS : mount -t aufs -o exec,noplink,dirs="/media/mmcblk0p1/pandora/appdata/midori-0.3.3=rw+nolwh":"/mnt/pnd/midori-0.3.3=rr" none "/mnt/utmp/midori-0.3.3"
[10h01m36 SUCCESS ]=== Mount the PND ==================================================
[10h01m36   START ]=== Starting the application (./run ) ==============================
[10h01m37   ERROR ]   ls: cannot access ./plugins: No such file or directory
[10h01m37    INFO ]   ./midori.bin: /usr/lib/ no version information available (required by /mnt/utmp/midori-0.3.3/lib/
[10h01m38    INFO ]   
[10h01m38    INFO ]   ** (midori.bin:9820): WARNING **: No root certificate file is available. SSL certificates cannot be verified.
[10h01m39    INFO ]   
[10h01m39    INFO ]   ** (midori.bin:9820): WARNING **: /usr/lib/midori/ undefined symbol: katze_net_new
[10h02m37    INFO ]   unhandled event 19
[10h02m40    INFO ]   Loading stream:
[10h12m52    INFO ]   ././run: line 11:  9820 Segmentation fault      ./midori.bin
[10h12m52  FAILED ]=== Starting the application (./run ) ==============================
[10h12m53   START ]=== uMount the PND =================================================
[10h12m53    INFO ]   cleanup done
[10h12m53 SUCCESS ]=== uMount the PND =================================================
Return code is : 3
I've choosen Midori 0.3.3 onto my new Pandora for browsing (besides Firefox for the "serious" stuff). Midori works good, crashed once (I had 3 tabs open and I guess it just loaded itself to death).
Midori itself seems to be good but I couldn't make some website functions to work. For example, here in this Forum you can minimize each cathegory onto the mainpage (cannoo, wiz) with the small minus onto the right side at the top of each category - this doesn't work in Midory even if "scripts" are enabled in the options (of course there is no indication of what scripts it means)
Another thing, I want to bring the "Favorites" star onto the top bar besides the "ad favs" star icon because only the last one is there, the other is in this strange "sidebar" hidden. So how can I bring the real Icon to this bar so I can access the favs more quickly?
Once, the sidebar (I pushed the wrong button I guess) somehow blewed up the entire Midori Window to giant size, only a restart of the Browser worrked.

Another thing I would like to know is, if there is a way to block advertisement'n stuff with Midori (without global deactivating scripts)? Because it takes longer to load and eats alot of space/memory.

Last thing I noticed during browsing is that Midori 0.3.3 sometimes produces artifacts of Website content during scrolling so you end up in a mess after some time when you scroll through pages (everything mixes up somehow).
Bugs in Webkit causes articats/js-bugs, and as the compilers available for the pandora is so udderly broken, I can't get anything newer working.
slaeshjag: couldn't you just grab the angstrom compilers and work with those? I'm sure they are less broken than Pandora's...
slaeshjag said:
Bugs in Webkit causes articats/js-bugs, and as the compilers available for the pandora is so udderly broken, I can't get anything newer working.
sounds like it would be a good idea to use a better version of this "webkit", if there is one available. Seems to be an important base of Midori, so why not start there. ^^
I also found out, that Midori sometimes has trouble with simple gif animations. I really wonder how Midory was able to make 100% in this acid test.
Last edited by a moderator: