Help with USB mouse/keyboard/video game controller


Still Fresh
Aug 7, 2012

Hello, I'm a new user of the Pandora as I received my unit one week ago and absolutely love it. I am using Open Pandora Rebirth Edition with Super Zaxxon 1.5 and Kernel 3.2.

I had a couple brief questions and hope someone can help me. I have reviewed these forums, Googled for help, and have tried many different suggestions on the Pandora but just can't seem to find the answer I'm looking for. I have a USB hub, which is USB 2.0 (Belkin Hi-Speed) and it works fine. It loads up my USB memory sticks just fine. I have no problems at all running a USB memory stick from the USB 2.0 hub. But that is all I can get the hub to load. I have a Verbatim USB wireless mouse/keyboard that when I plug in the USB stick, it lights up as being powered on the USB hub, but the mouse and keyboard do not work on the screen of the Pandora. Mouse movement lights the USB stick as active but nothing happens with the Pandora. I have tried 2 other USB mouses (a Logitech and an Apple Mighty Mouse powered by Blue Tooth) and neither of those worked either. I also tried a wired USB video game controller but it does not work - there is a power light on it that does not come on when plugged into the hub. Yet, I confirmed both PC mouses, the keyboard, and game controller all work 100% perfectly on my PC just fine, and the Mighty Mouse works on my Mac. I am not sure what the problem seems to be. Everyone on the forums says it's all about USB 2.0 and that's what I use but there seems to be no explanation for the devices not functioning. Is there something I need to do once I plug them in to make them work? I thought the items were plug-n-play and that no further action is required.

Like I said, the USB hub is 2.0 and is enabled. The hub itself works fine on the Pandora. I also enabled Pandora to boot with the USB enabled but that didn't help. I feel like there's just one thing I'm doing wrong but can't pinpoint it. Your help would be highly appreciated. Everything else on this device is perfect and all I need is a functioning game controller and mouse and i'll be in heaven! Thanks for any help you can offer.
Generally USB Keyboards and the like just work..

It's been reported that some HUBs require you plug in the devices into the HUB first and then plug the HUB into the Pandora ..

Also if you happened to plug in a USB 1.1 device directly into the USB 2.0 port it locks up the USB Kernel module.. you need to power down the Pandora completely and power it back up again for it to accept devices again.
Last edited by a moderator:
Hello and thanks for the replies guys!

I just purchased a Logitech F310 corded USB game controller. The hub has powered it up and lsusb shows the device, but I am unable to set mapkey/controls. Is that something I can do in a Pandora option or is it emulator specific? Right now, none of the buttons do anything yet the controller is turned on and recognized by the Pandora.

I had gone as far as restarting the device multiple times, sometimes taking the battery out altogether since a USB 1.1 may have previously locked it up, but that seemed to not help in the matter.

One thing the manual for the Logitech game pad says is that if you use a hub to run it, the hub must have its own source of power. Not sure if that is true or not as it's currently powered up on my hub which is not self-powered by AC or battery, just a plug into the Pandora itself.
There was some driver notaz compiled for a logitech gamepad, because otherwise it wouldn't work. It should be in the next firmware though.
Last edited by a moderator:
Look here:

Edit: What is the output from dmesg and lsusb?
Last edited by a moderator: