My USB hub isn't working


Dec 8, 2011
So, wanting to enable using additional hardware with the Pandora, I bought a 2-port USB hub, manufactured by Mobile Computing. It's said to be backwards compatible with USB 1.1, but none of my peripherals (tried both USB 1.x and 2.0 devices) got power through it. The LED on the hub itself lighted up when connected to the Pandora, though. It works fine on my Ubuntu PC.

..Any help?
Sometimes "backwards compatible" mean that it is a USB 1.1 hub that is stamped as a Usb 2.0 hub. They can justify this because USB 2.0 devices will work on the hub, just in low speed mode. I've run into this a couple of times already. I personally use this. With great success. In fact I've bought several.
First try plugging in you devices to the HUB before plugging it into the Pandora.. It's a known but that if you plug in certian hubs without any devices connected it can crash the USB kernel Module.. you will need to power down and start up the Pandora for it to detect USB devices again..
Last edited by a moderator:
Thanks.. ..but it didn't work. I had a pretty old mouse connected, along with my current keyboard. Nothing. I tried multiple reboots with the hub already attached and not, no devices, one device or two of these already attached, leaving the Pandora there for a moment with the hub..

The mouse and the keyboard simply don't get power at all. But it worked for you, and I find that odd.

Edit: So I tried booting with the older kernel - and what do you know, it worked!

I'd love to be able to use my hub in the newest beta of SuperZaxxon with kernel 3.2 as well :) But this is better than nothing - it'll speed up writing and playing by a bunch, if need be.
Last edited by a moderator:
Yes, it worked!

..Now, how do I make a file which I can run so that I'd be able to do this by simply executing it? I tried to make a shell script, but the autorun didn't work, and being a linux noob I don't know a workaround ^^;