HELP!!! Can't restore system backup!!!


Still Fresh
Dec 16, 2012
Alright, so i have spent the last three days trying to resolve this issue on my own to no avail. I usually boot angstrom from the sd card in slot 1, and load pnds off the one in slot 2. Recently, i decided to update superzaxxon from 1.53 to 1.54, so i made a backup using the script from the wiki that copies over your nand:

sudo su
mkdir /mp
mount --bind / /mp
cp -va /mp/* /media/<SD card>
umount /mp
rmdir /mp

and replaced <SD card> with "sd_drive/NAND_DATA", which is the directory on my second card that i use for backing up my os. (This method of backup has always worked for me in the past). I then updated to superzaxxon 1.54, but forgot to run the updater twice in a row, so my wifi drivers got deleted. I booted back to the nand, reformatted the first sd card with gparted, restored my backup, and booted to the first card. However, when i try to login, i see the command line flash for a second and then i am returned to the login screen. I typed exit to go to the command line and find the error, but there were no error messages displayed(besides the usual ones that happen anyway). I tried restoring the os by copying over my nand to the card, then copying over my backup and selecting "copy and replace all". This allows me to login and see the switch gui screen (i have switchgui set as my default boot option) however, selecting xfce causes the same problem (command line flashes, then returns to login screen) and minimenu just hangs indefinitly (i was able to get mmenu to load once, but i cant remember how), the only option that will load is openbox, although the wifi does not work for some reason. I also tried restoring my backup, booting to the nand, downloading a fresh copy of the 1.53 filesystem, and copying over the new files to the sd card (i thought that by overwriting the old files with the new ones it would replace any files that may have been damaged during the backup, and it would boot to a fresh intallation of angstrom). Obviously, the first boot file was found, so the first boot dialogue didn't show, and it couldnt find my user profile (i guess the file that remembers the profiles was overwriten) so i typed exit at the login screen, logged in as root from the command line, and used adduser to re-add my profile, returned to the login screen and tried to login again, but i just had the same problem where the command line flashes and i return to the login screen (i can't remember whether or not i made it to the switchgui screen that time). I think that this means that my backed-up files aren't corrupted, and the problem must be one of the files that i installed myself. I think the problem could be cause by openbox, since i didnt have it installed the last time i successfully restored a backup (and i use themes from openbox in xfce), but i cant remove it because xfce and mmenu dont work. I tried to remove it from the command line by launching the pnd and calling the uninstall script (i used the code from the desktop launcher to do this)

/usr/pandora/scripts/ -p "/media/sd_drive/pandora/apps//switchguiopenbox.pnd" -e "" -b "switchguiopenbox55"

but the pnd wont load. I also know that its not the sd card thats the problem because copying over the nand boots up just fine. Sorry this post has been so long, i wanted to make sure i explained everything i have tried over the last three days in the hope that it will help someone find a solution to this problem. I would really appreciate it if someone could help me out, because i don't want to lose all the changes i have made since i started booting from the sd card. I will try to upload a complete copy of my backup filesystem so that someone can recreate the issue that i am having. Thanks very much to anyone who can help.
im hoping to have my backup uploaded sometime tomorrow. Anyone who thinks they can help in the mean time please do so (i use my pandora for school and not having it is hurting me).
im giving up trying to solve this as i need my pandora back for school. if anyone thinks they know a solution it would still be nice to know for the future.