F/w 1.4.0


c17

Still Fresh
Joined
Jul 24, 2003
Messages
55
Ok, i d/l the F/W 1.4.0 file, unziped and get 3 files, including a .tar file that contains 3 folder.

i copy over the 3 files using a card reader and connecting my GP2x to the USB port, but no firmware update on boot.

i have the original, First edition, firmware still on my GP2x, but it will not update for some reason.

i'm using a 1Gb SD integral card supplied by Craigx, and it's been formated per the instructions from the official website.

Could anybody give me any ideas why it wont 'auto flash'

Thanx

c17.
 

Claym99

Member
Joined
Dec 13, 2005
Messages
234
Age
30
Location
Caldwell, Idaho
Website
www.myspace.com
the kernel only updates briefly while loading and then the file is deleted...if it updated your screen while loading will say 1.4.0 then go to utilities and run the patch it'll take a little while...then all will be fine.
 

barnesy

Member
Joined
Sep 5, 2003
Messages
488
Website
Visit site
I have the same type of card - it doesn't work for firmware updates. It works fine for other stuff though.

You can still use RobB's updater though. You can get it from here: http://gbax.com/firmware/flasher.zip

Make sure you read the instructions included with it, and you'll hopefully be OK.
 

Tobriand

Very Active Member
Joined
Dec 27, 2002
Messages
4,071
Age
34
Location
Croydon (UK)
Website
Visit site
Another thing I discovered today was that a card doesn't only need to be formatted in Fat32. It needs to be *freshly* formatted in Fat32 - deleting everything doesn't always work. Formatting seems to much mroe reliably, even if you only just formatted it to flash another image. Maybe it only reads the first couple of bytes of a card to see if there's anything there rather than checking properly or something... God knows.
 

rokdcasbah

got me a date with botticelli's niece
Joined
Jan 5, 2006
Messages
1,517
Location
up on cripple creek
i expected to have to do a fresh format or at least clean everything off, but no...i just put the kernel image in the root and left everything else on there and it worked fine. not to mention, i have a card that's listed in the wiki as not compatible (the older PNY 1gb). just lucky i guess?
 

andyB911

Member
Joined
Feb 12, 2005
Messages
365
Location
The Village
Website
Visit site
I've also got the 1gb integral card from gbax and its formated correctly but firmware scripts not detected at boot time. Can't work out why not for me and does work for others - but hey, the flasher script worked fine - so thanks for the link barnesy.
 
Top