Easy Bluetooth Headphone Solution


Hmmm, that sounds like something that could be implemented into the OS.

Have two asound.conf available, switch them and restart ALSA - is that all that's needed?

Someone should put that into the Pandora-Tray-Options (I could only do a toggle script).

Just a few more questions:

1. As that replaces the ALSA device, does it work with all stuff that plays audio?

2. If it only works with players, can't the Bluetooth be added as it's own ALSA device using the config? Then you should be able to use your player to choose the ALSA device at anytime.
 
When it comes to adding more plugins to the config tray icon; I got a half-implemented plugin manager I could finish, now that the amount of plugins is starting to approach the practical limit of what you can have loaded without having to scroll.

Wrapping a toggle script in a plugin would be trivial.
 
Well, you should be able to add a bluetooth headset device by adding the following to your existing asound.conf:


pcm.btheadset {
type plug
slave {
pcm {
type bluetooth
profile "auto"
}
}
hint {
show on
description "BT Headset"
}
}
ctl.btheadset {
type bluetooth
}

This should add an ALSA device called btheadset which you should be able to select using Audacious in the settings.
 
Last edited by a moderator:
Well, you should be able to add a bluetooth headset device by adding the following to your existing asound.conf:












pcm.btheadset {
type plug
slave {
pcm {
type bluetooth
profile "auto"
}
}
hint {
show on
description "BT Headset"
}
}
ctl.btheadset {
type bluetooth
}

This should add an ALSA device called btheadset which you should be able to select using Audacious in the settings.
Thanks ED :)   

Used your suggestion and got this to work on my Sony Smart Wireless Headset pro http://www.sonymobile.com/global-en/products/accessories/smart-wireless-headset-pro/

Though no working prev / next,  play / pause on the device.

Anyway, switching from bluetooth to non-bluetooth or vice-versa remains tricky.

In Audacious, once I have BT working as output, switching to non-BT again (i.e. going back to default PCM device via prevs) works fairly nicely. Afterwards, just select another song and output switches to speakers.

The other way around though is less smoothly. Then I get ALSA error messages. Then I need to quit the app en relaunch it to get BT-output to work.

Deadbeef is a bit more trouble.

From BT, once that works, to non-BT it switches immediately after the setting is made; no need to select another song afterwards even.

To get BT again working though is a lot more trouble (I haven't been able to reproduce consistent results of what happens, but it seems at least you can't switch the output plugin and output device at the same time and need to quit and relaunch app a few times when making the setting changes needed)

I am fairly happy with Audacious
 
Last edited by a moderator:
One of the downfalls of forums and non-standard titles, etc. is that the same problems get solved over and over. If you check out this thread:

http://boards.openpandora.org/topic/12875-bluetooth-audio-request/#entry251303/URL]

I posted "a way" to get your bluetooth headphones and a UConnect automobile system working. It is unfortunate that there is not a better way. I am going to try ED's solution to see if that works better. I find it very frustrating to have to do all this futzing as well as maintaining multiple player apps and then keep track of what players work for what uses. I wouldn't put up with it on any other device I own, but the P is special.
 
Last edited by a moderator:
^ I'd say that the asound.conf method is a definite improvement over the .asoundrc one.
I agree it looks that way. I'm going to try it, but I don't see how it will replace my method as it does not include the BT address of the device. I hope I am wrong.
 
Not working for me. The BT headset showed up in the device list using VLC and Deadbeef, but VLC puked when I tried to play and Deadbeef didn't work. I tried it with the default .asoundrc and then I renamed .asoundrc so that alsa would recreate or not have one. What am I missing? Let's attempt to get all of the correct instructions (and maybe working players) into a single post, preferably the first post.
 
I've ordered a BT speaker, I'll give it a go with the Pandora when it arrives, hopefully it will work so that I can use it in the bathroom.
 
Not working for me. The BT headset showed up in the device list using VLC and Deadbeef, but VLC puked when I tried to play and Deadbeef didn't work. I tried it with the default .asoundrc and then I renamed .asoundrc so that alsa would recreate or not have one. What am I missing? Let's attempt to get all of the correct instructions (and maybe working players) into a single post, preferably the first post.
The steps that I used to get things working were.


Turn on Bluetooth


Pair headphones


Modified asound.conf file (file attached)


Started up DeaDBeeF


Made sure that output plugin was set to ALSA output plugin and output device was set to default audio device


Job Done


Edit: Forgot to mention Pandora may require a restart after switching asound files, then DeaDBeeF will work fine.

asound.zip
 

Attachments

  • asound.zip
    343 bytes · Views: 166
Last edited by a moderator:
Sounds like a lot of fussing.

I'll maybe stick to using BT speaker via my PC or phone.
 
Not working for me. The BT headset showed up in the device list using VLC and Deadbeef, but VLC puked when I tried to play and Deadbeef didn't work. I tried it with the default .asoundrc and then I renamed .asoundrc so that alsa would recreate or not have one. What am I missing? Let's attempt to get all of the correct instructions (and maybe working players) into a single post, preferably the first post.
Its not .asoundrc you need to modify. Take a loook at http://boards.openpandora.org/topic/9282-easy-bluetooth-headphone-solution/#entry301428/URL]
 
Last edited by a moderator:
The steps that I used to get things working were.


Turn on Bluetooth


Pair headphones


Modified asound.conf file (file attached)


Started up DeaDBeeF


Made sure that output plugin was set to ALSA output plugin and output device was set to default audio device


Job Done


Edit: Forgot to mention Pandora may require a restart after switching asound files, then DeaDBeeF will work fine.
Just checking, I set the output device to the default audio device? When I do that, it goes to the P speakers. I thought I would select the BT Headset as the output device. BTW, I did restart the P after I modified my asound.conf.
 
Back
Top