Audacious does Not Play After Pause Fix


Active Member
Oct 1, 2006
Short Version:
The Problem: Audacious does not resume play after pause is used.

The Possible Fix (run from terminal with WiFi enabled and connected to Internet):

 sudo opkg install
This updates the ALSA library and its plugins on the NAND.
If you experience the pause problem try it and post results.

TL;DR Version:

I have been invited to a ‘bring your own music device’ social gathering. I want to use the Pandora (with the WinAmp Classic interface) to play music.

Ever since upgrading to the 1 GHz Pandora I have experienced the problem where when using the ALSA output plugin Audacious does not resume play after pause is used.

The /tmp/pndrun_audacious.out file indicates the following error:
alsa: snd_pcm_pause failed: Input/output error

I tried the other output plugins but none were satisfactory.

OSS3 has a nasty click and pop whenever the sound is stopped and started again (pause, seek, next track, etc.) And the pause automatically advances to the next whole second. It also constantly hammered the the /tmp/pndrun_audacious.log with a mixer error.

SDL was a lot better as the pause worked but it could not pass my stability test. It has to run for at least 24 hours straight without crashing. Using SDL Audacious would just unexpectedly quit to the desktop. Sometimes the log would show a seg fault.

Then I tried installing XMMS to NAND from the angstrom repo. It worked but had the same ALSA pause problem and the OSS click and pop was even louder.  XMMS, being the original, also lacked the bells and whistles of Audacious.

So I went back to Audacious and the pause worked!

I re-examined what XMMS installed and noticed that it upgraded libasound2 on root from 1.0.20-r3.5 to 1.024.1-r0.6

Then I re-flased SZ 1.54 and ran the following command from the terminal:

sudo opkg install
The alsa: snd_pcm_pause failed: Input/output error still happens in the log file but now the pause actually works.  If you experience the pause problem try it and post results. You don't need to re-flash just the sudo opkg install.  I am currently testing the stability.
Last edited by a moderator:
Your welcomed and thanks for testing.

I can also confirm that Audacious is stable after the fix. I ran it for 36+ hours and it did not crash.
failed to download... I`m pretty sure I have that line right :(

I`ll try it when I get home!



EDIT: weird... I went to the location manually and found the file and downloaded.... might be my crappy work connection..
Last edited by a moderator:
I've tried doing the opkg install over wifi and over usb tether, but I always get: failed to download......., wget returned 1.

If I were to download the file manually, how do I install it on my Pandora?

Edit: Hmm... when I try to go download the file, it says page not found? O. o

Edit2: Well copy pasting the command into terminal worked. For the life of me I can't see that I typed anything different, but something wasn't right. All sorted now. :)
Last edited by a moderator:
I wanted to mention that Audacious doesn't play any files with special characters anymore, it did in the past. I'm not sure if this is an OS issue (general character encoding) or some kind of bug in  newer audacious versions, at least the PC Versions had a bugfix, maybe this can help?

I had some OS updatess on the Pandora and didn't used Audacious fo a while. But recently I found out that it doesn't play alot of my songs anymore, the playlists are still displayed, even correctly with special charaters and everything but the files are not played (skipped).  I don't want to rename everything, I hope to catch the problem at the root, so whoever can test and fix this, please take a look at the file encoding of Audacious. ^^
Wild speculation: perhaps your media are now mounted with different encoding settings?
Not sure what you mean. I actualy didn't change anything. It's just the file names because renaming works. But it worked in the past with the same files and with included special (non english) characters. So if I didn't change anything, it actualy must be Audacious update or the OS update. ^^"