Can't Smbmount On Windows - 'errnoaccess (access Denied.)'


hitbyambulance

Active Member
Joined
Nov 26, 2005
Messages
634
Location
Seattle, WA
Website
troubletype.org
i followed the instructions here after setting up the TCP/IP access as detailed here, to the letter. i have a shared directory on my WinXP machine called The_Hutch and i did "mkdir /mnt/winshared" on the GP2X. after telnetting onto the GP2X with PuTTY, i do

smbmount //10.1.0.1/The_Hutch /mnt/winshared

i then get

148: session request to 10.1.0.1 failed (Called name not present)
148: session request to 10 failed (Called name not present)
Password:


after hitting Enter, then i get

Anonymous login successful
151: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed


any shared directory i create under WinXP does the same thing. what am i doing wrong, or what do i need to do first?
 

jaesond

Still Fresh
Joined
Jan 17, 2006
Messages
78
i followed the instructions here after setting up the TCP/IP access as detailed here, to the letter. i have a shared directory on my WinXP machine called The_Hutch and i did "mkdir /mnt/winshared" on the GP2X. after telnetting onto the GP2X with PuTTY, i do

smbmount //10.1.0.1/The_Hutch /mnt/winshared

i then get

148: session request to 10.1.0.1 failed (Called name not present)
148: session request to 10 failed (Called name not present)
Password:


after hitting Enter, then i get

Anonymous login successful
151: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed


any shared directory i create under WinXP does the same thing. what am i doing wrong, or what do i need to do first?
Everytime I used smbmount I added in a username and password in the command itself. It gave me one error, but that error was ignorable, since I was still able to view the shared folder and read content. If you need a reference of commands, use this webpage.
 
Last edited by a moderator:

hitbyambulance

Active Member
Joined
Nov 26, 2005
Messages
634
Location
Seattle, WA
Website
troubletype.org
Everytime I used smbmount I added in a username and password in the command itself. It gave me one error, but that error was ignorable, since I was still able to view the shared folder and read content. If you need a reference of commands, use this webpage.
if there is no password/login needed for the windows shared folder (that i know of), do you just specify
smbmount //10.1.0.1/The_Hutch /mnt/winshared -o username= password=
?? because that doesn't work... if i do -o guest, then i still get

97: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

so it must be something with the ip address? my ip address for the gp2x connection is 10.1.0.1, and the ip address for the gp2x itself is 10.1.0.2

EDIT: it seems to work now - i had to put in the domain after my username. however, i still get

124: session request to 10.1.0.1 failed (Called name not present)
124: session request to 10 failed (Called name not present)

after running the command - why does it do this?
 
Last edited by a moderator:
Top