Gp2x Tutorial: Setup Usbnet On Windows Xp 64-bit

HenrikE

Still Fresh
Joined
Jun 18, 2007
Messages
42
(I could only find Linux tutorials, so I'm writing this while I still have it fresh in my head. Also works for normal XP - but see below. Mods: feel free to move the thread if this is not the forum for it.)

First off, a BIG thanks to Dimacus! He told me the "trick" which is basically:

a ) Set your GP2X ip (in its menu) to not conflict with the addresses on your PC network, and
b ) When XP shows your GP2X is connected, set a fixed IP that is also different from PC ip AND the GP2X ip.


Here's what I wanted: Some way of transferring files without having to go into the settings/usb menu all the time, turn it off after copying the file, run the program I compiled, exit, turn on usb in the menu, transfer new enhanced .gpe, ...

(NOTE: The IP range of *your* network might be completely different. Run->cmd->"ipconfig /all" to find your PC's IP and subnet mask. The below IPs are just examples - the important thing is the the GP2X ip and the USBnet connection IP differ from each other, and differ from your PC's ip in _both_ last two numbers of the IP.)

First: Enable USB networking on GP2X:
1. Menu Settings->System->these settings:
- Advanced/Menu Extension: ON
- USB Host: Always on
- USB Network: Always on
- IP: 192.168.10.1 (if your PC's IP is like 192.168.0.139 - never change your PC's ip)
- FTP, Telnet Server: Always on
- Samba Server: Always on (not sure this is necessary)
Button B to save settings. (To change IP numbers, press Y and A buttons.)

2. Plug in/turn on your GP2X. XP asks for a driver.

XP driver link: http://embedded.seattle.intel-research.net...files/linux.inf
Change two words in it to "port it to XP 64-bit" - instructions: http://64.233.183.104/search?q=cache:x2Tf8...mp;client=opera

3. Follow the instructions here to install the driver http://embedded.seattle.intel-research.net...amp;redirect=no

You should get a "hardware is working" popup at the end of the guide.


Second: Configure the network in XP:
(I never recommend to turn firewall and antivirus off, but if you do, they could detect and offer some options automatically if you do.)

1. Start->Network Connections, you should see a second network next to your normal internet connection. It probably says "Acquiring address..." and then fails.

2. Right-click the connection->Properties. Click "Internet Protocol (TCP/IP)" in the small list, Properties...-> Advanced Tab, enter
- IP: 192.168.10.11 (different from both PC and GP2X ip)
- Subnet Mask: 255.255.255.0 (usually default)

Click OK and after a few seconds the status of the connection should change to "Connected".

--- Now, the important thing is to always use the IP in the GP2X menu to access it!

3. Start->Run... "\\192.168.10.1\"

A normal explorer window should open, containing a folder called "gp2x". By putting files in "/gp2x/mnt/sd" or "/gp2x/mnt/nand" you can get your files onto the card without wearing down the GP2X menu ;)


Third: Convince your Firewall and Antivirus that yes, you really want to allow access:
1. In Windows Firewall: Exceptions Tab->Add Port, type "gp2x-ftp", "21", OK. Then "gp2x-telnet", "23", OK.

2. In Windows Firewall, go to Advanced->"gp2x connection"->Settings->Services. I enabled:
- FTP
- telnet
- Web Server (HTTP)

(the last one was to make Kaspersky happy.)


That's it! If step 3. above failed, go Start->Run..."cmd" and type "ping 192.168.10.11" or whatever you chose _in XP_. If you get ping times back, you have a connection.

You should now be able to connect with an ftp client, or get commandline access with Start->Run..."telnet 192.168.0.1 23" (23 is the port we opened), both using username "root" and no password.


It was lovely to finally solve this, now I can press 2 keys and press the B button 3 times to compile and test a program I made. Thanks again to Dimacus for helping me resolve the IP "trick" ! :)

[EDIT: Results of some heavy compiling sessions...]

DEving over USBnet isn't perfect, on occasion it uses an old copy (but only if the previous program didn't return to the menu so GP2X could hold hands with USBnet again) - upload, unplug the USB and plug it in again, and the new version is the latest one. Seems GP2X reads cached network files before storing to / looking at the sd card.

But I'm happy, I can recompile and test in a few seconds, and programs don't hang that often, so it's no real hassle.
 

peelie

Member
Joined
Apr 6, 2007
Messages
887
i can connect to GP2X via telnet but i can't seem to connect via an explorer window?

also still can't connect to the internet from gp2X, any ideas?
 

HenrikE

Still Fresh
Joined
Jun 18, 2007
Messages
42
peelie said:
i can connect to GP2X via telnet but i can't seem to connect via an explorer window?

also still can't connect to the internet from gp2X, any ideas?
Are you doing it with Start->Run..."\\<gp2x's ip>\" ? Is that IP different from the USB network ip and your pc's ip? Internet: is Web server enabled on gp2x and Web enabled for the USB network in the firewall, and is port 80 open?

Parkydr: Heh :) Guess I didn't search for the "right words" then. I might fix it up, but I hesitate a little since I don't have in-depth knowledge on "making a correct doc for anyone", I just wrote the post as a hands-on how I made it work. Actually, it was sheer luck that I even found a 64-bit driver then. :)
 
Last edited by a moderator:

u9i

Call me Uni
Joined
Jun 27, 2008
Messages
761
Age
43
Location
Faroe Islands
Website
riotdigital.com
Henrik Erlandsson said:
First: Enable USB networking on GP2X:
1. Menu Settings->System->these settings:
- Advanced/Menu Extension: ON
- USB Host: Always on
- USB Network: Always on
- IP: 192.168.10.1 (if your PC's IP is like 192.168.0.139 - never change your PC's ip)
- FTP, Telnet Server: Always on
- Samba Server: Always on (not sure this is necessary)
Button B to save settings. (To change IP numbers, press Y and A buttons.)
There are no such options in firmware version 4.0.0. Does anyone know how to proceed, or have GPH completely removed this from the OS?
 
Last edited by a moderator:

Squirrel61

Member
Joined
Aug 23, 2008
Messages
312
Location
The Netherlands
Website
www.psp-flevoland.nl
u9i said:
Henrik Erlandsson said:
First: Enable USB networking on GP2X:
1. Menu Settings->System->these settings:
- Advanced/Menu Extension: ON
- USB Host: Always on
- USB Network: Always on
- IP: 192.168.10.1 (if your PC's IP is like 192.168.0.139 - never change your PC's ip)
- FTP, Telnet Server: Always on
- Samba Server: Always on (not sure this is necessary)
Button B to save settings. (To change IP numbers, press Y and A buttons.)
There are no such options in firmware version 4.0.0. Does anyone know how to proceed, or have GPH completely removed this from the OS?


Yes I would like to know that too, since the F200 isn't downgradable below 4.0.0 and it doesn't include the USB Network drivers. Or at least, if it's still part of the firmware, it isn't accessible through the menu any longer.

[edit] Problem not solved but question answered... In another thread on this forum I read that where the F100 uses a netchip to drive the built-in usb port, the F200 uses a cardreader chip. In other words, where the F100 is capable of setting up an ip over usb connection, the F200 only acts as a cardreader for the built-in sd slot. And a bad one too.
 
Last edited by a moderator:
Top