C compiler cannot create executables

It looks like I now have some time to try again to compile this.

I have tried editing the build script and replacing each "./configure" command with "pndconfigure", but when called from inside the build script, "pndconfigure" is not found. I have added an "echo $PATH" command just before the first call to pndconfigure, and it looks like path is OK:


But pndconfigure is not found. If I call pndconfigure outside the script, it is properly called. If I call pndconfigure from inside the script, it is not found. Maybe something from the environment is not properly inherited in the script?
Thanks Kazuki. I have worked around the pndconfigure problem using ./configure --host="$TARGET_SYS", but I'll try your suggestion if I have more problems with this.

Using this approach I have compiled most of the dependencies: freetype, jpegturbo, nasm, yasm, png, sdl, sdl_image, sdl_ttl and zlib.

Now I'm trying to compile pygame, but it's not working. I have opened a new thread to deal with the problems I find trying to compile Ren'Py from now on.
Last edited by a moderator: