Release C/C++ Development Tools

My new pnd can update itself from the angstrom repo, so if I don't include it, it should be easy to add it.
how is this so? the PND is read only? unless you store the updated files in the appdata folder? but if you ever deleted the app dats folder the pnd would revert to an older version?

im all confused?
Oh yeah sorry - it includes a version of opkg that installs everything into appdata, the pnd remains the same. Although a script that remakes the pnd using the contents of the pnd and the contents of appdata should be feasible. But in my experience, being able to nuke appdata when you screw up is useful too!
Would it be possible to include an mkisofs? Somehow I can't find one in the angstrom repositories (although that's rather improbable - guess I fail at searching).

Also noticed I had to set "-fdollars-in-identifiers" to get some software compiled. Seems that's default on other platforms...
Hello :) it's possible to included a librairy : cmake, pascal(fpc), lua, qt4 and hg

Thank you in advance ;)
Should be great to have all -dev libraries from the git too.
Last edited by a moderator:
Just wanted to report in that I've been using this PND a lot lately, its really great (except for the .cdevrc script, heh heh..) and an easy, nice solution for building things on the Pandora. Since the opkg repo isn't working so great, it sure is nice to have a .PND file rescuing us sinister onboarders!

EDIT: the way I work with this PND is I log into my USB-tethered Pandora first, source a devrc script, and then type 'make'. This works very well with my editor (vim) on my host machine. The .cdevrc is clumsy when you're ssh'ed in to use the .PND ..
Last edited by a moderator:
Just booted this up for the first time in a while and noticed that svn is reporting problems with missing libneon .. wtf is that all about? I thought it was working last time I used it (must be, I have .svn repo's on my Pandora that got there with C/C++ Development Tools.pnd) but it seems something has gotten borked somewhere along the lines ..

EDIT: never mind, this fixed it:

 opkg install libneon25
Last edited by a moderator:
I noticed that a while ago, but forgot to post about it. Thanks for the fix, I'll do that tonight
Hi, I am attempting to compile notaz's improved SDL using only the cdevtoos PND.

./ seems to work

./configure seems to work

./make fails at building SDL_x11dga.o when looking for "X11/extensions/XShm.h": No such file or directory

This XShm.h file is not at:




Any ideas? Thanks!

EDIT: Okay I worked around it with:

opkg update

opkg install libxext-dev

So it put the files in /usr/include/X11/extensions/ on NAND

I still wouldn't mind this being in the PND though, Thanks!
Last edited by a moderator:
Hey freamon, I don't know if you're watching this thread, but hopefully you are.

Any chance we could get SDL_gfx included in this PND in a future release?
I don't think he hangs around here anymore. His user profile says last active back in September :(