Bricked Gp2x?


Still Fresh
May 26, 2008
Hello there,

I'm new to this forum; often been a reader but have not up until now participated. I was wondering if anyone would be kind enough to offer me some advice on my seemingly broken GP2X, any help would be much appreciated. I've looked all over the FAQs and forum and can't seem to find a problem quite like mine.

Basically, my GP2X worked fine before I'd moved; I'd put a couple of games on the NAND when I first got it as my SD card didn't work, but I ordered a new SD card and everything worked perfectly after that as I simply put all of my games on the card. I didn't do any silly things in the NAND (the unit was firmware 2.0.0 from new) and everything went very smoothly for about six months.

I then moved so it was placed in a box, and being as busy as I am it wasn't taken out of said box for another few months. Anyway, when I unpacked it I charged up some batteries, tried to use it and it wouldn't turn made a faint clicking sound like it was strugling to power up and the screen was alternately black and wavey lines or alternately black and white, in time with the clicks. I assumed it was the batteries as I'd seen this before when I had low bought some new ones, to no avail. I then bought a new charger for my batteries, which also hasn't worked.

I'm really confused; all the unbricking guides seem to point to having a solid white screen or solid wavey lines, and my screen blinks. Just to be sure, I am using 2700mAh batteries and the green power light stays constantly when it is turned on and the screen starts doing its flashing act. I'm also confused as I haven't done anything stupid to it that I can remember...I'm not particularly technical and definitely steered clear of doing things in the NAND and root files, apart from when I loaded a couple of games there when I first got it, which as stated before seemed to be completely benign.

If anyone could help, I would be really grateful.


If it's less than 12 months old, I'll return it to whoever you bought it from as it sounds like the move has loosened a component. If you move it around do you hear anything rattling around?
No, it doesn't seem to rattle, no more than you'd expect from the build quality and buttons...

I'm going to try a PSU tomorrow, one from Argos as recommended by the wiki.

Oh, and thanks for the idea, but I think it's over twelve months old so there's not much chance of returning it.

Is there anywhere I can send it for repairs?
Try a new PSU, and if that doesn't work, then I'd get in touch with EvilDragon and/or Craigix and ask who's willing to repair them at the moment.