Bluetooth connecting but devices not working


Still Fresh
Dec 28, 2012
Hi. I have recently received a 1Ghz pandora and I am trying to get bluetooth to work. I have successfully connected via bluetooth through the XFCE desktop to both a headset and keyboard. Yet when I try to use either device nothing happens. I have Angstrom 1.52 Super Zaxxon and the headset is a Phillips SHB9100 Headset and the keyboard is a standard Australian Kmart bluetooth keyboard.

Can anyone help me with this issue?

Also does bluetooth work in Android on the Pandora? I have installed the latest version of Android and it doesn't allow me to activate bluetooth.



I  Have The similar Issue Any one Help me How to solve that The problem
Last edited by a moderator:
Do a search on the forum for "a2dp" and read all the relevant threads about Bluetooth and audio but basically unless things have changed in the most recent firmware of zaxxon, then the audio situation is still this

To enable Bluetooth you must modify the asound.rc file in your home directory with a few lines to add Bluetooth as a system recognised audio parameter and save that version of the file under a new name. You then must manually switch to that version of the file when you wish to use Bluetooth audio speakers (headsets don't seem to work yet).  The limitations I mentioned in the link remain though.

Your keyboard should be useable though. So that needs looking into.  There maybe info on the wiki or via researching for Bluetooth threads.  I lack my Pandora at present to be more detailed.  

Hope that's some minor help and good luck :)   Yars the next OS May well correct the audio issues.
Last edited by a moderator:
Yeah the bluetooth support (GUI mostly) in the OS is a bit minimal / "bluez is there, configure the rest yourself".

I'm not sure about whether the keyboard should even work with our bt applet. but you should be able to do sudo hidd --search (whilst pressing connect on your keyboard - and note that sudo will ask your password) to connect the keyboard.
Hi psigh,

I've got the same setup (1GHZ Pandy, SHB9100).

Summary: it works, but only with GNOME Mplayer.


Long version:

I did this:

Step 0: Paired your devices and then...

[[[A detailed version of Step 1-3:]]]

Step 1: Make sure your .asoundrcDEF and .asoundrcBT work correctly. Rename .asoundrcDEF to .asoundrc1 and .asoundrcBT to .asoundrc2

Step 2: Rename the file of your choice to .asoundrc (whichever you choose will be active first)

Step 3: Paste the following into mousepad and save it as in your home folder(EDIT- by home folder, I mean the one with your username. ex: /home/edgex004 for me):

#!/bin/bash if [ -f .asoundrc1 ] then rename .asoundrc .asoundrc2 .asoundrc rename .asoundrc1 .asoundrc .asoundrc1 notify-send "Digital Output" else rename .asoundrc .asoundrc1 .asoundrc rename .asoundrc2 .asoundrc .asoundrc2 notify-send "Bluetooth" fi

Step 4: Open a terminal in you home folder and enter the following commands:

chmod ugo+rwx

chmod +x

sudo cp /usr/bin/btswitch

Make sure to type in your password when sudo requests it.

This should create a switch command in the terminal that can be run by just typing 'btswitch' and pressing enter.

Step 5: In the xfce menu, navigate to settings->keyboard.

Switch to the 'Application Shortcuts' tab. Click add. In the command box enter:


Click 'Ok' and then press the key combo you desire at the next window. I pressed <Control><Alt>comma as it is easy to reach.

Step 6: Test it out! You should get a popup which either says 'Bluetooth' or 'Digital Output' depending on whichever is being turned on. If something doesn't work, just let me know and I'll try to figure out what's going wrong.

I understand that my script could break at some point as I don't have any double-checking written into it, but it works for me and hasn't screwed me up so far.

Lots of credit for this goes to SomeGuy99 as I took my shortcut creation method directly from his screenshot guide.


Note: I "mapped" the btswitsch script to CTRL+A


1. You have to switch on the BT Output BEFORE you start the player. [Check the notifier]

2. The only player that worked was GNOME MPlayer: Quite buggy. Not able to close via GUI [Terminal: killall mplayer worked..]

3. Players I tested but didn't work:

    - Panplayer

    - VLC Player

    - SMPlayer 2

    - Rockbox

    - DeaDBeef

4.VLC Player/SMPlayer 2/DeaDBeef are mysterious because in the preferences/audio output you can make a hell of driver setting (ALSA, OSS...). Even if you have the SAME settings than in GNOME MPlayer there are no headphone tunes...

...or is the whole thing a A2DP problem? Anyone with updates/new ideas?
Last edited by a moderator: