Ahh Gigas Problem!!


Octavious

Programer Guru! ...in the making
Joined
Feb 2, 2004
Messages
1,795
Location
USA
Website
www.retroportables.4x2.net
Bear with me people for this is long

woah
I had gone through a lot of stuff and made a very nice almost complete demo of my version of my Diablo like games town, i will go through everything untill now to tell you what happened

First of all, I got tired of editing your demo, and I have learned what I believe to be everything about this engine that can be used
SO, I went to your website and got the blank game set, made a folder for the project on my 32 ( its called Diablo32 , no one take that name damnit , took me a while to get that good name ) and slapped everything in it onto my 32 in that folder
Then I took a tile set .raw file I made with my completley custom tileset ( that took a while too ) and through on your chars file with a few of my own people also. I now know I also forgot the scfx and level up animations and the attack animations, but that shouldnt matter, right?
anyways, I started up the 32 and entered the folder and opened Diablo32 for the first time
It made the default tile, every damn tile on the map, the very first tile from the set, but they were as if they were a solid... so I went to edit mode , and it didnt show anytiles anywhere where there were the first tile. This leads me to believe that the first tile in the set is the " no tile-tile " , you should put that in the next readme, I thought it was just another empty space
ANYWAYS...
I shrunk the map to 85 by 60 and filled every layer 0 tile with my grass tile that looks good
took a while on the 32.... then I proceded to add my first building, the lumber yard, some stumps, and a few scary looking trees. also had a few differant wood piles and the such
so far so good, Worked a charm when I played in the game mode every now and then. Then I went and change a good sized chunk of layer 0's into a farm land themed tiles. I then put a layer 1 fence around the farm, and made it solid also. Then I made a large farm house with a store house and some other junk. added a few layer 1 scarecrows and barrels. Then I saved the map. I then put down a layer one river to the farthest right side of the screen and layer when I tried..well, Ill get to that. I then added a Player and 4 Dogs ( made a dog charecter , so cool ) to wander around and give them " farm town " feel. everything worked in play mode. I then saved, took a break powering down the 32 and gettin some pizza and Jo-jo's. Back to the 32 half an hour later, I started up the 32 , gigas , diablo32 , and started editing
extended the screen to 90 instead of 85 and filled in the tiles with a layer 0 grass. covered over the river, but it seems that some places where the river was, It is a solid and I cant undo that?So I finish up my store house and farm house buildings. I have not done any interior work, so nothing is on the inside ( hence other maps, triggers, so on and ther was none of this ) I then added another dog and saved and exited.

NOW THE HORROR!!! ahhhhh

I came back later ( spent about 5 hours almost in a row doing the above , but they on fresh new TITANIUM BATTERIES ( oo, aaa, titanium ) still plenty of juice left, so I know the problem is not batteries, but I put in fresh ones anyway
SO..
I went to gigas, went to play diablo32 ( figured Id play and see what is still needed for a town. and I got a bios error!!! AHHH ( RUNING MFW2 ) what is up with this shit? I restart, go to edit, same damn thing. AHHH! I restart and try another program ( fsms ) and it works , try osnes9x just for the hell of it , and it works also. then I try the demo folder game and , son of a bitch, it works. edit and play. So then I try like 9 more times and keep gettin errors. This morning, I tried each again, and now it gets strange. Play still gives me an error. but, when I hit edit, It gets just as far as play in the intitialsing screen and a forth through loading, but when I used to get a bios error, I get some warning saying that there is a layer problem , it cant find a layer or load it press b to contiue , and then it goes to the error when I hit B

as of 20 minutes from typing this message ( as in ago ) It dosnt give me that warning everytime I got through edit , just some times
please help
did a smc repair via pacrom and still same results ( found no errors on card )

so, please help.
I spent a lot of time on this map and I dont want to lose It
also, please make sure this happens to no one else, cause it really blows

thx

~Octavious
 
A

Aaaaaaaa

Guest
I also got this error on one of my maps. the rest worked, but theat one map, died.
 

Pirotic

Certified Guru
Joined
Feb 16, 2004
Messages
593
hmmm, so in short

everything worked fine, then you resized the map and saved it - and then upon rebooting and reloading its erroring on you?

if anybody else has had this problem, can you also explain how it occured, it sounds like it may be something to do with the map resizing.

i'll have to look into that, but all isnt lost tho - if possible zip up your game folder on your SMC and e-mail it to me (gigas at pirotic dot com) andi 'll see whats happened.

so long as you have the files "M<number>L<0 to 2>.DAT" your map is saved, its possible that its just the map settings file which is currupted somehow

i'll look into this ASAP

thanks for the heads up

Pirotic
 

Pirotic

Certified Guru
Joined
Feb 16, 2004
Messages
593
fixed the bug i think, if anybody has any currupt maps on their SMC's still and fancy testing out the new version to see if it fix's the bug, MSN me please

my MSN is

pirotic at pirotic dot com

i replicated the bug in 0.6.5, and then the maps loaded fine in 0.6.6 - just need to test it out with somebody else then i'll update the download to 0.6.6
 
Top