Workaround found: Can't Install OS to SD card: "Error: Timeout waiting for device special files"


Still Fresh
Feb 16, 2013
Decided to pull my Pandora out of mothballs last night and it was running just sorta janky after updating the OS. No problem, I can just do a quick clean install on an empty SD card.

Unfortunately after running Pandora SD installer I get the message "Error: Timeout waiting for device special files (fdisk may have failed)" every time.

It does not matter what SD card slots I use or what SD cards I use.

I also tried installing to NAND but the "boot from SD1" option does not appear in the boot menu.

Soo...yeah. That's where I'm at. Any help is welcome.

Workaround found: Flashing the NAND to SuperZaxxon version 161 allowed the SD Install .pnd to work fine. The NAND must not be upgraded. This may only be a problem with Gigahertz editions.
Last edited:
Yes. The error still pops up with the installer and the option to boot off SD1 does not appear in the R-button boot menu.

I have tried half a dozen different SD cards including cards that formerly worked fine with the Pandora.

I also tried the online installation process in the wiki but the link is broken.

ETA Oh and the NAND has been upgraded to 1.75/4 but as you can see, it's a bit glitchy.
Last edited:
For the 'boot off SD1' option to appear the SD card must at least contain a file called 'boot.scr' in the root which is got when you unpack a release zip file, if you're trying to reflash the NAND. Have you got that file on there?
OK I was able to find the right combination of media/luck to flash the NAND and do a clean install but I'm still getting the same timeout error when trying to use the GUI-based installation system.

These are with the same physical SD cards that were working fine before.

Thanks, by the way, my problem was that I didn't extract all the files correctly before.
OK I've now tried about every SD and MicroSD card I have and both the built-in SD Install program as well as current and legacy .pnd versions with both versions of SuperZaxxon 1.75 flashed to NAND as well as earlier versions going back to 1.55 and every single one generates the same error:

"Error: Timeout waiting for device special files (fdisk may have failed)"

If I tell it to create a swap partition it will create the partition then crash with the error leaving the rest of the SD card unallocated. If I tell it not to create a swap partition it will crash and not change the existing partition on the card at all.
@Axman: it could also be the card reader: try cleaning it with a queue tip/blowing in it. What sizes are your SD cards? did you try different sizes?
I've tried both SD card slots to the same effect. The cards read and write correctly in both slots for other programs/functions.

SD/Micro SD cards used include 2, 6, 8, 32, and 64 gig cards, including confirmed compatible cards. Like I said, they worked before; I previously successfully installed the OS on these exact cards before.

Thanks for the continued brainstorming, though, it really helps.
Please forgive me for being slow, but what does the 'create SD installer' option actually do? I've never used it - I've always created both bootable and flashable cards manually using other machines I control.

Since you've found a set of cards that work to reflash the unit, do you actually need anything else? I suppose it's still easily worth knowing if an option supplied as part of the OS doesn't work though.

And since the error mentions fdisk, have you tried running fdisk yourself? You can start it from a terminal; bring one up using the main menu in XFCE, then type 'sudo fdisk /dev/mmcblk0p1' (or maybe p0). Once you've entered your user password, it'll print some basic information about the card identified, like it's capacity, then dump you at a prompt. Enter 'p' and it'll print out the partitions on the card. Enter 'q' and it'll quit the command, and won't have actually modified the card at all unless you told it to write out changes at any time.

It may be worth mentioning that on my system at least, running fdisk on my mounted pnd card comes up with an error line containing something about 'sector 4' (IIRC), and then produced an empty partition table when asked for one. I could try unmounting it but I have pnds mounted and running in the background (mainly my music player), so that would be a little more involved, and I had only intended to check the commands so I could write this post.
The app automates the creation of a bootable SD card. I have tried the manual method

I cannot complete the process because the keyboard won't produce an underscore. That's why I need the SD Installer pnd to work:

Edit: Just found this, gonna give it a shot:

Edit 2: Downgrading the NAND to 161 allows the SD Install program work normally.
Not problem solved, but work-around found.
Last edited: