Ur-quan Masters


Still Fresh
Jun 18, 2007
I have a GP2X Value pack. This comes with Firmware 3.0.0 which includes libSDL-1.2.so.0.7.0

I'm having trouble getting The Ur-Quan Masters to work, game boots to the menu, then doesn't respond to controls.

I have seen some other people having the same problem description in this forum, so in response to those comments I have tried the following...
Installing the SDLlibs from http://archive.gp2x.de/cgi-bin/cfiles.cgi?0,0,0,0,31,869 didn't work.
I originally had it installed in /mnt/sd/Games/uqm changing this to /mnt/sd/games/uqm didn't work.
Renaming uqm-0.5.0-content.uqm to content.uqm didn't work.

Here is the console output while running the game... nothing obviously wrong here... other than possibly the SDL version missmatch "Using SDL version 1.2.9 (compiled with 1.2.7)"

Any comments appreciated

[root@gp2x root]$cd /mnt/sd/games/uqm
[root@gp2x uqm]$./uqm.gpe
The Ur-Quan Masters v0.5.0 (compiled Nov 25 2006 19:29:13)
This software comes with ABSOLUTELY NO WARRANTY;
for details see the included 'COPYING' file.

Initializing base SDL functionality.
Using SDL version 1.2.9 (compiled with 1.2.7)
SDL_GP2X: CreateDevice
SDL_GP2X: VideoInit
SDL_GP2X: Physical screen = 320x240 (ilace = 0)
SDL_GP2X: Creating cursor 16x16
SDL_GP2X: Allocated WMcursor @ 0x4ae820 (32)
SDL_GP2X: SurfaceManager allocating 256 bytes
Warning: There's no 'packages/addons' directory in the 'content' directory;
'--addon' options are ignored.
Initializing Pure-SDL graphics.
SDL driver used: GP2X
SDL initialized.
Initializing Screen.
SDL_GP2X: ListModes
SDL_GP2X: ListModes
SDL_GP2X: ListModes
SDL_GP2X: Setting video mode 320x240 16 bpp, flags=90000000
SDL_GP2X: FreeHWSurfaces
SDL_GP2X: InitHWSurfaces 0x40025800, 5085184
SDL_GP2X: Screen bucket 0x4addc4
SDL_GP2X: First free bucket 0x5fe9d8 (size = 5085184)
SDL_GP2X: Creating cursor 16x16
SDL_GP2X: Allocated WMcursor @ 0x5fe9f0 (32)
SDL_GP2X: SurfaceManager allocating 256 bytes
SDL_GP2X: SurfaceManager adding new free bucket of 5084928 bytes @ 0x5fea08
SDL_GP2X: SurfaceManager allocated 256 bytes at 0x40025800
Set the resolution to: 320x240x32
1 joysticks were found.
The names of the joysticks are:
VControl opened joystick: PEP Joy
0 axes, 19 buttons, 0 hats.
Initializing SDL audio subsystem.
SDL audio subsystem initialized.
Opening SDL audio device.
using dsp at 44100 Hz 16 bit stereo, 256 samples audio buffer
Initializing mixer.
Mixer initialized.
Initializing sound decoders.
Sound decoders initialized.
'starcon.lst' -- 12386 bytes
'lbm/scclrtab.ct' -- 104466 bytes
We've loaded the Kernel
VideoDecoder_Load: Unknown file type
'lbm/title.ani' -- 20 bytes
'arilou.lst' -- 315 bytes
'arilou/ariicons.ani' -- 50 bytes
<---snip more "'arilou/aritext.txt' -- 407 bytes" type statements ---->
'lbm/menusnd.snd' -- 56 bytes
_GetSoundBankData(): loading lbm/menusnd01.wav
_GetSoundBankData(): loading lbm/menusnd02.wav
_GetSoundBankData(): loading lbm/menusnd03.wav
_GetSoundBankData(): loading lbm/menusnd04.wav
'lbm/stars.ani' -- 60 bytes
<---snip more "'lbm/astbig.ani' -- 492 bytes" type statements ---->
'lbm/boosml.ani' -- 194 bytes
Warning: Can't open 'lbm/mainmenu.ogg' <--- This file I deleted on purpose to make the menu quiet
'lbm/newgame.ani' -- 177 bytes
Warning: Can't open 'lbm/mainmenu.ogg'
'lbm/newgame.ani' -- 177 bytes
<--- This is where I hit ^C on the console to exit the game because I can't select anything in the menu --->
SDL_GP2X: Freeing cursor 0x5fe9f0
SDL_GP2X: SurfaceManager freeing 256 bytes @ 0x40025800 from bucket 0x5fe9d8
SDL_GP2X: merging with next bucket (0x5fea08) making 5085184 bytes
SDL_GP2X: VideoQuit
SDL_GP2X: FreeHWSurfaces
SDL_GP2X: Freeing bucket 0x5fe9d8 (size 5085184)
SDL_GP2X: FreeHWSurface 0x4adee0
SDL_GP2X: SurfaceManager freeing 153600 bytes @ 0x40000000 from bucket 0x4addc4
SDL_GP2X: DeleteDevice

[root@gp2x uqm]$
at first i thought that i had this problem...the menu responds but it's just hard to see because the highlighted color is very similar to the regular one, and pulses slowly. you may already have noticed that but i wanted to make sure.
I had the same problem but didn't have the patience to figure it out, so I deleted it. Seems like a cool game though, if you figure it out let me know.
it's downright awesome. if you've ever played solar winds for dos, you know what you're in for.

be advised that there are two ports (according to the wiki), the older one is harder to install and much less complete. here's the one you want, i believe that it has all of the data files included:


read the readme: i believe it has to be installed to /mnt/sd/games/uqm

now: if you're getting to the loading screen, it should be ok. look very carefully at the options before you decide that it's locked, because the highlight effect for the selected option is very subtle.

that said, i am going to run my copy from telnet and see if i get the same messages.
ok, just checked an my sdl output is, line for line, the same as mogs's, except for the snipped out parts obviously. sdl mismatch and all.

if i wait at the menu long enough i get a few more lines since the credits start rolling and there's more resources to be loaded.

for what it's worth, i'm loading with gmenu2x and clock speed 200mhz. i'm hitting "A" on the gp2x to select menu options.

apparently there is a voice file that you can add in, i think i'm going to do that asap.
Thanks for the comments so far.

It's definitely not responding when in the menu, no amount of pressing the buttons will make the game proceed past the menu.

And as rokdcasbah pointed out it will start to roll the credits if I wait another minute or so on this screen.

I have tried launching by browsing from gmenu2x, but not from a script. I can't imagine this will make any difference, but I'll give it a try.
have you tried reinstalling it? or formatting your sd card and then reinstalling it? there could be some weird corruption going on either with the download or the disk. you could try replacing just the main content file first.
rokdcasbah said:
have you tried reinstalling it?
Nice one, deleting the uqm folder and replacing it from a fresh download fixed it. Thanks.
Last edited by a moderator: